apt-get install python3-numpy doesn't install numpy on python3, but installed on python2.7

I'm trying to install numpy for python3, and I used sudo apt-get install python3-numpy to install numpy as I use Jetson tx2.

Although the installation is successful, but numpy is installed on python2.7 not python3. How can I solve it?

Actually when you flash your Jetson TX2 with Jetpack (version), numpy package is present for Python2 by default and not for Python3. In order to install numpy for Python3 Please follow the steps given below:- 1. Check if you have pip3 installed for Python3. If not install pip3. sudo apt install python3-pip 2. Then using pip3 install numpy pip3 install numpy After installation check the location: /usr/local/lib/python3.6/dist-packages you will find numpy installed for Python3 Hope this helps!

Install numpy on Ubuntu 18.04 Bionic Beaver Linux, Using the appropriate PIP python version installed on your system execute the following pip3 command to install the python Numpy module: I have flashed my TX2 successfully with the latest JetPack. When I try to install numpy for python3 (default on the TX2 is python 3.5), I run into problems. It doesn’t matter if I use apt or pip3, I suspect the underlying problem is the same. Variation 1: Install via apt $ sudo apt install python3-numpy

I think this is because your default interpreter is Py v2.7 Check this by runnin in console:

python -V

Then you can specify Py3 installation as was commented above:

pip3 install numpy

Note: Do not run this command with sudo because it will run setup.py with sudo or

in other words - an arbitraty upload a malicious project on PyPI this is a hight risk action.

apt-get install python3-numpy doesn't install numpy on python3, but , Actually when you flash your Jetson TX2 with Jetpack (version), numpy package is present for Python2 by default and not for Python3. In order� Mac doesn’t have a preinstalled package manager, but there are a couple of popular package managers you can install. For Python 3.5 with Macports , execute this command in a terminal: sudo port install py35 - numpy py35 - scipy py35 - matplotlib py35 - ipython + notebook py35 - pandas py35 - sympy py35 - nose

You can try using the python3 package manager :

pip3 install --user numpy

Install NumPy, SciPy, Matplotlib and OpenCV for Python 3 on , 1 sudo apt install python3-venv python3-pip python3-tk this will be installed separately and won't mess up your default Python version:. Tried -> sudo apt-get install --reinstall python-lockfile – ZodEnIX Oct 9 '14 at 11:47 The answer here apparently applies to later releases and has been helping people with them , so this appears not to be EoL-specific after all.

How to Install NumPy {Windows, Linux and MacOS}, pip is the simplest way to download packages directly from PyPI from your command line. Moving on with this Install NumPy in Python article� It doesn't appear to be possible using only apt-get. apt-file find jupyter ## returns no results For 16.04: sudo apt-get install python-pip pip install --upgrade pip ## secret sauce -- pip fails otherwise sudo pip install jupyter then. jupyter notebook

How To Install NumPy In Python | NumPy Installation, python3 --version. If you are using Ubuntu 16.10 or newer, then you can easily install Python 3.6 with the following commands: $ sudo apt-get update $ sudo� sudo apt-get update. after that again install the numpy library using : sudo apt-get install python3-numpy. after that your “import numpy” will work…..

Installing Python 3 on Linux — The Hitchhiker's Guide to Python, sudo apt-get install -y python3-numpy. Copy. Step 3. Check the system logs to confirm that there are no related errors. You can use ZoomAdmin to check the� apt-get install libpython2.7 Because clearly the system doesn't have the python header files (apt-get install python-dev), otherwise they'd also have libpython.

Comments
  • How did you determine that it was installed in python 2.7 and not in 3?
  • There is no way python3-numpy will install anything for Python 2. Voting to close as unreproducible.
  • because numpy is imported successful on python2.7, but not on python3 @MatiasValdenegro
  • Are you using the same python interpreter as the python3-numpy package? Can you give a link to the actual package you installed?
  • Again, bad advice to run pip with sudo.
  • @MatiasValdenegro, this is true, thanks. I corrected an answer.
  • This is very bad advice, do not run pip using sudo.
  • @MatiasValdenegro Good observation, I corrected my answer