You are running version v8.9.3 of Node.js, which is not supported by Angular CLI 8.0+

My current angular version is '^7.1.4' and I want to continue with same version. but while doing ng serve I am getting below error.

You are running version v8.9.3 of Node.js, which is not supported by Angular CLI 8.0+. The official Node.js version that is supported is 10.9 or greater.

Please visit https://nodejs.org/en/ to find instructions on how to update Node.js.

Node version : v8.9.3 NPM Version : 6.4.1

thanks in advance

Looks like your global CLI version got upgraded to 8. To downgrade to 7 try this:

 ng --version
 npm uninstall -g @angular/cli
 npm cache clean --force

 npm install -g @angular/cli@7.1.4
 ng --version

ng serve not working when install latest version of angular cli � Issue , ng serve not working when install latest version of angular cli #4895. Closed At first running NG Serve produced a request to modify the cli json file: "To migrate Make sure you have the latest version of node.js and npm installed. npm ERR! Please include the following file with any support request: First, Angular doesn't run on NodeJS. The Angular CLI does. Second, the solution is in the question: use NVM to install several versions of Node, and use the appropriate one based on what you're doing: 10.x for your Angular CLI tools, and 8.x to run your NodeJS backend.

It seems that you might have upgraded your angular/cli to latest, downgrade it to version 7.1.4. Run these commands -

npm uninstall -g @angular/cli
npm cache clean --force    
npm install -g @angular/cli@7.1.4 

Angular CLI 1.7.4 does not support NodeJS 10 � Issue #10527 , Versions Node 10.0.0 NPM 6.0.0 Windows 10 Repro steps Install the latest NodeJS 10, the latest NPM 6 with Angular 1.7.4 Observed behavior When trying to run ng serve on an angular 1.7.4 project it fails because Angular CLI 1.7.4 does not support NodeJS 10 #10527 opened this issue on Apr 29, 2018 � 8 comments. Update Now! Node.js 8 is Not Supported from 2020. Last updated: Oct 02, 2019 Node 8 won’t get any more updates from 2020. In this article, we’ll discuss how and why you should move to newer, feature-packed, still supported versions.

You can use nvm for a different angular project you can switch your node version as your requirement, here I attach a link to install nvm. https://itnext.io/nvm-the-easiest-way-to-switch-node-js-environments-on-your-machine-in-a-flash-17babb7d5f1b

You are running version v6.14.4 of Node.js, which is not supported , js, which is not supported by Angular CLI v6. The official Node.js version that is supported is 8.9 and greater." For building Angular 6 applications the host needs at� 🐞 Bug report Command (mark with an x) new build serve test e2e generate add update lint xi18n run config help version doc Is this a regression? I'm not sure if there is an issue with Angular versions prior to 9.

Update Now! Node.js 8 is Not Supported from 2020, Node 8 won't get any more updates from 2020. In this article, we'll discuss how and why you should move to newer, Building Complex Apps with Angular Node 8 might not be compatible with the V8 / NAN version in later @nodejs or from a package manager, make sure that when you run which node� You have to adjust the version of angular-cli in your package.json file. There should be an entry for the angular-cli. Take a look at the following image. Under devDependenciesyou can see @angular/cli with the version. Change this version and invoke again npm install. The package.json is located in the root directory of you angular project.

How can I install @angular/cli on ubuntu 16.04 LTS?, You are running version v0.10.48 of Node.js, which is not supported It looks like Angular CLI is picking up the older version of Node.js. ok, nvm install v8. 11.3 Then ng -v Angular CLI: 6.0.8 Node: 8.11.3 OS: linux x64 Angular: . To upgrade to latest version (and not current stable) version, you can use: Dismiss Join GitHub today. GitHub is home to over 50 million developers working together to host and review code, manage projects, and build software together.

@angular/cli, @angular/cli. 10.0.4 • Public • Published 7 days ago. Readme � ExploreBETA � 20 Dependencies � 312Dependents � 379Versions� Contribute to angular/angular-cli development by creating an account on GitHub. Version 10.13.0 was the first version of 10.x that was considered LTS. This also provides an improved performance baseline as well as access to newer Node.js APIs and Javascript language features

Comments
  • Did you upgrade angular/cli? What's the version number in package.json? Did you recently initiate an Angular 8 project?
  • update.angular.io - Follow this
  • I'm using nvm and have this exact problem. "ng -v" always shows the wrong version of node.js being used, even though I'm using nvm, and I've run "nvm use 10.16.0" to use v10.16 of node.js.