Unable to uninstall bundler 1.17.3

My current bundler version appears to be 1.17.3. I actually need 1.17.2 for my latest work, but I am unable to uninstall 1.17.3.

If I run gem uninstall bundler the command exits with no output. The command gem info bundler always shows version 1.17.3.

$ gem uninstall bundler
$ gem info bundler

*** LOCAL GEMS ***
... yada yada yada ...
bundler (1.17.3)
    Installed at (default): /Users/disaacs/.rvm/rubies/ruby-2.5.3/lib/ruby/gems/2.5.0

If I install the bundler version I need, I get both versions installed, but the 1.17.3 version runs by default.

$ gem install bundler -v 1.17.2
Fetching bundler-1.17.2.gem
Successfully installed bundler-1.17.2
Parsing documentation for bundler-1.17.2
Installing ri documentation for bundler-1.17.2
Done installing documentation for bundler after 3 seconds
1 gem installed
$ gem info bundler

*** LOCAL GEMS ***
... yada yada yada ...    
bundler (1.17.3, 1.17.2)
    Installed at (1.17.3, default): /Users/disaacs/.rvm/rubies/ruby-2.5.3/lib/ruby/gems/2.5.0
                 (1.17.2): /Users/disaacs/.rvm/gems/ruby-2.5.3

    The best way to manage your application's dependencies
$ bundle --version
Bundler version 1.17.3

Any suggestions about how I can get rid of bundler 1.17.3?

My environment is a MacBook running 10.14.5 (Mojave), with ruby 2.5.3 installed via rvm.

$ rvm list
=* ruby-2.5.3 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

It appears that RubyGems 3.0.4 includes bundler 1.17.3, and this was overriding any earlier version of bundler I tried to install. I fixed the issue by downgrading my RubyGems to version 2.7.6.

$ gem update --system 2.7.6

bundler version 2.0.1 fails to run · Issue #6882 · rubygems/bundler , bundle --version Bundler version 1.17.3 $ bundle exec bundler: exec needs a command to run $ sudo gem uninstall bundler --quiet --silent  $ bundle --version Bundler version 1.17.3 $ bundle exec bundler: exec needs a command to run $ sudo gem uninstall bundler --quiet --silent $ sudo gem list | grep bundler $ sudo gem install bundler Fetching: bundler-2.0.1.gem (100%) Successfully installed bundler-2.0.1 1 gem installed $ bundle --version Traceback (most recent call last): 2: from

had same issue, use below process to uninstall it

1. $ rvm gemset use global
2. $ sudo gem uninstall bundler -v 1.17.3
3. $ gem install bundler -v 1.17.2

Default bundler version for ruby 2.6.x installations · Issue #2842 , Invoking gem uninstall bundler --version 1.17.2 doesn't seem to be able to uninstall the bundler provided by ruby 2.6.x, so at this point I need to  In any case to install a particular version of bundler use the following command. # gem install bundler --version '1.17.3' --user-install. I had to delete gemfile.lock, restart the application and then run bundle install before it would all work.

In short, try navigate to a location except where your rails project is, and run gem uninstall bundler again.

MacOS 10.15.2, Ruby 2.6.5 and RubyGems 3.0.3

I was trying to uninstall bundler 2.1.4, and my default bundler is 1.17.2

$ gem list | grep "bundle"
bundler (2.1.4, default: 1.17.2)

And I tried

$ gem uninstall bundler -v 2.1.4
Gem 'bundler' is not installed

And also

$ gem uninstall bundler

just output nothing.

And finally I cd to another folder and run uninstall again and it worked.

Trouble uninstalling gem bundler, I cannot uninstall 1.17.3 to use 1.12.5. Part of the problem is the gem uninstall bundler doesn't seem to be working - you still see it when do  If bundler 1.17.3 is installed startup will fail. $./msfconsole [*] Metasploit requires the Bundler gem to be installed $ gem install bundler Solution is gem uninstall bundler -v 1.17.3.

How to Upgrade to Bundler 2, Before you upgrade to Bundler 2, make sure you have the right Ruby and When a Gemfile has been created by Bundler 2, or manually upgraded by a Remove support for deprecated versions of Ruby (< 2.3); Remove support for  gem install bundler -v 1.17.3 # Currently the latest bundler version < 2.0 bundle _1.17.3_ install Alternatively, you can also remove bundler 2.x completely and only use Bundler 1.x: gem uninstall bundler -v ">= 2.0" gem install bundler -v "< 2.0" # Now you can use bundler as before bundle install

Bundler 2.0.1 installed, Rails says "must use Bundler 2 or greater"?, bundler versions gem "bundler" cannot be uninstalled because it is a default gem update --bundler to 1.17 3 can't find gem bundler (>= 0.a) with executable  I currently recommend uninstalling bundler 2 locally and updating your Gemfile.lock to show that the BUNDLE WITH is 1.17.3: BUNDLED WITH 1.17.3 This error is due to the rubygems/bundler integration, an issue is here rubygems/rubygems#2592.

How to downgrade bundler or upgrade rails?, update --bundler to 1.17 3 you may need to uninstall or upgrade bundler gem uninstall bundler gem install bundler --version '1.0.0' upgrade your bundler There are some problem when we are trying to uninstall global bundler version. It is dangerous to remove default gem, Unable to uninstall bundler 1.17.3. 0. Can't use a gem because json 2.1.0 is activated, but the gem requires 1.8.6. 3.

  • Have you tried gem install --default -v1.17.2 bundler? Also, when you run which gem and which bundler do they show the rvm shim paths?
  • After running gem install -default -v 1.17.2 bundler I now have 2 default versions of bundler installed, and I can't uninstall either of them :( Also, the 1.17.3 version is still taking precedence.
  • which gem returns ~/.rvm/rubies/ruby-2.5.3/bin/gem, which bundle returns ~/.rvm/gems/ruby-2.5.3/bin/bundle
  • I ran into something similar a few months back. I ended up deleting the default version following instructions here, then re-installing with the --default flag again (only the one I wanted)
  • I tried that and it doesn't work for me. It still won't uninstall the 1.17.3 bundler (though 1.17.3 is not longer marked as default). I was able to install 1.17.2 as default, but when I run bundler I am still getting version 1.17.3.