Eclipse showing "Maven Configuration Problem: Unknown"

eclipse display view missing
eclipse showing false errors
eclipse shows error on project but there is none
eclipse shows error but no error
show error window in eclipse
compilation error not showing in eclipse
eclipse not show errors
eclipse shows errors but compiles java

I just imported a spingboot project that I created in https://start.spring.io/ in eclipse. I tried to import two times, but the problem persists. Already tried to do a mvn update , a mvn clean install, tried to clean the project but none of this worked. Its a problem in the first line of pom xml file. I dont have any idea how to solve this. I'm using java 11

This is the complete POM file:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
    <groupId>org.springframework.boot</groupId>
    <artifactId>spring-boot-starter-parent</artifactId>
    <version>2.1.5.RELEASE</version>
    <relativePath/> <!-- lookup parent from repository -->
</parent>
<groupId>com.in28minutes.springboot.rest.example</groupId>
<artifactId>spring-boot-2-jpa-with-hibernate-and-h2</artifactId>
<version>0.0.1-SNAPSHOT</version>
<name>spring-boot-2-jpa-with-hibernate-and-h2</name>
<description>Demo project for Spring Boot</description>

<properties>
    <java.version>11</java.version>
</properties>

<dependencies>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-data-jpa</artifactId>
    </dependency>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-web</artifactId>
    </dependency>

    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-devtools</artifactId>
        <scope>runtime</scope>
    </dependency>
    <dependency>
        <groupId>com.h2database</groupId>
        <artifactId>h2</artifactId>
        <scope>runtime</scope>
    </dependency>
    <dependency>
        <groupId>org.projectlombok</groupId>
        <artifactId>lombok</artifactId>
        <optional>true</optional>
    </dependency>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-test</artifactId>
        <scope>test</scope>
    </dependency>
</dependencies>

<build>
    <plugins>
        <plugin>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-maven-plugin</artifactId>
        </plugin>
    </plugins>
</build>

This seems like a bug in eclipse: https://bugs.eclipse.org/bugs/show_bug.cgi?id=547340

You can fix this by temporary downgrading the maven jar plugin version to 3.1.1 from 3.1.2. Add this to the properties section:

<maven-jar-plugin.version>3.1.1</maven-jar-plugin.version>

So your pom will look like this:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
    <groupId>org.springframework.boot</groupId>
    <artifactId>spring-boot-starter-parent</artifactId>
    <version>2.1.5.RELEASE</version>
    <relativePath/> <!-- lookup parent from repository -->
</parent>
<groupId>com.in28minutes.springboot.rest.example</groupId>
<artifactId>spring-boot-2-jpa-with-hibernate-and-h2</artifactId>
<version>0.0.1-SNAPSHOT</version>
<name>spring-boot-2-jpa-with-hibernate-and-h2</name>
<description>Demo project for Spring Boot</description>

<properties>
    <java.version>11</java.version>
    <maven-jar-plugin.version>3.1.1</maven-jar-plugin.version>
</properties>

<dependencies>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-data-jpa</artifactId>
    </dependency>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-web</artifactId>
    </dependency>

    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-devtools</artifactId>
        <scope>runtime</scope>
    </dependency>
    <dependency>
        <groupId>com.h2database</groupId>
        <artifactId>h2</artifactId>
        <scope>runtime</scope>
    </dependency>
    <dependency>
        <groupId>org.projectlombok</groupId>
        <artifactId>lombok</artifactId>
        <optional>true</optional>
    </dependency>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-test</artifactId>
        <scope>test</scope>
    </dependency>
</dependencies>

<build>
    <plugins>
        <plugin>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-maven-plugin</artifactId>
        </plugin>
    </plugins>
</build>
</project>

Update: A fix has been released. Click Help > Check for updates in Eclipse/STS and install the newest m2e connector.

Eclipse shows errors but I can't find them, Based on the error you showed ('footballforum' is missing required Java project: '​ApiDemos'), I would check your build path. Right-click the  An astronaut aboard the International Space Station has shared a selection of photographs revealing the reverse view of the annual ‘ring of fire’ solar eclipse and showing the resulting shadow passing over our planet.

Strange symbols are showing in Eclipse, You need to click (actually un-click) one button with symbol of Pi. enter image description here. Characters you see are symbols of tabulations  A satellite orbiting the Moon captured the amazing moment when a total solar eclipse occurred. The photos taken by the satellite show the cosmic phenomenon from the Moon’s perspective.

<maven-jar-plugin.version>3.1.1</maven-jar-plugin.version>

Add this dependency in pom.xml under properties tag

Map of Annular Solar Eclipse on June 21, 2020, Where & when is the Annular Solar Eclipse on June 21, 2020 visible? Interactive map showing eclipse path and local times for start and end in any city. The first solar eclipse of the year 2020 just concluded. Pictures of the annular solar eclipse made it to the social media platforms where we could see the partial solar eclipse as well as the maximum eclipse showing a “ring of fire”. When the eclipse looked so magnificent from the Earth, imagine what it would have looked like from space.

if you are using spring boot downgrade the version to 2.1.4.RELEASE instead of 2.1.5.RELEASE it will solve the problem

Very Basic Eclipse Users Guide, Debugging: Stopping the Debugger; Displaying Line Numbers; Creating a zip file via eclipse. (separate page). Other  This is NASA's official eclipse Web site. It contains maps and tables for 5,000 years of eclipses and includes information on eclipse photography, observing tips and eye safety.

I am using eclipse photon and had similar issue. Didnt want to add the maven-jar-plugin.version in my pom as I dont want my codebase to contain code specific to IDE.

What I noticed is eclipse photon has m2e version of 1.5 which is causing the problem. I uninstall all the m2e connectors, restarted my eclipse and then installed the m2e connector using the below url manually

https://download.eclipse.org/technology/m2e/releases/1.13/

this worked like a charm

Stunning Sunrise Photos Show 'Devil Horns' During Solar Eclipse , Stunning Sunrise Photos Show 'Devil Horns' During Solar Eclipse. The right time, the right spot and the right phenomenon landed one  An eclipse perspective can show any number of views and editors. All editor instances appear in a single editor area, whereas views are placed inside view folders. A workbench window can display any number of view folders. Each view folder can display one or more views.

Total Solar Eclipse 2019: Path, Viewing Maps and Photo Guide , Outside the path of totality, this map shows the percentage of the sun's disk that will be covered by the moon at maximum partial eclipse. For some reason Eclipse is no longer showing me Java compilation Errors in the Problems View. It is still showing Warnings. This has suddenly happened and I cannot think of anything that I have c

Eclipse shows moon move in reverse | Human World, A timelapse showing the unusual eclipse of the sun by the moon, as seen from NASA's Solar Dynamics Observatory on March 6. In reality, the  Upcoming Eclipse: July 5, 2020 — Penumbral Lunar Eclipse is not visible in Kuala Lumpur. See animation and where it can be seen June 21, 2020 — Annular Solar Eclipse — Kuala Lumpur

Eclipse showing error for an android application in 'Package , This happens most of the time for me. For me it was due to giving same ID to different TextViews, ListViews, GridViews or other type of user controls that are used  The Eclipse Foundation - home to a global community, the Eclipse IDE, Jakarta EE and over 350 open source projects, including runtimes, tools and frameworks.

Comments
  • github.com/Romulo-S/Manager-System
  • I ran into this same problem, it was Bug 547340 - Cannot import any project into Eclipse with maven-jar-plugin 3.1.2. SOLUTION: Eclipse > Help > Install New Software > Work with= https://download.eclipse.org/m2e-wtp/signed/mavenarchiver/0.17.4/, <Enter>, m2e extensions= Y > Next... Updating m2e did NOT work. Manually installing m2e 0.17.4 DID work.
  • Thanks! By the way, how did you find that this is a bug?
  • @RomuloSorato no problem ;) I also use eclipse, so I created a dummy project to reproduce the issue, after creation I immediatly encountered the issue. Tried maven build and application run, it worked flawlessly, so I concluded it could be a bug in eclipse. I did a search for 'maven' in the eclipse bugzilla and found an issue that seemed similiar
  • Thats nice! Thanks again.
  • No luck with the 'update' to m2e, running latest downloadable eclipse, with the m2e milestone 1.12.0.20190529-1915, and it still does't work
  • Ah, it's the m2e-wtp, updating from this milestones download site made it work download.eclipse.org/m2e-wtp/milestones/1.4. You might want to add that in big letters :)
  • The application runs fine,however, the error in line 1 persists
  • @RômuloSorato Even after updating the project? can you share your pom.xml
  • Do NOT downgrade anything. Eclipse "update" didn't help me, either. Instead, manually install the fix for Eclipse Bug 547340: Eclipse > Help > Install New Software > Work with= https://download.eclipse.org/m2e-wtp/signed/mavenarchiver/0.17.4/, <Enter>, m2e extensions= Y > Next...
  • you could also try Help > Install new software, select "All Available sites" from "Work with" combobox and type in m2e in search, then check in the "m2e connector for mavenarchiver pom properties" under m2e extensions
  • @gybandi thanks! Sadly I have the same problem as G.A.. Of course downgrading to v3.1.1 worked, but I would like not to have to do that. Now when I try to check for updates, it says there are none. Trying to get it from the Eclipse Market does not get me further either. I am using Eclipse Version: 2019-03 (4.11.0), Build id: 20190314-1200. I'll give Eclipse 2019-06 RC1 since I have some time on my hands.
  • @Igor have you tried "Install new software" section instead of the Eclipse Marketplace/Check for updates? Sometimes marketplace does not work for me neither
  • @gybandi I actually did not try the Marketplace - just "Install New Software" from the Help-menu... weird... No proxy (since it was from my home PC) either...
  • While this code may solve the question, including an explanation of how and why this solves the problem would really help to improve the quality of your post, and probably result in more up-votes. Remember that you are answering the question for readers in the future, not just the person asking now. Please edit your answer to add explanations and give an indication of what limitations and assumptions apply. From Review