Error when trying to install Angular Cli or update current Node.js Version

uninstall angular cli
update npm
you are running version v6.10.3 of node.js, which is not supported by angular cli v6.
npm install
angular cli versions
check angular cli version
npm latest version
ng' is not recognized as an internal or external command

I'm new to angular. So in order to learn angular i tried to install it. But it give me the following error

I tried to update my node also. But that also failed.

I used following commands for it...... npm install npm -g (For npm update) npm install -g @angular/cli (For Angular update)

My current node version is 8, and OS is Win10.

The Error is

npm ERR! errno ENOTFOUND
npm ERR! network request to https://registry.npmjs.org/@angular%2fcli failed, reason: getaddrinfo ENOTFOUND registry.npmjs.org 
registry.npmjs.org:443
npm ERR! network This is a problem related to network connectivity.
npm ERR! network In most cases you are behind a proxy or have bad network settings.

Check your config settings: npm config list

Then you could add or change your proxy settings:

npm config set http-proxy http://your_proxy_ip:port
npm config set https-proxy http://your_proxy_ip:port

Answer is from here: https://github.com/npm/npm/issues/17947

Unable to install angular cli through npm · Issue #5296 · angular , 99478 error Make sure you have the latest version of node.js and npm installed. 99478 error If you do, this is most likely a problem with the node-  Exception or Error Node.js version v11.3.0 detected. The Angular CLI requires a minimum Node.js version of either v10.13 or v12.0. Please update your Node.js version or visit https://nodejs.org/ for additional instructions.

Please refer this site, besthostadvisor.com/blog/how-to-update-node-js/ it includes all methods to update the node

ng serve not working when install latest version of angular cli · Issue , If you the error above still persist then try this: Upgrade your npm version (to 3 or +) (this was the little devil) Make sure you have the latest version of node.js and npm installed. I Downgraded my Node via nvm from the current stable version, I removed the node_modules and cleared the cache. As you can see from the above screenshot, I have version 8. So, the next step is to upgrade the version of Angular CLI 8 to Angular CLI 9. To update the latest angular-cli package installed globally, you need to follow the below commands. First, we need to uninstall the old version of Angular CLI.

I had that problem with npm 6.0.9 and i did this: i use npm install -g @angular/cli with the powershell and this is functionalling correctly.

Common errors, Broken npm installation; Random errors; No compatible version found; Permissions Please see the discussions in “Downloading and installing Node.​js and npm” and Error: ENOENT, stat 'C:\Users\<user>\AppData\Roaming\npm' on Windows 7§ upgrade your version of npm npm install npm -g --ca=""; tell your current  As you can see, I have an Angular CLI of 9.1. Let us update this with angular 10. Step 2: Uninstall the old version of Angular CLI with the following command: npm uninstall -g @angular/cli. This will remove all the Angular packages available in your system. Now if you will try to run and “ng” command this will give you an error:

Downloading and installing Node.js and npm, js on a variety of operating systems, see this page. < About npm CLI versions | Configuring your registry settings as an npm Enterprise user >. The current stable​  After upgrading node.js, try and run the above Angular CLI upgrade steps, and you are good to go. When you were upgrading Angular CLI and got any error, then the best solution would uninstall that Angular CLI and fix the issue and again install the Angular CLI. This way, most of the Angular CLI related errors will be solved.

Angular CLI update issues: Manually Update your Angular Project, Let's do a fresh install of Angular CLI by running the following 3 commands: x.x​), generating a new project will use the old version (1. Also, if we run ng serve to start our app, it will throw an error! This will update the project's node modules and will bring our basic Good Parts of JavaScript — Objects. If you are upgrading to an older version of Angular, for example, version 6, then it is better to install the corresponding Angular CLI Version Since, the Angular Version 6, the Angular CLI follows the same Version No as the Angular. Hence for Angular 7, the corresponding version of the Angular CLI is 7. The Angular CLI version 1.7 was for

Error while installing angular/cli using npm, When I tried to install angular cli using this command npm install -g (current: {"​os":"win32","arch":"x64"}) npm WARN ajv-keywords@3.2.0 requires a DEPENDENCY: node-sass@4.9.0 postinstall: `node scripts/build.js This would be solved if you update the npm version to the latest, use this command: 2. Install and add the latest version of @angular/cli to your package.json file as a development dependency. npm install --save-dev @angular/cli@latest. 3. Install node packages. npm install. 4

Comments
  • are you installing it on a corporate pc? could be a proxy issue?