after installing ionic cordova plugin add cordova-plugin-fcm-with-dependecy-updated my android built not working

Related searches

Error: Execution failed for task ':processDebugGoogleServices'.

Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/android/android-tools/com.google.gms.google-services/) or updating the version of com.google.android.gms to 10.+.

i want ionic cordova plugin cordova-plugin-fcm-with-dependecy-updated for notification but build is crash after installed this plugin if i remove this plugin then my app is working

i try to use fcm plugin with android 8.0.0 with cordova-plugin-googleplus 7.0.0 and i try with android 7.4.1 and 6.4.0 with cordova-plugin-googleplus 5.2.1

try this!..

step 1 ionic cordova platform rm android

step 2 go to /plugins/cordova-plugin-fcm-with-dependecy-updated/src/android/FCMPlugin.gradle

change like this

buildscript {
    repositories {
        mavenCentral()
        jcenter()
        mavenLocal()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.+'
        classpath 'com.google.gms:google-services:3.1.+'
    }
}
repositories {
    mavenCentral()
    jcenter()
}
dependencies {
    compile 'com.google.firebase:firebase-core:11.4.2'
}
// apply plugin: 'com.google.gms.google-services'
// class must be used instead of id(string) to be able to apply plugin from non-root gradle file
apply plugin: com.google.gms.googleservices.GoogleServicesPlugin

step 3 ionic cordova platform add android

step 4 Goto /platforms/android/project.properties

Change like the numbers into 11.4.2

cordova.system.library.3=com.google.firebase:firebase-core:11.4.2
cordova.system.library.4=com.google.firebase:firebase-messaging:11.4.2
cordova.system.library.7=com.google.android.gms:play-services-auth:11.4.2
cordova.system.library.8=com.google.android.gms:play-services-identity:11.4.2

demo project.properties file

# This file is automatically generated by Android Tools.
# Do not modify this file -- YOUR CHANGES WILL BE ERASED!
#
# This file must be checked in Version Control Systems.
#
# To customize properties used by the Ant build system edit
# "ant.properties", and override values to adapt the script to your
# project structure.
#
# To enable ProGuard to shrink and obfuscate your code, uncomment this (available properties: sdk.dir, user.home):
#proguard.config=${sdk.dir}/tools/proguard/proguard-android.txt:proguard-project.txt
# Project target.
target=android-26
android.library.reference.1=CordovaLib
cordova.gradle.include.1=cordova-plugin-badge/mobile-badge.gradle
cordova.system.library.2=com.facebook.android:facebook-android-sdk:4.25.0
cordova.system.library.3=com.google.firebase:firebase-core:11.4.2
cordova.system.library.4=com.google.firebase:firebase-messaging:11.4.2
cordova.gradle.include.2=cordova-plugin-fcm-with-dependecy-updated/mobile-FCMPlugin.gradle
cordova.system.library.6=com.android.support:appcompat-v7:25.+
cordova.system.library.7=com.google.android.gms:play-services-auth:11.4.2
cordova.system.library.8=com.google.android.gms:play-services-identity:11.4.2
cordova.gradle.include.3=cordova-plugin-local-notification/mobile-localnotification.gradle
cordova.gradle.include.4=cordova-plugin-telerik-imagepicker/mobile-ignorelinterrors.gradle
cordova.gradle.include.5=cordova-plugin-telerik-imagepicker/mobile-androidtarget.gradle
cordova.gradle.include.6=phonegap-plugin-barcodescanner/mobile-barcodescanner.gradle
cordova.system.library.11=com.android.support:support-v4:27.+
cordova.gradle.include.7=twitter-connect-plugin/mobile-twitter.gradle
cordova.system.library.12=com.squareup.okhttp3:okhttp:3.12.0

step 5 ionic cordova build android

Note :: Don't forgot to add google-services.json file in root directory, main_project/google-services.json

cordova-plugin-fcm-with-dependecy-updated, Google Firebase Cloud Messaging Cordova Push Plugin fork with Donate npm downloads npm per month npm version License: MIT GitHub issues GitHub forks For Android, to show the notification received on the foreground, Ionic. Default preferences: npm install -g cordova@latest # Minimal� Adding both Platforms iOS and Android using Cordova add platform command; than adding plugin to implement push notification through Ionic Guide using this command sudo ionic cordova plugin add cordova-plugin-fcm-with-dependecy-updated; For android its executing successfully but for iOS its not. please check below details for more details.

We have the same issue and yesterday we solve this problem with this answer:

Answer:1

This is due to the firebase updates on April 05. Here https://firebase.google.com/support/release-notes/android#update_-_april_02_2019, I found the last working versions and adjusted my project.properties accordingly like so

cordova.system.library.4=com.google.firebase:firebase-core:16.0.8 
cordova.system.library.5=com.google.firebase:firebase-messaging:17.5.0 
cordova.system.library.6=com.google.firebase:firebase-config:16.4.1 
cordova.system.library.7=com.google.firebase:firebase-perf:16.2.4

Here all dependencies are locked to the specific version (Update - April 02, 2019) instead of +, which would get you the latest version thus breaking the build process.

Now I can build successfully! I hope it helps!

Ref: page

Answer: 2

A wonderful person opened a pull request 31 in the cordova-firebase-plugin official repo and it works.

Steps I did:

1 - Remove cordova-firebase-plugin with ionic cordova plugin remove cordova- 
firebase-plugin

2 - Install: ionic cordova plugin add https://github.com/dpa99c/cordova-plugin-firebase#GH-1057-April-05-android-build-issue

3 - rm -rf node_modules/ plugins/ platforms/android package-lock.json

4 - ionic cordova platform add android && npm install

5 - In my case, I also use a firebase js library in an old version because the newest ones are not working for me. With that library I always need to reinstall it manually after all the previous steps, so also I did: npm install firebase@4.12.1.

And now it’s working.

ref: Page

Help - IONIC 4, Help - IONIC 4 - after installing ionic cordova plugin add cordova-plugin-fcm-with- dependecy-updated my android built not working � ionic. after installing ionic cordova plugin add cordova-plugin-fcm-with-dependecy-updated my android built not working Hot Network Questions In a world without stars, how would travelers navigate at night?

I'm a Korean who develops with Cordova

I solved as below. cordova-plugin-admob-free and Library conflict with cordova-plugin-fcm-with-dependecy-updated.

I changed only the ads version and ran it as shown below.

I am not sure if the content will be delivered using Google Translate. enter image description here

/platforms/android/project.properties

cordova.system.library.1=com.google.firebase:firebase-core:16.0.9 cordova.system.library.2=com.google.firebase:firebase-messaging:18.0.0 cordova.gradle.include.1=cordova-plugin-fcm-with-dependecy-updated/helloworld-FCMPlugin.gradle cordova.system.library.3=com.google.android.gms:play-services-base:11.0.4 cordova.system.library.4=com.google.android.gms:play-services-ads:17.0.0

Plugin not installed � Issue #113 � andrehtissot/cordova-plugin-fcm , hasPermission, but the FCM plugin is not installed. GitHub is home to over 50 million developers working together to host and review code, I run the application by calling ionic cordova run android --device FCM: has been created plugin: 'ionic cordova plugin add cordova-plugin-fcm-with-dependecy- updated' After I've installed the latest Ionic CLI (see below) and created a new empty project. Adding the android platform, it builds. Then adding the FCM plugin and the necessary google-services.json, it no

cordova-plugin-fcm-with-dependecy-updated 7.0.8 node npm open , install build build:www build:ionic prettier tslint. npm install cordova-plugin-fcm- with-dependecy-updated Google Firebase Cloud Messaging Cordova Push Plugin issues](https://img.shields.io/github/issues/andrehtissot/cordova-plugin- For Android, to show the notification received on the foreground,� Dismiss Join GitHub today. GitHub is home to over 50 million developers working together to host and review code, manage projects, and build software together.

Ionic 5 Firebase FCM Push Notification Tutorial with Example , Push notifications provide you updates, be it: We have successfully created the Firebase application for Android Check out the version of Ionic by running the following command. in the terminal to install the lab plugin as a dev dependency. Install & Configure Ionic 5 Cordova Native FCM Plugin. If you do not set this resource, then the SDK will use the default icon for your app which may not meet the standards for Android >5.0. iOS compilation details Put the downloaded file 'GoogleService-Info.plist' in the Cordova project root folder.

Installation ionic cordova plugin add cordova-plugin-fcm-with-dependecy-updated npm install @ionic-native/fcm npm install cordova-plugin-fcm-with-dependecy-updated npm install @ionic-native/fcm ionic cap sync Ionic Enterprise comes with fully supported and maintained plugins from the Ionic Team.

Comments
  • sir above solution is fixed but got another error generated: FirebaseInstanceId.getInstance().getInstanceId()
  • thanks for help , tried your solution still same error Found com.google.firebase:firebase-core:16.0.8, but version 10.+ is needed for the google-services plugin. Found com.google.firebase:firebase-messaging:17.5.0, but version 10.+ is needed for the google-services plugin. Found com.google.android.gms:play-services-auth:+, but version 10.+ is needed for the google-services plugin. Found com.google.android.gms:play-services-identity:+, but version 10.+ is needed for the google-services plugin.