module schedule/tracking does not exist in the Haste module map

module crypto does not exist in the haste module map
module not found can t resolve scheduler
unable to resolve module react-native-swipeout
cannot determine which native sdk version your project uses because the module expo is not installed
cannot find module scheduled schedulearray
expo deprecated

React Native Environment Info:

System:
  OS: macOS High Sierra 10.13.6
  CPU: x64 Intel(R) Core(TM) i3-7100 CPU @ 3.90GHz
  Memory: 559.26 MB / 16.00 GB
  Shell: 3.2.57 - /bin/bash
Binaries:
  Node: 10.11.0 - /usr/local/bin/node
  npm: 6.4.1 - /usr/local/bin/npm
  Watchman: 4.9.0 - /usr/local/bin/watchman
SDKs:
  iOS SDK:
    Platforms: iOS 12.0, macOS 10.14, tvOS 12.0, watchOS 5.0
IDEs:
  Xcode: 10.0/10A255 - /usr/bin/xcodebuild
npmPackages:
  react: 16.0.0 => 16.0.0 
  react-native: ^0.57.3 => 0.57.3 
npmGlobalPackages:
  react-native-cli: 2.0.1

here is react-native info similar solutions from GitHub does not work for me

"Module `schedule/tracking` does not exist in the Haste module map , "Module `schedule/tracking` does not exist in the Haste module map" still points to a locked issue in  "Module `schedule/tracking` does not exist in the Haste module map" still points to a locked issue in another repo #271 Open Kerrick opened this issue Sep 28, 2018 · 2 comments

If running with your versions of npm packages:

react: 16.0.0 => 16.0.0 
react-native: ^0.57.3 => 0.57.3

We'll have the same error as below:

error: bundling failed: Error: Unable to resolve module `scheduler/tracing` from 
`C:\projects\rnw\node_modules\react-native\Libraries\Renderer\oss\ReactNativeRenderer- 
dev.js`: Module `scheduler/tracing` does not exist in the Haste module map

Upgrade to the following versions:

"dependencies": {
  "react": "16.6.3",
  "react-native": "0.58.1"
},

And the error will be gone.

module schedule/tracking does not exist in the Haste module map , The error appears due to the renaming of schedule/tracking to schedule/tracing from react@16.5.1 to  Hey 👋 So, now RN 0.57.3 is out which means that this is fixed, BUT you NEED to upgrade react and react-test-renderer to version "16.6.0-alpha.8af6728".. It's safe, I've tested 0.57.3 in multiple apps without issues these past few hours.

If there is an error related to module Schedule/tracking not found, use react-native 0.55.0 version. Above RN->0.55.0 version schedule/tracking package is renamed or moved to another module which is not found by node server.

Command: react-native init (Project Name) --version 0.55.0

React native "Module 'scheduler' does not exist in the Haste module , does not exist in the Haste module map This might be related to https://github.​com/facebook/react-native/issues/4968  I am trying to upgrade to RN 0.59.3 (my understanding is that I need 0.59 to get 64 bit, required by Play Store by August). I am seeing an "Unable to resolve module 'scheduler/tracing'" message. (Note that it says "scheduler/tracing", not "schedule/tracking".)

bundling failed: Error: Unable to resolve module `schedule/tracking`, Module `schedule/tracking` does not exist in the Haste module map This might be Remove haste cache: `rm -rf /tmp/haste-map-react-native-packager-*`. at ModuleResolver. Unable to resolve module scheduler from D:\sujata\final react\reactnative ode_modules\react-native\Libraries\Renderer\oss\ReactNativeRenderer-prod.js: Module scheduler does not exist in the Haste module map. The below steps were printed on console. This might be related to facebook/react-native#4968 To resolve try the following:

Unable to resolve module `schedule/tracking`, Module `schedule/tracking` does not exist in the Haste module map rolling back to 16.5.1 fixes this for me locally  Module does not exist in the module map or in these directories: please help!! native\Libraries\react-native\react-native.js: Module does not exist in the module

Ejecting React Native Jan 2019, Module `scheduler` does not exist in the Haste module map. I tried debugging how could a whole  I have tried it all and I'm still facing the "unable to resolve module . does not exist in the haste module map". I'm running it on IOS simulator on a Mac, with RN 0.55.2 I've tried: Clearing npm cache; Running watchman watch-del-all; Removing haste file from temp; Removing metro files from temp; Removing react files from temp

Comments
  • Thanks for clarifying the version when using expo!