Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules

cannot change version of project facet dynamic web module
the server does not support version 4.0 of the j2ee web module specification.
dynamic web module 4.0 cannot be uninstalled
dynamic web module version 3.0 is not supported
unable to configure web module for jax-rs
project facets in eclipse
tomcat 9 download
dynamic web module 4.0 requires java 1.8 or newer

I'm trying to deploy a very simple HTTPServlet project using Tomcat 7 in my Eclipse J2EE perspective. I am getting the error "Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules". I have already tried modifying my org.eclipse.wst.common.project.facet.core.xml as mentioned here file but that doesn't seem to fix the issue. I'm able to deploy just fine by using file->export->.war directly to my installed tomcat server. Any ideas?

Tomcat is not a Java EE compliant application server, so you won't have EJB or CDI out-of-the-box here. Instead, use JBoss Wildfly or TomEE which are built on top of tomcat. Or, change to a complete different Java EE implementation like GlassFish.

Another option may be if you deploy directly into Tomcat. Eclipse by default deploys on a different folder and use some kind of bypass to see it deployed on Tomcat. Follow these steps:

  1. In your Eclipse, go to the Servers view (if it's not visible in the IDE, go to Window/Show view/Servers), it will show you your tomcat server (and others), double click on it.
  2. In the Tomcat overview window, check the Server locations panel, expand it and check where the webapp is deployed.
  3. If selected option is Use Tomcat installation then the web app must be in <tomcat>/webapps. If not, make sure to select this option and the application will be directly deployed on Tomcat folder.

Eclipse IDE, Eclipse - Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules. By Yashwant Chavan, Views 39469, Last  Yashwant. Hi there! I am founder of technicalkeeda.com and programming enthusiast. My skills includes Java,J2EE, Spring Framework, Nodejs, PHP and lot more.

Go to Project Properties -> Project Facets and change the version of Dynamic Web Module. If it is set to 3.1 then change it to 3.0. In case it does not allow you to change the version, uncheck it and press apply. Then you can select the version, check it and apply-OK. Worked for me!

Eclipse IDE: Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4 , Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules​. Copy. Tools used : Eclipse Juno 4.2; Tomcat 6.0.35; JDK 1.6  Tomcat version 7.0 only supports J2EE 1.2 only supports J2EE 1.2 and Java EE 5 and 6 Web mod and Java EE 5 Web mo new and old version java EE 6 Libraries java EE 5 Libraries 3 and 5 negtive 5 and minus PHP 5 and MariaDB and Java and web J2EE Jsp and Servlet Red5 And Tomcat tomcat and jboss 1.3-J2EE Modules Modules tomcat version

Yes, using Maven, Spring project with Java EE compliance we face this issue with Tomcat. To fix this problem please execute the list of commands to make the project as Java EE compliance.

  1. $ mvn eclipse:clean - to clean the eclipse files like .project .classpath
  2. $ mvn eclipse:eclipse -Dwtpversion=2.0 to create the eclipse compatible with Java EE.

At last open the project in eclipse select the server tomcat now click run on servers(Alt+Shift+x,R) select tomcat7.0 to run.

Solve Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java , Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules. Problem description. When the project is loaded into  Import a Java web project in Eclipse, build with Maven, once create a Tomcat server instance, unable to add the Java web project, and showing. Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules Tools used : Eclipse Juno 4.2; Tomcat 6.0.35; JDK 1.6

If you are getting "Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules" error when trying to add project to Tomcat 7. Simply,

Right click on the project --> go to project facets --> uncheck the dymanic web module (which should be 3.1)--> apply --> then change the dynamic web module to 3.0 --> apply and then save.

Try to add now and it should work.

Tomcat version 8.5 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 , Tuesday, 16 August 2016. Eclipse IDE: Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules. Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules . 에러가 발생 * 원인. 다이나믹 웹 프로젝트를 생성할 때. Target runtime 이 <None>인 상태로 생성했기 때문에. * 해결. 다이나믹 웹 프로젝트를 생성할 때. Target runtime 옆에 'New Runtime..'

For Tomcat Version 6

In project, .settings folder OR Or CTRL+SHIFT+R : find this file

org.eclipse.wst.common.project.facet.core.xml

change the version of facet=jst.web to 2.4 or 2.5

File : org.eclipse.wst.common.project.facet.core.xml

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="jst.java"/>
  <fixed facet="jst.web"/>
  <installed facet="jst.web" version="2.4"/>
  <installed facet="jst.java" version="6.0"/>
</faceted-project>

Tomcat 7 You need facet="jst.web" version="3.0" to deploy on Tomcat 7.

530844 – Eclipse irreversible Dynamic Web Module 4.0 selection , Solve Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules, Programmer Sought, the best programmer technical posts 

Solve Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules cannot be added to tomcat, Programmer Sought, the best 

Tomcat version 8.5 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5, 6, and 7 Web modules. by avignon avvin 2019. 6. 4. [ Error ]. The superclass 

I selected my web project, but Eclipse said: "Tomcat version 9.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5, 6, 7, and 8 Web modules".

Comments
  • The server works perfectly fine with the application when deployed directly to the Tomcat/webapps folder. I only see this problem in Eclipse while trying to add to the server instance in my J2EE perspective. Also, I have other JAX-RS projects that I can add with no issues through the same J2EE perspective
  • Not too sure what the root of my problem was but I created a copy of the project that was not working and then was able to add it to my server. However, I also was messing around with the "Server Locations settings" so that might have been the culprit. Ultimatly I am able to deploy my project dynamically after switching to "Use Tomcat installation" option so will accept your answer :) thanks!
  • @PhilipRego and that's because...?
  • Check your web.xml file and see which Servlet version you're using. Make sure it's 3.0. Also, check the properties for your project and make sure it works with Web 3.0, not higher.
  • I confirm in my case this solved the problem. Even though I am clueless why this error came for different web module version.
  • Thanks it worked for me. In .settings/org.eclipse.wst.common.project.facet.core.xml the tag must be <installed facet = "jst.web" version = "3.0" />
  • In my case, as a result of the execution of the two Maven commands, the Dynamic Web Module in my Project Facets was configured to version 2.4. The problem was still there until I changed the version to 3.0.
  • this suggestion helps me fix my issue