error int the Failed to set referrer policy

no-referrer-when-downgrade nginx
referrer-policy nodejs
firefox referrer policy
fetch referrer policy
referrer-policy best practice
referrer policy php header
servicenow referrerpolicy is not defined
block referrer header

I'm getting the following error in my chrome console for a Wordpress site I'm working on.

Failed to set referrer policy: The value 'http://example.com/comic/' is not one of 'always', 'default', 'never', 'no-referrer', 'no-referrer-when-downgrade', 'origin', 'origin-when-crossorigin', or 'unsafe-url'. The referrer policy has been left unchanged.

It's reffereing to this line in the <head> of the HTML document...

<meta name="Referrer" content="http://example.com/comic/" />

I'm vieing the page over http, not https.

What is causing this issue and how can I fix it?

Go into your .htaccess file and change the following:

Header set Referrer-Policy ""

to

Header set Referrer-Policy "origin"

That should fix the issue.

The reason is more than likely because you don’t have correct permissions on your .htaccess file that allows w3tc to make the changes it needs to.

error int the Failed to set referrer policy, Go into your .htaccess file and change the following: Header set Referrer-Policy "​". to. Header set Referrer-Policy "origin". That should fix the  Failed to set referrer policy: The value ” is not one of… So, it seems that, depending on from which version to which version the plugin is updated, the value for the new Referrer Policy option is set to an empty string that causes this error on Chrome.

How to fix "failed to set referrer policy: The value ' ' is not one of , When I inspect the page in console I get the "Failed to set referrer policy" error a bunch of times. So first thing I did was uncheck Referrer policy in  “Failed to set referrer policy: The value ‘same-origin’ is not one of ‘no-referrer’, ‘no-referrer-when-downgrade’, ‘origin’, ‘origin-when-cross-origin’, or ‘unsafe-url’. The referrer policy has been left unchanged.”

you can manually find and change as following in .htaccess file :

<IfModule mod_headers.c>
    Header set Referrer-Policy ""
</IfModule>

to

<IfModule mod_headers.c>
    Header set Referrer-Policy "origin"
</IfModule>

Solved : Failed to set referrer policy Error on Chrome console, After installing w3 total cache plugin you might get Failed to set referrer policy Error on your Console, it shows the following error: “Failed to set  The referrer policy has been left unchanged. Hi @wasabikino , bumping this to get some other input as I’m not a wordpress expert at all! I wanted to revisit your question as it seems familiar.

Chrome Inspection Console showed me the same Error for my Wordpress sites which have W3 Total Cache installed. "Failed to set referrer policy: The value '' is not one of 'no-referrer', 'no-referrer- when-downgrade', 'origin', 'origin-when-cross-origin'"

and I tried to update the .htaccess file as indicated in the above answer. This fixed the Chrome Inspection Console error but it returned a few moments later.

Checking the Dashboard of W3 Total Cache Performance ->Browser Cache-> Referrer Policy-> Directive, this entry was showing blank.

Selecting 'origin' from the dropdown resulted in .htaccess being updated with the same value 'origin'

Solved : WordPress Failed to Set Referrer Policy Error – W3 Total , On Production WordPress site you might be got Failed to set referrer policy Error on your Console, it shows the following error: “Failed to set  On a web server you have a .htaccess file. This hidden file controls a lot of the behavior of the web server from the top to end. This is where you enable gzip compression, https redirection, protection of files and directory browsing, and setting cookies and headers.

"Referer" as a header is spelled without the double R. Maybe with the double R, it's matching against a different header than the one you mean.

"Failed to set referrer policy" - error message, Chrome gives me this error message: Failed to set referrer policy: The value '' is not one of 'no-referrer', 'no-referrer-when-downgrade', 'origin',  After the last update of the plugin When inspecting the website with google chorme console, it shows the following error: “Failed to set referrer policy: The value ” is not one of ‘no-referrer’, ‘no-referrer-when-downgrade’, ‘origin’, ‘origin-when-cross-origin’, ‘same-origin’, ‘strict-origin’,

Referrer-Policy, Carefully consider the impact of this setting. Integration with HTML. You can also set referrer policies inside HTML. For example, you can set the  Referrer-Policy: no-referrer, strict-origin-when-cross-origin In the above scenario, no-referrer will only be used if strict-origin-when-cross-origin is not supported by the browser. Specifying multiple values is only supported in the Referrer-Policy HTTP header, and not in the referrerpolicy attribute.

How To Fix a Missing Referrer-Policy on a Website, The policy can be set a number of ways, including in website code (PHP, etc). Below we will be configuring the Referrer-Policy header in  El error Failed to set referrer policy El error que aparece es 1 Failed to set referrer policy : The value '' is not one of 'no-referrer', 'no-referrer-when-downgrade', 'origin', 'origin-when-cross-origin', 'same-origin', 'strict-origin', 'strict-origin-when-cross-origin', or 'unsafe-url'.

Unable to Explicitly Set Referrer Policy in Pro - Support, Here is the error: Failed to set referrer policy: The value '' is not one of 'no-referrer'​, 'no-referrer-when-downgrade'  Of course, you can't achieve a grade A now without the new Referrer-Policy header properly configured. If you try and set it with no policy, or a bad policy, it's not going to help you. You have to set the header and use a good policy to be awarded top marks!

Comments
  • Note there is basic browser support for some of these values, particularly same-origin, strict-origin and strict-origin-when-cross-origin when included in a http header - developer.mozilla.org/en-US/docs/Web/HTTP/Headers/…
  • Just in case if you are here but your referrer policy looks fine but your URL contains google-ad-words or something social, then ad-blocker might be the culprit. try disabling it.