Android Studio Failed to resolve: support-core-utils

error: failed to resolve: support-compat
error: failed to resolve: support-media-compat
failed to resolve: com android support design
failed to resolve: com android support design 28.1 0
failed to resolve: com android support appcompat-v7:29
error failed to resolve: com android support support v7:28.0 0
appcompatv7 error android studio
android add support library

After upgrading support library version to 27.1.1 when i sync the project i face with below error:

Failed to resolve: support-core-utils

Any idea?

here is my project level build file:

    buildscript {
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.0'
        classpath 'com.google.gms:google-services:3.1.0'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        maven { url "https://jitpack.io" }
    }
}

and app level build file:

implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'com.android.support:support-v4:27.1.1'
implementation 'com.android.support:design:27.1.1'
implementation 'com.android.support:recyclerview-v7:27.1.1'
implementation 'com.android.support:cardview-v7:27.1.1'

I solved this by setting google() as first entry in allprojects/repositories in top level build.gradle

allprojects {
    repositories {
        google()
        jcenter()
        maven { url "https://jitpack.io"
        }
    }
}

Failed to Resolve: support-core-utils, support-compat, support , I use Android Studio 3.3 to open an old project and bump into the following errors​. ERROR: Failed to resolve: support-core-utils; ERROR:  I use Android Studio 3.3 to open an old project and bump into the following errors ERROR: Failed to resolve: support-core-utils ERROR: Failed to resolve: support-compat ERROR: Failed to resolve: support-media-compat The old project is using compileSdkVersion 27 targetSdkVersion 27 buildToolsVersion unspecified support libraries: 27.1.1 Android Studio 3.3 is using Android Gradle 3.2.1 NOTE

as per behavior changes in android-Gradle plugin (v3.2.0 September 2018) you need to keep the google repository as the first entry

buildscript {
      repositories {
          google() // here
          jcenter()
      }
      dependencies {
          classpath 'com.android.tools.build:gradle:3.2.0'
      }
  }
  allprojects {
      repositories {
          google() // and here
          jcenter()
  }

android-Gradle plugin release note

How to fix "Failed to resolve: support-core-utils"? - ionic-v3, When I build apk I got below error: Failed to resolve: support-core-utils My AndroidManifest.xml file is as follows: <?xml version='1.0'  Join GitHub today. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together.

I have same problem and i changed to successful. Added maven { url 'https://maven.google.com' } as first entry in allprojects/repositories in top level build.gradle

failed to resolve "support-core-utils" and "support-annotations" when , to 2.5.0 or 2.5.1 i get the following errors: Failed to resolve: com.android.​support:support-core-utils:25.4.0 Failed to resolve: com.androi I have recently updated my Android Studio to api 25 with the the latest sdk tools and repositories. But I'm now getting a gradle project sync failed.

In my case , it was because of a library dependency and I solved by excluding support-core-utils from that library :

implementation ('com.github.chrisbanes:PhotoView:2.0.0'){
    exclude module: 'support-core-utils'
}

Failed to resolve: com.android.support:support-core-utils , the project by adding data binding but gradle throws me an error says "Failed to resolve: com.android.support:support-core-utils:24.0.0". Android Studio Error: Failed to resolve: support-core-utils Affected Modules: app Error: Failed to resolve: support-compat Affected Modules: app.

I had the same problem with AppCompat library with version 28.0.0. I fixed it by using 28.0.0-alpha1. None of answers helped me. Android studio 3.1.4 Target and compile sdk 28.

At the time the library was not really stable. support-core-utils is a part of android-support-v4, so if you still have a problem with that try adding implementation 'com.android.support:support-v4:27.1.1' to the dependencies.

Failed to resolve: support-core-utils, Failed to resolve: support-core-utils, Programmer Sought, the best programmer technical posts sharing site. classpath 'com.android.tools.build:gradle:3.1.0'. Android gradle failed to resolve core right after creating a androidx project 8 Manifest merger failed : Attribute application@appComponentFactory updating Firebase libraries

Support Library Setup, How to set up your app to use the Android Support Libraries. Include Google's Maven repository in your project's build.gradle file. allprojects { repositories { google implementation "com.android.support:support-core-utils:28.0.0" }. Caution:  I've been working on this Android Project for about a year now, suddenly when I opened it yesterday Android Studio 3.1.2 failed to sync gradle and the project doesn't build anymore giving me this error: Could not find support-core-ui.jar (com.android.support:support-core-ui:27.1.1).

Support Library Revision Archive, (AOSP issue 220762); TextInputLayout fails to resolve error text color. performAccessibilityAction() . support-core-utils: Provides a number of  003. How to fix No cached version of com.android.tools.build:gradle:3.0.0 available for offline mode - Duration: 1:39. Bharat Makwana 25,325 views

Recent Support Library Revisions, We have split parts of support-core-ui, support-core-utils, and support-compat into smaller libraries. This change will help us detangle support library  Gradle Sync Failed Error Android Studio 3 .2 .1 100% Solve Error.

Comments
  • Do you have the google() repository listed in your repositories closures in your top-level build.gradle file?
  • @CommonsWare yes i have
  • Can you add the gradle line of the support lib?
  • @UrielFrankel added to op
  • This is weird... support-core-utils is a dependency of support-v4: and appcompat-v7... You may try implementation 'com.android.support:support-core-ui:27.1.1' to see if it unlocks your situation.
  • Future readers, note the as first entry. google() must come before jcenter().
  • Superb... found
  • unbelievable. it works. i could not understand why cant they maintain backward compat, instead of breaking thousands of builds. thank god, we have SO.
  • It's already present for OP though. google() is the Google repo
  • any progress for this issue? I'm having the same problem
  • Changing the order did work for me. Any explanation?
  • It did work for me also, thank you for this answer. And shame on gradle for this nonsense bug.
  • I think the top answer is better, to change the order of the repository in the general Gradle config.