Cannot find module node_modules\@ionic\app-scripts IONIC 3

error loading ionic-angular package.json: error: cannot find module 'ionic-angular/package'
cannot find module node_modulesionicbinionic
@ionic/app-scripts not installed
error with ./node_modules/@ionic/app-scripts/package.json file: file_not_found
[app-scripts] error: cannot find module 'typescript'
ionic-app-script task: "build"
error: cannot find module src ionic
error: cannot find module ionic 3

I have installed npm 3.10.10 then i have installed ionic 3.9.2 and cordova 7.0.1.

i have tried the following steps:

  1. ionic start newProject

    (selected a tabs project)

  1. ionic serve

this command will throw the error

Error: Cannot find module 'E:\firstProject\node_modules\@ionic\app-scripts'

i found only this thread Error: Cannot find module '@ionic/app-scripts'.

i don't want to downgrade my nodejs version,as i want to use latest feature

but i tried,

npm i @ionic/app-scripts (SAG Answer)

i'm getting same error after executing above command

please help me without downgrading nodejs version

EDIT 1 (as per sampath suggestion) : below is my package.json file

{
  "name": "firstProject",
  "version": "0.0.1",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "lint": "ionic-app-scripts lint",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/common": "4.1.3",
    "@angular/compiler": "4.1.3",
    "@angular/compiler-cli": "4.1.3",
    "@angular/core": "4.1.3",
    "@angular/forms": "4.1.3",
    "@angular/http": "4.1.3",
    "@angular/platform-browser": "4.1.3",
    "@angular/platform-browser-dynamic": "4.1.3",
    "@ionic-native/core": "3.12.1",
    "@ionic-native/splash-screen": "3.12.1",
    "@ionic-native/status-bar": "3.12.1",
    "@ionic/storage": "2.0.1",
    "ionic-angular": "3.6.0",
    "ionicons": "3.0.0",
    "rxjs": "5.4.0",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.12"
  },
  "devDependencies": {
    "@ionic/app-scripts": "2.1.4",
    "typescript": "2.3.4"
  },
  "description": "An Ionic project"
}

when i run ionic info it is giving some kind of error

$ ionic info

EDIT 2: (After sampath Answer)

  1. i did the following changes
i removed `"@ionic/app-scripts": "2.1.4"`
  1. $ npm install @ionic/app-scripts@latest --save-dev

post $ npm install @ionic/app-scripts@latest --save-dev , package.json file will look like below

please help me thanks in advance!!!!

Guys i solved this issue. Just want to share with you to save your time at least. Follow steps.

  1. Remove node_modules.
  2. Downgrade Node to version 6 (run npm install node@6 or brew install node@6)
  3. Add "@ionic/app-scripts": "3.1.9" under dependencies in project.json
  4. npm i

Cannot find module node_modules\@ionic\app-scripts IONIC 3 , Guys i solved this issue. Just want to share with you to save your time at least. Follow steps. Remove node_modules . Downgrade Node to  Click to email this to a friend (Opens in new window) Click to share on Facebook (Opens in new window) Click to share on Twitter (Opens in new window)

Remove "@ionic/app-scripts": "2.1.4" from your package.json file firstly.

According to your ionic info, you have a problem with app-scripts.So you can install latest as shown below.

and after that compile:

npm install @ionic/app-scripts@latest --save-dev

Remove "@ionic/app-scripts": "2.1.4" from your package.json file firstly.

Update from Git

Running on Windows you might try:

  1. Set environment in local command window and verify problem:

    set OPENSSL_CONF=c:\dummy npm -v

=> you now probably see this ssl error message

  1. Remove environment and verify problem is gone:

    set OPENSSL_CONF=npm -v

=> no ssl error message

Error: Cannot find module node_modules\@ionic\app-scripts', I am new at ionic framework while trying to build the app using “ionic serve” I am Error: Cannot find module node_modules\@ionic\app-scripts' packages: @​ionic/app-scripts : not installed Cordova Platforms : android 6.2.3  Error: Cannot find module 'myapp\dreamhouse-mobile-ionic ode_modules\@ ionic\app-scripts\bin\ionic-app-scripts.js' #3 nikhilrmusale opened this issue Apr 19, 2017 · 1 comment Comments

Run:

npm install @ionic/app-scripts@latest --save-

to install app-script.

Then:

npm install

To install node_modules to avoid Typescript error

And it worked for me.

Fix: Error: Cannot find module '/node_modules/@ionic/app-scripts , I got this error when I tried running my newly created Ionic3 App using the command. ionic serve. 1. 2. 3. ionic serve. To fix this error you need  Ionic Framework Version: 2.0.0-rc.3 Ionic CLI Version: 2.1.17 Ionic App Lib Version: 2.1.7 Ionic App Scripts Version: 0.0.47. in other pc with ionic cli 2.1.14 and appscripts in 0.0.46 works ok. Updated: if i do npm run webpack i get the same error, what i am doing is to generate the build step by step:

Only install the latest version of @ionic/app-scripts

npm install @ionic/app-scripts@latest --save-dev

(SOLVED) Error: Cannot find module 'C:\[]\node_modules\cordova , Description: When I want to deploy my app on my Android with "Ionic cordova run​(or build) android, Powershell Says That cordova module cannot be found. Steps to Reproduce: Running app-scripts build: --platform android --target cordova [​11:37:43] node_modules\cordova\bin\cordova' on Jul 3, 2018. Sorry actually you should be able to accomplish this now with ionic link.There is an option available that a allows you to create a new app. This should accomplish the same thing.

try deleting node_modules folder and do npm install again this might solve your problem

@ionic/App-script and other modules missing · Issue #2791 · ionic , It says that the ionic/app-script is missing, and if I manually install that, it says Cannot find module angular/tsc-wrapped/src/tsc, which I I have too (run ionic serve error cannot find '\node_modules@ionic\app-scripts')  Dismiss Join GitHub today. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together.

@ionic/app-scripts, Following are the steps I did: 1. Installed Git. 2. Installed chromium. 3. [npm] > npx gulp watch & npx ionic-app-scripts serve -b --devapp --address=0.0.0.0 Error: Cannot find module 'C:\Users\sarat\Desktop\Moodle Mobile App Development \node_modules\@ionic\app-scripts\bin\ionic-app-scripts.js' Hello! Thank you for opening an issue with us! The Ionic Framework issues list is designated for the reporting of bugs with the Ionic Framework or for requesting new features.

Moodle in English: Not able to set up development environment for , The only commands I had run since ionic start when creating the app were ionic integrations enable capacitor to add capacitor to the project, npx cap init myApp com.myapp.com to initialize capacitor, ionic build to build the app and generate the www folder, and then npx cap add ios and npx cap add android to add the platforms I need.

Hi Do you want to make web application with php and php framework(CI, Laravel)? Want to make android application with hybrid framework ? Then contact with us.

Comments
  • Can you show the package.json file and ionic info?
  • hi sampath you can see it at EDIT1
  • sampath please help me with the above error
  • Did you solve your issue? I am having the same problem
  • In my case I had set NODE_ENV=production in my terminal. To check value of NODE_ENV, echo $NODE_ENV, change it back to development with NODE_ENV=development.
  • After struggling with this issue for very long finally, this solution worked.
  • @Muhammed: i got above error :after :npm install node@6 but i got above error:npm ERR! node@6.17.1 preinstall: node installArchSpecificPackage?
  • hi sampath, i'm still getting the same error after following your steps. please look into that, thanks in advance
  • Do you have the internet on your machine?
  • yes i do have i'm able install the npm install @ionic/app-scripts@latest --save-dev the package
  • Can you try Update section above? See the git issue too.
  • your above update is working, therefore im not getting any junk message in cosole . does this solve my original problem?
  • i have tried this but getting same error when i execute ionic serve the error is Error: Cannot find module 'E:\firstProject\node_modules\@ionic\app-scripts
  • i think you should try reinstalling ionic npm uninstall ionic -g then npm install ionic -g
  • i have tried that but still same error. please help me if have any further solution