ERROR: Could not find a valid gem 'rails' (>= 0) in any repository

Related searches

I installed rvm and ruby successfully in a linux environment. When I try to install rail, that time I face following error:

$ gem install rails
/home/bathakarai/.rvm/rubies/ruby-1.9.3-p385/bin/gem:4: warning: Insecure world writable dir /home/bathakarai in PATH, mode 040777
ERROR:  Could not find a valid gem 'rails' (>= 0) in any repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    Errno::EHOSTUNREACH: No route to host - connect(2) (http://rubygems.org/latest_specs.4.8.gz)

My gem version is

1.8.25

Rvm version is "rvm 1.18.19 (stable) by Wayne E. Seguin , Michal Papis [https://rvm.io/]".

Please help me by letting me know why this error occurs.

You can use to install with below command

gem install rails --source http://rubygems.org

ERROR: Could not find a valid gem 'bundler' (>= 0), This seems to only be an issue with MacOS builds. When we try and install ANY gem's we get the following error: ERROR: Could not find a� I am trying to install rails using the following command: sudo gem install rails and get the following error: ERROR: Could not find a valid gem 'rails' (>= 0) in any repository ERROR: Possi

Yes, Finally I got the result. It seems like some sort of proxy problem. I set the proxy using export "$HTTP_PROXY=IPAddress which is given in browser:portnumber". For any reference http://khylo.blogspot.in/2007/12/ruby-on-rails-headaches.html

ERROR: Could not find a valid gem 'jekyll' (>= 0), here is why: � Issue , C:\RubyDevKit>gem install jekyll ERROR: Could not find a valid gem 'jekyll' (>= 0 ), here is why: Unable to download data from� Make sure you have all the packages. sudo apt-get update sudo apt-get install ruby ruby-dev make gcc If you do then remove ruby first. sudo apt-get remove ruby

Try running

sudo gem install rails

This may overcome the permission problem you are having

You also look to be having an internet connectivity problem based on the error message.

Hello guys, I'm having a problem. When I try to execute "gem install , ERROR: Could not find a valid gem 'bundler' (>= 0) in any repository ERROR: While executing gem (Gem::RemoteFetcher::FetchError)� Dismiss Join GitHub today. GitHub is home to over 50 million developers working together to host and review code, manage projects, and build software together.

In my case the culprit was avast! Internet Security software on my MacBook Pro. I went to System Preferences, clicked on avast!, clicked on the lock to enable changes, and disabled the Web Shield and File System shield.

After that, I was able to install gems.

i am having ruby version ruby-1.9.3-p547 [ x86_64 ] which i am using for Rails 3.0. Now i am having a project with rails version '2.3.18'. and ree-1.8.7-2012.02 [ x86_64 ]. bundle install and rake

I have struggled to install rails for two days (I've been getting almost the same error message, but, without that "Insecure world ..." line). And at last I did it using the script below (provided at RailsGirls):

bash < <(curl -sL https://raw.github.com/railsgirls/installation-scripts/master/rails-install-ubuntu.sh)

I don't know why it worked. Just leaving it here with the hope that it will be helpful for some other soul as well. ;P

> bundle install Could not find gem 'neo4j-core (~> 2.0.1) ruby' in the gems available on this machine. > gem install neo4j-core ERROR: Could not find a valid gem 'neo4j-core' (>= 0), here is why: Found neo4j-core (2.0.1), but was for platform java ERROR: Possible alternatives: bio-core, eson-core, gom-core, lego-core, merb-core

I am trying to do the Michael Hartl tutorial. When I attempt to install rails 3.2.14 in my gemset, I get the following issue: $ gem install rails -v 3.2.14 ERROR: Could not find a valid g

$ gem install update_xcode_plugins ERROR: Could not find a valid gem 'update_xcode_plugins' (>= 0), here is why: Unable to download data from https://rubygems.org

gem install logstash-core -v '6.1.3' ERROR: Could not find a valid gem 'logstash-core' (= 6.1.3) in any repository ERROR: Possible alternatives: logstash-cli, logstash-file, logstash-lite, logstasher, logstash-fakes I am not sure which (if any) alternatives I can take? Can anyone assist. Thanks in advance.