ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.2 which is incompatible

ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.2 which is incompatible

google-auth 1.10.0 has requirement setuptools
upgrade setuptools
cannot uninstall 'wrapt'. it is a distutils installed project
has requirement setuptools 41.0 0 but you'll have setuptools<=39.1 0 which is incompatible
install tensorflow
modulenotfounderror: no module named 'tensorflow'
pip install tensorflow
attributeerror: module 'tensorboard.lazy' has no attribute 'lazy_load'

gave this error in installation. Does this cause a problem?

ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.2 which is incompatible.


I had the exact same error:

ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.2 which is incompatible.

Then I did the following three steps and it worked:

1) pip uninstall tensorflow-tensorboard 2) pip uninstall tensorflow-gpu 3) pip install --upgrade tensorflow-gpu

Then somehow I found this result. It seems that it has been fixed.

Installing collected packages: tensorflow-gpu, setuptools
Found existing installation: setuptools 40.6.2
Uninstalling setuptools-40.6.2:
Successfully uninstalled setuptools-40.6.2

Successfully installed setuptools-42.0.2 tensorflow-gpu-2.0.0

tensorflow 1.8.0 has requirement tensorboard<1.9.0,>=1.8 , tensorboard 2.0.1 has requirement setuptools>=41.0.0, but you'll have @ vidyakabadi The error is what it says; tensorboard requires version� To upgrade setuptools, try one of the following two options: Option 1: First uninstall and then install the newer version. pip3 uninstall -y setuptools; pip3 install setuptools>=41.0.0; Option 2: pip3 install --upgrade setuptools


I just did a pip install setuptools --upgrade

then

pip install tensorflow

ERROR: tensorflow 1.9.0 has requirement setuptools<=39.1.0, but , ERROR: tensorflow 1.9.0 has requirement setuptools<=39.1.0, but you'll tabulate-0.8.2 tensorboard-1.9.0 tensorflow-1.9.0 termcolor-1.1.0� I apologize because this probably has an easy fix, but I am not overly familiar with Python and could not find it described in the other issues. Describe the bug I'm in the process of install axondeepseg ERROR: tensorflow 1.9.0 has requirement setuptools<=39.1.0, but you'll have setuptools 41.0.1 which is incompatible. To Reproduce


Uninstall TensorFlow using command pip uninstall tensorflow

Re-install it using the command pip install --upgrade tensorflow

noob trying to install Tensorflow for a class, ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.2 which. 프로필 � 향냥이. 2020. 5. 18. 22:26. 이웃추가. 본문 기타� sudo -H pip install --upgrade tensorflow tensorflow-tensorboard. and i got this error: tensorflow 1.8.0 has requirement tensorboard<1.9.0,>=1.8.0, but you'll have tensorboard 1.6.0 which is incompatible. also whatever i do i dont know why i still cannot import tensorboard_logger


Three steps and it worked as it said earlier

    > pip uninstall tensorflow-tensorboard 
    > pip uninstall tensorflow-gpu
    > pip install --upgrade tensorflow-gpu

But in case if you got error uninstalling "wrapt" try this two below command and hopefully everything works fine.

conda update --all
pip install --upgrade tensorflow==2.0.0-beta1

Refer to this original issue: https://github.com/tensorflow/tensorflow/issues/30191

tensorboard 1.14.0 has requirement setuptools>=41.0.0, but youll , i have python 3.7 in CMD i ran 'pip install tensorflow' generated this after a bunch of tensorboard 1.14.0 has requirement setuptools>=41.0.0, but you'll have� For anaconda installation, first pick a channel which has the latest version of tensorflow binary. Usually, the latest versions are available at the channel conda-forge. Then simply do: conda update -f -c conda-forge tensorflow


Modify the METADATA file of tensorboard. Let it not complain the version of setuptools.

This solution works on MacOS. Edit file

/Library/Python/3.7/site-packages/tensorboard-2.0.2.dist-info/METADATA

Change "Requires-Dist: setuptools (>=41.0.0)" to "Requires-Dist: setuptools (>=40.0.0)"

Then it will not report the error.

更新setuptools版本:EROR: tensorboard 2.0.2 has requirement , "ERROR: tensorboard 2.1.1 has requirement setuptools>=41.0.0, but you'll have setuptools 36.4.0"解决办法 � 安装tensorflow过程中遇到如下问题� System information Have I written custom code (as opposed to using a stock example script provided in TensorFlow): No OS Platform and Distribution (e.g., Linux Ubuntu 16.04): Linux Ubuntu 16.04 TensorFlow installed from (source or binary


How to upgrade setuptools for tensorflow (Python), ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but youll have setuptools 40.6.3 which is incompatible.解决方法:_tensorboard� ERROR: tensorboard 1.14.0 has requirement setuptools>=41.0.0, but you'll have setuptools 40.8.0 which is incompatible. Faylixe self-assigned this Nov 4, 2019 Faylixe added bug distribution help wanted pip labels Nov 4, 2019


python, ERROR: tensorboard 2.0.0 has requirement setuptools>=41.0.0, but you'll have setuptools 39.0.1 which is incompatible. How can I upgrade� tensorflow-tensorboard 1.5.0 has requirement bleach==1.5.0, but you'll have bleach 2.1.2 which is incompatible. tensorflow-tensorboard 1.5.0 has requirement html5lib==0.9999999, but you'll have html5lib 1.0.1 which is incompatible


Authorize with GitHub - Show notebooks in Drive, ERROR: tensorboard 2.0.2 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.2 which is incompatible. 然后,我执行了以下三个步骤,并且成功�