Getting the following error while executing expo init command

expo init not working
error while executing ls-remote
expo cli
expo init awesomeproject
syscall spawn
expo install
run expo project
npm err enoent undefined ls-remote
Installing dependencies...
npm WARN deprecated core-js@1.2.7: core-js@<2.6.5 is no longer maintained. Please, upgrade to core-js@3 or at least to actual version of core-js@2.
npm ERR! path git
npm ERR! code ENOENT
npm ERR! errno ENOENT
npm ERR! syscall spawn git
npm ERR! enoent Error while executing:
npm ERR! enoent undefined ls-remote -h -t ssh://git@github.com/expo/react-native-maps.git
npm ERR! enoent
npm ERR! enoent
npm ERR! enoent spawn git ENOENT
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\SAMSUNG\AppData\Roaming\npm-cache\_logs\2019-04-01T08_16_06_470Z-debug.log
Process exited with non-zero code: 1
Set EXPO_DEBUG=true in your env to view the stack trace.

Please make sure, that you have git installed. NPM requires git for installing some of the packages. You can check if git is installed via:

git --version

If so, according to the reported issue, removing and reinstalling node_modules should help:

rm -rf node_modules && npm install

You can also try to resolve the issue with yarn:

brew install yarn
npm uninstall -g create-react-native-app
yarn global add create-react-native-app

expo init doesn't work. � Issue #280 � expo/expo-cli � GitHub, i installed nodejs, then installed expo by > npm install expo-cli I got the solution for following error when I run expo init (in ubuntu 18.04) For Permission Access issues use --unsafe-perm with the command along with sudo. Installing javascript dependencies can't get completed while I init a new project� I followed the first steps and I ran into some issues on the command line: expo init AwesomeProject Here's the log : Choose a template: expo-template-tabs √ Please enter a few initial configuration values.

It appears to be a core-js version issue.

In package.json, check "expo-core": "version" and if it is lower than the error:You correct the version to fit the error.

and rm -rf node_modules && npm install

or

npm install -g expo-cli

Once you've done it, try running a new expo init.

Expo Init Error with error code 1 � Issue #318 � expo/expo-cli � GitHub, Expo Init Error with error code 1 #318 its official website, https://facebook.github .io/react-native/docs/getting-started. version 6.6.0; Install Expo by executing npm install -g expo-cli; Run expo init AwesomeProject and the error will appear Command failed: /usr/bin/git clone --depth=1 -q -b v0.22.1-exp.0� Navigate to the directory you want to create your new project and do expo init "project-name". When the init ask for whether you want to use yarn, select yes; Doing the above steps makes the expo init successful on my laptop. 👍

Just check that you've git installed on your system. otherwise, download it

Install git from here - https://git-scm.com/downloads

Your problem will be solved cheers! :)

First Expo project throwing error after npm start, It installed with the following output. After this, expo init command worked. But when I run expo start in a project folder I get the below output. I don't know what� For some reason the init command (or one of the libraries) is not getting the proxy information and hence fails. I have worked around by cloning the repo and performing a local build which uses the local environment variables during compilation. I believe the binaries need to have a flag to get the proxy variables passed through to all the

The default expo-template-blank template points react-native to their own Github repo - installing from a Github repo might cause the NPM to hang or err out for various reasons.

To work around this ctrl-c to interrupt initialization when it proceeds to install the dependencies after the project scaffolding is done, edit the package.json to install react-native from the NPM registry - for example this is how my dependencies look:

 "dependencies": {
    "expo": "^35.0.1",
    "react": "^16.8.3",
    "react-dom": "^16.8.3",
    "react-native": "^0.59.10"
//...

Then manually do npm i to install the dependencies and enjoy.

This command requires Expo CLI - react-native - html, When I try to run the expo command I get an error that the system cannot find the react-native-cli react-native init ProjectName and get the following error error� Open Expo Client on your device. Scan the QR code printed by expo start with Expo Client (Android) or Camera (iOS). You may have to wait a minute while your project bundles and loads for the first time.

This shows when you dont have git installed. You can follow any of the answers above to get it working on local. But if you're facing this issue in deploying a node app, check the node image you're using for deployment. If it is node: alpine then u will get this error.

To fix it, you can use node:carbon image.

Installation, In addition to the command-line interface (CLI) it also has a web-based graphical user Expo CLI globally, you can do this by running the following command:. On Aug 26, 2017 11:09 PM, "Abed Kibbe" ***@***.***> wrote: I have tried the four steps, but it wont work. npm version 4.6.1 node version 6.11.2 ubuntu 16.04.2 without yarn Here's the stack trace: See https://git.io/v5vcn for more information, either install watchman or run the following snippet: sudo sysctl -w fs.inotify.max_user_instances=1024 sudo sysctl -w fs.inotify.max_user_watches=12288

How can i solve this error: error: unknown option , a project properly, I am now getting the following error when running yarn start: If the latter then you can also try creating a new project with expo init -native- community\cli\build\commands\server\runServer.js:82:58) at� ***Command :: expo init *** After the name specified, it will run and install the npm dependencies normally but in my case, it just shows the following error: npm ERR! code 1

Getting Started � React Native, Then run the following commands to create a new React Native project called expo init AwesomeProject cd AwesomeProject npm start # you can also use: expo start you get started quickly, but before committing to building your app with Expo CLI, If you get an error like Cannot find module 'npmlog' , try installing npm� Hi, I have tried to use the scotch box in my windows 10 machine for last two days. Every time I git clone and vagrant up I'm getting the following error: Bringing machine 'default' up with 'virtualbox' provider ==> default: Importing

Fullstack React Native: Getting Started with React Native, With this simple app we'll cover some essentials of React Native including: code for copying and pasting longer examples or debugging unexpected errors. yarn init creates a package.json file and adds it directly to our project. yarn Once yarn is installed, let's run the following command to install the Expo CLI globally:. SAM CLI error: "no such option: --app-template" When executing sam init, you see the following error: Error: no such option: --app-template This means that you are using an older version of the AWS SAM CLI that does not support the --app-template parameter.

Comments
  • Checking for git and if not present installing it is already given as suggestion in the answer from April 1st here including a link to installation instructions. Please only add answers that brings new suggestions in.