Anaconda-Python RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a supported version

requestsdependencywarning: urllib3 (1.25.8) or chardet (3.0.4) doesn't match a supported version!
importerror: cannot import name dependencywarning
requestsdependencywarning: urllib3 17 1 or chardet 2.0 1 doesn t match a supported version
urllib3 1.25 1
chardet-3.0 4 py2 py3 none-any whl
chardet 3.0 4 github

I am getting a warning that doesn't seem to be covered in any other online resource. I have Anaconda Python 3.6 installed. The warning I get when I create a new Conda environment is:

RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a supported version!
  RequestsDependencyWarning)

I thought it was a pip issue because of a possibly related question (not sure if it actually is: How to fix urllib3 RuntimeError: Requests dependency 'urllib3' must be version >= 1.21.1, < 1.22?). But I get the same issue:

 $ conda update pip
/Users/VincentLa/anaconda3/lib/python3.6/site-packages/requests/__init__.py:80: RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a supported version!
  RequestsDependencyWarning)
pip install --upgrade chardet

may help.

urllib3 (1.22) or chardet (2.2.1) doesn't match a supported version , Anaconda-Python RequestsDependencyWarning: urllib3 (1.22) ou chardet RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a  ii python-urllib3 1.9.1-3 all HTTP library with thread-safe connection pooling for Python ii python-chardet 2.3.0-1 all universal character encoding detector for Python2 I don't have no more ideas

The only combination that helped me was (taken from http://blog.51cto.com/binuu/1948043):

pip uninstall urllib3    
pip uninstall chardet
pip install requests

All other ones were unable to update chardet, as "it was already updated" (it appears, that info was taken for that lib in another location).

Anaconda-Python RequestsDependencyWarning: urllib3 (1.22), La advertencia que recibo cuando creo un nuevo entorno de Conda es: RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a  Le Magazine a pour vocation de faire acquérir la maîtrise de la Science des données à travers la mise à disposition et la vulgarisation d’une panoplie de ressources algorithmiques, logicielles et analytiques qui répondront aux attentes aussi bien des néophytes que des experts.

I had this same issue.

The cause is from your python instance being confused about multiple libraries with different versions in different locations.

This Ubuntu scenario that i had will also yield your error.

a) Ubuntu Python libraries installed via sudo apt-get install python3-requests will download source to /usr/lib/python*/dist-packages

b) Ubuntu Python libraries installed via sudo -H pip3 install requests will download source to /usr/local/lib/python*/dist-packages

c) OS PATH & PYTHON_PATH point to /usr/lib:/usr/local/lib

d) You get a runtime warning because of python's library selection precedence. It therefore warns you that your current library in /usr/local/lib is incompatible with the dependancy located in the parent os library location /usr/lib

For your specific scenario, it seems you are using MacOS which has - python installed out of the box, and a custom python installation via anaconda.

To prevent conflict i recommend you remove the os python path /usr/lib/python when starting anaconda's python instance.

This will make sure it only uses anaconda's python libraries only, and not from your os.

urllib3 (1.25.1) or chardet (3.0.4) doesn't match a supported version , I'm seeing this on Travis, with python 3.7: RequestsDependencyWarning: urllib3 (​1.25.2) or chardet (3.0.4) doesn't match a supported version! RequestsDependencyWarning: urllib3 (1.25.2) or chardet (3.0.4) doesn't match a supported version! Copy link Quote reply mirmirik commented May 9, 2019

What worked for me:

pip uninstall requests
pip install requests
pip uninstall docopt # maybe would not be installed.
pip install docopt # install it nonetheless.

Cannot launch navigator, This issue tracker is for issues with installing Anaconda or Miniconda or with RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a config files : conda version : 4.4.7 conda-build version : 3.2.2 python version  Other info. Please also note the dependency problems on packages urllib3 and chardet, displayed after each conda command. I do not known what causes them nor how to fix them.

The following code worked for me:

pip install --upgrade requests

User Tedo Vrbanec, No questions with score of 5 or more. Top Answers. 15 · Anaconda-Python RequestsDependencyWarning: urllib3 (1.22) or chardet (2.3.0) doesn't match a  RequestsDependencyWarning) I have tried upgrading chardet, urllib3 and requests but nothing is working, anyone know how can I fix this? Edit: RequestsDependencyWarning: urllib3 (1.9.1) or chardet (2.3.0) doesn't match a supported version <-- This did not fix my problem.

requestsdepenencywarning: urllib3 (1.24.2) or chardet (3.0.4) doesn't match a supported version! #1571 nsperic opened this issue Apr 22, 2019 · 5 comments Comments

I start the container root@compute02:~# docker run --name flexget -e WEB_PASSWD=test -e TORRENT_PLUGIN=deluge cpoppema/docker-flexget, the update process is long but it finnaly completes.

Dismiss Join GitHub today. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together.

Comments
  • Note for anyone else coming across this thread. I ended up uninstalling and reinstalling anaconda.
  • FYI, this has nothing to do with Anaconda because it is happening on other systems without Anaconda.
  • Works for me as well.
  • (I also had to do pip install --upgrade urllib3) but this worked!
  • Worked for me in python 3.7
  • Didn't worked until I added --no-cache-dir option to pip install requests
  • Can you outline the steps to remove the os python path /usr/lib/python when starting anaconda's python instance?