Xcode 11 Upgrade | Could not find iPhone X simulator | XRPackageModel 9.0.omo

Anyone else getting this since upgrading from Xcode 10.3 to Xcode 11 when running react-native run-ios and any idea to get back up and running?

CoreData: annotation:  Failed to load optimized model at path '/Applications/Xcode.app/Contents/Applications/Instruments.app/Contents/Frameworks/InstrumentsPackaging.framework/Versions/A/Resources/XRPackageModel.momd/XRPackageModel 9.0.omo'
error Could not find iPhone X simulator

I remember this happening before and amending:

node_modules⁩ ▸ ⁨@react-native-community⁩ ▸ ⁨cli⁩ ▸ ⁨build⁩ ▸ ⁨commands⁩ ▸ ⁨runIOS⁩ ▸ findMatchingSimulator.js

As a current workaround, updating:

if (simulator.availability !== '(available)' && simulator.isAvailable !== 'YES') {
  continue;
}

To:

if (simulator.availability !== '(available)' && simulator.isAvailable !== true) {
  continue;
}

Seems to get me back up and running.

Hopefully this gets updated pronto.


"react-native": "^0.59.3"

Question: Xcode 11 and RN 0.58.6 / not find Iphone X , React Native version: 0.58.6 react:16.6.3 xcode: Version 11.1 (11A1027) Question: Xcode 11 and RN 0.58.6 / not find Iphone X Simulator #26677 /​Versions/A/Resources/XRPackageModel.momd/XRPackageModel 9.0.omo'. Could not find iPhone X simulator. Error: Could not find iPhone X simulator react-native run-ios returns Error: Could not find iPhone X simulator 👍 44 😄 5 🎉 21 ️ 15 🚀 2 👀 2 reactjsexample mentioned this issue Sep 11, 2019

Xcode 11 can't see iPhoneX or Other Simulator - First need to add new Simulator - Then click on the bottom left of the Simulator then choose device you wanna add 😎

react-native run-ios can not find any simulator · Issue #23282 , react-native-cli: 2.0.1 react-native-git-upgrade: 0.2.7 Error: Could not find iPhone X simulator at resolve (/Users/eric/. By default react native will run simulator iPhone 11 Pro Max. See list current simulator: If doesn't work after add iPhone X simulator in XCode McMainsLiam commented on Jan 9  React Native version: 0.58.6 react:16.6.3 xcode: Version 11.1 (11A1027) node:12.11.0 Steps To Reproduce My Xcode run App is success Execute the command ‘react-navite run-ios’ or 'npm run ios&#3

You can change the default simulator to use.

react-native run-ios --simulator="iPhone 11 Pro Max"

Could not find iPhone XXX simulator · Issue #21824 · facebook/react , "react-native-sound": "^0.10.9", "react-native-vector-icons": "^4.6.0", "react-​native-video": "^2.2.0", "react-navigation": "^2.3.0", After I downloaded Xcode 11 beta, this issue happened again! error Could not find iPhone X simulator react-native-community/cli#418 react-native upgrade this may need. 11 Xcode 11 Upgrade | Could not find iPhone X simulator | XRPackageModel 9.0.omo Sep 23 '19 10 Arrow keys do not work with firebase init command Apr 6 '17 View all questions and answers →

Open xcode and go to window > Device and Simulators... go to the Simulators tab and click the + in the bottom left, here you can add iphone X.

error Could not find iPhone X simulator · Issue #418 · react-native , create-react-native-web-app: 0.1.11 react-native-cli: 2.0.1 react-native-git-​upgrade: 0.2.7 react-native run-ios can not find any simulator facebook/react-​native#23282 the issue for me, as I couldn't find an iPhone X simulator to install in the GUI on Xcode 11. thinklinux commented on Oct 9, 2019  Hi Guys! I’m updating my app for iPhone X and in Xcode, the app is running and the notch is in the way! I have used code level support and did not help, I have gone through and I can’t find the problem.

The problem is that you are using a @react-native/cli version that doesn't detect XCode 11 simulators. You can either downgrade your XCode or install a @react-native/cli that supports it.

If you are not managing the version of @react-native/cli directly in your package.json you can simply remove your package-lock.json or yarn.lock file and install it again:

rm yarn.lock 
yarn install

or

rm package-lock.json
npm install

Can't find simulator - Xcode 9 - Mobile, I'm in the process of moving to Xcode 9 and although CircleCI prints out available simulators that contains: iPhone 7 (11.0) /Versions/A/Resources/​XRPackageModel.momd/XRPackageModel 9.0.omo' instruments[1071]: [MT] iOSSimulator: Could not launch simulator: -10825 2017-09-21 07:24:07.852  The last 2 days I've been banging my head on this, and since I had to dig through gitHub issues to find my fix, I'm putting it here so it will hopefully help someone else. I can run all of the other

Question: Xcode 11 and RN 0.58.6 / not find Iphone X , react-native:0.58.6 react:16.6.3 xcode: Version 11.1 (11A1027) node:12.11.0 --> .framework/Versions/A/Resources/XRPackageModel.momd/XRPackageModel 9.0.omo' Error: Could not find iPhone X simulator at Promise.then.udid.udid  1. ios 시뮬레이터 찾기 실패 react-native: 0.59.5 macOS xcode 10.xx 에서 11.0으로 업데이트 후 아래와 같이 나오면서 시뮬레이터로 실행이 안된다 info Found Xcode project NemocloudApp.xcodeproj CoreData:..

Could not find iPhone simulator after migrating from Xcode10 to , After the upgrade, their was a slight change in the simulator If you are experiencing the “Could not find iPhone X simulator error”, this is because iPhone X is used as default and maybe from your xcode, the iPhone X simulator is not installed. You can “ios”: “react-native run-ios — simulator='iPhone 11'”.

iPhone - Questions - Page 5 of 7, XCode 11 Upgrade | Could not find iPhone X simulator | XRPackageModel 9.0.​omo. Post author By Full Stack; Post date September 23, 2019 · No Comments on​ 

Comments
  • Sorry, reopened. I misinterpreted a duplicate answer posting, confusing two authors.
  • Did you find an answer?
  • We've had to downgrade back to Xcode 10.3 in the end based on the complexity of our dependencies, so back to running iPhone X simulator on all versions of iOS as normal. Back to playing the waiting game with a beady eye.
  • I get this error using instruments -s devices. Does any one have the same problem?
  • @PedroSilva This would make sense and is expected when it comes to reaching listing your iPhone X devices the same way react-native run-ios looks for the iPhone X by default. So in theory the temporary fix should solve.
  • what version of react-native?
  • ^0.59.3, mid-upgrading to ^0.60.5
  • please add it to your answer, thanks :)
  • @Ilario Oops yes very important detail - added
  • Thank you for your contribution, but this has already been covered, scroll down: stackoverflow.com/questions/58060484/…. I.e. This does not work.
  • But this is work for me and I just wanna share
  • This worked for my specific use case
  • Thank you for your contribution, yes this command runs a specified simulator, but this does not run the iPhone X simulator. In this context, X stands for 10, not any generic version.
  • Thank you for your contribution, but the iPhone X and subsequently other simulators are already added. Removing then re-adding them has no effect.
  • The iPhone X simulator wasn't already added in my specific use case, so this and the answer above were the solutions for me