Simulator is not available appcelerator studio

i am trying to run app which is build in titinium.js on simulator on ios but giving the following error.

[INFO] :   Writing index.json with listing of JS/JSON files
[INFO] :   Invoking xcodebuild
[INFO] :   Finished building the application in 25s 110ms
[INFO] :   Launching iOS Simulator

[ERROR] : Simulator is not available

App is not opening in simulator with 8.0.0.GA but open in the 8.1.* but some functionality does not work

Previously it was working in simulator.

Here is the details of environment

DesignBees-MacBook-Pro:~ designbee$ appc info

Appcelerator Command-Line Interface, version 7.1.1
Copyright (c) 2014-2019, Appcelerator, Inc.  All Rights Reserved.

Operating System
  Name                        = Mac OS X
  Version                     = 10.14.6
  Architecture                = 64bit
  # CPUs                      = 8
  Memory                      = 16.0GB

Node.js
  Node.js Version             = 10.16.3
  npm Version                 = 6.9.0

Appcelerator CLI
  Installer                   = 4.2.15
  Core Package                = 7.1.1

Titanium CLI
  CLI Version                 = 5.2.1
  node-appc Version           = 0.2.49

Titanium SDKs
  8.0.0.GA
    Version                   = 8.0.0
    Install Location          = /Users/designbee/Library/Application Support/Titanium/mobilesdk/osx/8.0.0.GA
    Platforms                 = iphone, android
    git Hash                  = 3726240fa2
    git Timestamp             = unknown
    node-appc Version         = 0.2.47

Mac OS X
  Command Line Tools          = installed

Intel® Hardware Accelerated Execution Manager (HAXM)
  Not installed

Java Development Kit
  Version                     = 12.0.1_12
  Java Home                   = /Library/Java/JavaVirtualMachines/jdk-12.0.1.jdk/Contents/Home

Genymotion
  Path                        = not found
  Genymotion Executable       = not found
  Genymotion Player           = not found
  Home                        = not found

VirtualBox
  Executable                  = not found
  Version                     = unknown

Android SDK
  Android Executable          = not found
  ADB Executable              = /Users/designbee/Library/Android/sdk/platform-tools/adb
  SDK Path                    = /Users/designbee/Library/Android/sdk

Android NDK
  NDK Path                    = not found
  NDK Version                 = not found

Android Platforms
  1) android-21
    Name                      = Android 5.0.1 **Not supported by Titanium SDK 8.0.0.GA**
    API Level                 = 21
    Revision                  = 2
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = 
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-21
  2) android-22
    Name                      = Android 5.1.1 **Not supported by Titanium SDK 8.0.0.GA**
    API Level                 = 22
    Revision                  = 2
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = 
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-22
  3) android-23
    Name                      = Android 6.0
    API Level                 = 23
    Revision                  = 3
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = x86
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-23
  4) android-24
    Name                      = Android 7.0
    API Level                 = 24
    Revision                  = 2
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = 
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-24
  5) android-25
    Name                      = Android 7.1.1
    API Level                 = 25
    Revision                  = 2
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = x86
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-25
  6) android-26
    Name                      = Android 8.0.0
    API Level                 = 26
    Revision                  = 1
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = 
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-26
  7) android-27
    Name                      = Android 8.1.0
    API Level                 = 27
    Revision                  = 1
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = x86
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-27
  8) android-28
    Name                      = Android 9
    API Level                 = 28
    Revision                  = 1
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = 
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-28
  9) android-29
    Name                      = Android 10 (not supported by Titanium SDK 8.0.0.GA, but may work)
    API Level                 = 29
    Revision                  = 1
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = 
    Path                      = /Users/designbee/Library/Android/sdk/platforms/android-29

Android Add-Ons
  None

Android Emulators
  Nexus 4 API 23
    ID                        = Nexus_4_API_23
    SDK Version               = Android 6.0 (API level 23)
    ABI                       = x86
    Skin                      = nexus_4
    Path                      = /Users/designbee/.android/avd/Nexus_4_API_23.avd
    SD Card                   = /Users/designbee/.android/avd/Nexus_4_API_23.avd/sdcard.img
    Google APIs               = yes
  Pixel 2 API 27
    ID                        = Pixel_2_API_27
    SDK Version               = Android 8.1.0 (API level 27)
    ABI                       = x86
    Skin                      = pixel_2
    Path                      = /Users/designbee/.android/avd/Pixel_2_API_27.avd
    SD Card                   = /Users/designbee/.android/avd/Pixel_2_API_27.avd/sdcard.img
    Google APIs               = no

Genymotion Emulators
  None

Connected Android Devices
  None

Xcode
  10.2.1 (build 10E1001) - Xcode default
    Install Location          = /Applications/Xcode.app/Contents/Developer
    iOS SDKs                  = 12.2
    iOS Simulators            = 12.2
    Watch SDKs                = 5.2
    Watch Simulators          = 5.2
    Supported by TiSDK 8.0.0.GA = yes
    EULA Accepted             = yes
    Teams                     = none

iOS Keychains
  login.keychain-db           = /Users/designbee/Library/Keychains/login.keychain-db
  System.keychain             = /Library/Keychains/System.keychain

iOS Development Certificates
  None

iOS App Store Distribution Certificates
  None

Apple WWDR Certificate
  Apple WWDR                  = installed

Development iOS Provisioning Profiles
  None

App Store Distribution iOS Provisioning Profiles
  None

Ad Hoc iOS Provisioning Profiles
  None

Enterprise Ad Hoc iOS Provisioning Profiles
  None

iOS Simulators
11.4
  iPad Air (ipad)
    UDID                      = FE30B24F-6BB9-4D2E-B0C3-E080D6EC1D2A
    Supports Watch Apps       = no
  iPad Air 2 (ipad)
    UDID                      = A1E9B240-F6FA-46EF-8DAC-FACF86133D5A
    Supports Watch Apps       = no
  iPad (5th generation) (ipad)
    UDID                      = 5E1EF611-0E7F-4A3B-80AA-202F007F1867
    Supports Watch Apps       = no
  iPad Pro (9.7-inch) (ipad)
    UDID                      = 34755173-9E9D-4393-B8FB-412D76A63B1C
    Supports Watch Apps       = no
  iPad Pro (12.9-inch) (ipad)
    UDID                      = F7366C49-4D28-423F-9570-084C2019A031
    Supports Watch Apps       = no
  iPad Pro (12.9-inch) (2nd generation) (ipad)
    UDID                      = 5614E66D-0DEA-4A09-9517-C66FC9A744A2
    Supports Watch Apps       = no
  iPad Pro (10.5-inch) (ipad)
    UDID                      = 8288A0FC-0711-4BD4-9D76-5918DADB8D29
    Supports Watch Apps       = no
  iPhone 8 (iphone)
    UDID                      = F922EDEB-77A0-4AF5-9758-D65FC3DDF9A4
    Supports Watch Apps       = yes
  iPhone 8 Plus (iphone)
    UDID                      = 7F818C69-63A2-4933-9E85-92E7E39A4C75
    Supports Watch Apps       = yes
  iPhone X (iphone)
    UDID                      = 148CADFC-A6AD-44B3-82E3-6DD9A96C1570
    Supports Watch Apps       = yes
  iPhone 5s (iphone)
    UDID                      = 455B45F1-E701-4FD3-BB54-B8483F18F66D
    Supports Watch Apps       = yes
  iPhone 6 Plus (iphone)
    UDID                      = 8F5E1690-ADF0-4077-B17E-65BE70AA8F17
    Supports Watch Apps       = yes
  iPhone 6 (iphone)
    UDID                      = D5CD717B-9E85-41CA-9886-FBC9AD8371D5
    Supports Watch Apps       = yes
  iPhone 6s (iphone)
    UDID                      = ADB19013-2CAB-4978-A546-E38BEA7B840C
    Supports Watch Apps       = yes
  iPhone 6s Plus (iphone)
    UDID                      = 6D696FDF-C0E3-4648-A2F2-CC7395B72645
    Supports Watch Apps       = yes
  iPhone SE (iphone)
    UDID                      = 262C2FD9-72E3-4D42-8539-1335CC066F96
    Supports Watch Apps       = yes
  iPhone 7 (iphone)
    UDID                      = FA749D64-0E29-42A5-BC41-1BA36218C958
    Supports Watch Apps       = yes
  iPhone 7 Plus (iphone)
    UDID                      = CCF43719-6923-475B-8D71-A6E60D25EA35
    Supports Watch Apps       = yes

12.2
  iPad Air (3rd generation) (ipad)
    UDID                      = 574C2384-25E5-4908-9ECB-13B3CE2FDAD7
    Supports Watch Apps       = no
  iPad Air (ipad)
    UDID                      = FEC98851-2059-49CA-ACFF-53B1C0A9F885
    Supports Watch Apps       = no
  iPad Air 2 (ipad)
    UDID                      = B2CE9C5D-A482-47E3-92FC-6E7D8BB3CCEB
    Supports Watch Apps       = no
  iPad (5th generation) (ipad)
    UDID                      = 326BBB80-DBBD-4FAE-95BE-411DF19570F4
    Supports Watch Apps       = no
  iPad Pro (9.7-inch) (ipad)
    UDID                      = 8A94D703-C119-468F-92BB-6291B965F612
    Supports Watch Apps       = no
  iPad Pro (12.9-inch) (ipad)
    UDID                      = 7840ABC3-298C-4F7F-A117-9BA6872700AC
    Supports Watch Apps       = no
  iPad Pro (12.9-inch) (2nd generation) (ipad)
    UDID                      = CDB1E905-5DF7-43F0-A11B-277852C2D628
    Supports Watch Apps       = no
  iPad Pro (10.5-inch) (ipad)
    UDID                      = 7D37AE8B-9142-402E-85FE-86F3B7EB4562
    Supports Watch Apps       = no
  iPad (6th generation) (ipad)
    UDID                      = B0E08123-6AC7-4F22-9EEE-D60FC6A2293B
    Supports Watch Apps       = no
  iPad Pro (11-inch) (ipad)
    UDID                      = 62EBC7CE-29EC-46F7-8454-D20A9343C1FD
    Supports Watch Apps       = no
  iPad Pro (12.9-inch) (3rd generation) (ipad)
    UDID                      = F29299CD-4ADB-4286-9A36-4EA0B3F8BE38
    Supports Watch Apps       = no
  iPhone 8 (iphone)
    UDID                      = ECF28DF4-B15D-4055-9E61-83FFEFBEC70D
    Supports Watch Apps       = yes
  iPhone 8 Plus (iphone)
    UDID                      = 01C12798-E252-47AA-97E8-EBE17CE80963
    Supports Watch Apps       = yes
  iPhone X (iphone)
    UDID                      = 328EA9D6-B598-4BE8-9808-5F3869DCEBE1
    Supports Watch Apps       = yes
  iPhone Xs (iphone)
    UDID                      = DAFAD514-2AE5-4CD0-B61C-AFB18C7F43AD
    Supports Watch Apps       = yes
  iPhone Xs Max (iphone)
    UDID                      = 3C0BEE43-4873-4BC0-8AE2-815DF2CD68AA
    Supports Watch Apps       = yes
  iPhone Xʀ (iphone)
    UDID                      = C917841E-FFFD-4782-93EF-3F37E0EC1BC7
    Supports Watch Apps       = yes
  iPhone 5s (iphone)
    UDID                      = FEA8787C-68E4-4BB2-90CC-03197DB339E6
    Supports Watch Apps       = yes
  iPhone 6 Plus (iphone)
    UDID                      = BFFE75F2-FF14-45A4-B0C2-0CD4791568C1
    Supports Watch Apps       = yes
  iPhone 6 (iphone)
    UDID                      = 7FADEADA-BC25-4E35-B944-397D6D4B557E
    Supports Watch Apps       = yes
  iPhone 6s (iphone)
    UDID                      = 775CFC7E-5F0E-4A87-9BFE-C65B6F78373D
    Supports Watch Apps       = yes
  iPhone 6s Plus (iphone)
    UDID                      = 490AC88D-AAA5-4365-A0D2-8C07CC6E11DE
    Supports Watch Apps       = yes
  iPhone SE (iphone)
    UDID                      = 5056D8F0-8483-49FF-BF29-4E1C33A60733
    Supports Watch Apps       = yes
  iPhone 7 (iphone)
    UDID                      = B4825C08-A906-472D-AD1F-16740BC4A6A8
    Supports Watch Apps       = yes
  iPhone 7 Plus (iphone)
    UDID                      = B4C55280-7F45-4F56-BEAA-8C7097194D97
    Supports Watch Apps       = yes

WatchOS Simulators
5.2
  Apple Watch Series 2 - 38mm (watch)
    UDID                      = 4B361CB5-83DB-4257-BBA1-309D7EDBB582
  Apple Watch Series 2 - 42mm (watch)
    UDID                      = D5EF7B25-CE1D-44E3-B5CD-822CB86922EF
  Apple Watch Series 3 - 38mm (watch)
    UDID                      = 8C62712B-B8B6-47A0-ADDC-DB4688086D9A
  Apple Watch Series 3 - 42mm (watch)
    UDID                      = F7C2090F-E672-4AD3-8694-9A8B86A67AD5
  Apple Watch Series 4 - 40mm (watch)
    UDID                      = AE3F43E6-033A-46EC-86C0-A74A480A791A
  Apple Watch Series 4 - 44mm (watch)
    UDID                      = 7752FAB2-D241-4018-A407-F243ECA73BD6

Connected iOS Devices
  None

Android Issues
  !  Unable to locate an Android NDK.
     Without the NDK, you will not be able to build native Android Titanium modules.
     If you have already downloaded and installed the Android NDK, you can tell Titanium where the
     Android NDK is located by running 'appc titanium config android.ndkPath /path/to/android-ndk',
     otherwise you can install it by running 'appc titanium setup android' or manually downloading
     from http://appcelerator.com/android-ndk.

  !  Android API Android 5.0.1 (android-21) is too old and is no longer supported by Titanium SDK
     8.0.0.
     The minimum supported Android API level by Titanium SDK 8.0.0 is API level 23.

  !  Android API Android 5.1.1 (android-22) is too old and is no longer supported by Titanium SDK
     8.0.0.
     The minimum supported Android API level by Titanium SDK 8.0.0 is API level 23.

  !  Android API Android 10 (android-29) is too new and may or may not work with Titanium SDK 8.0.0.
     The maximum supported Android API level by Titanium SDK 8.0.0 is API level 28.

iOS Issues
  !  Unable to find any valid iOS development provisioning profiles.
     This will prevent you from building apps for testing on iOS devices.
     You will need to log in to http://appcelerator.com/ios-dev-certs with your Apple Developer
     account, then create, download, and install a profile.

  !  Unable to find any valid iOS adhoc provisioning profiles.
     This will prevent you from packaging apps for adhoc distribution.
     You will need to log in to http://appcelerator.com/ios-dist-certs with your Apple Developer
     account, then create, download, and install a profile.

  !  Unable to find any valid iOS distribution provisioning profiles.
     This will prevent you from packaging apps for AppStore distribution.
     You will need to log in to http://appcelerator.com/ios-dist-certs with your Apple Developer
     account, then create, download, and install a profile.

  !  Unable to find any valid iOS developer certificates.
     This will prevent you from building apps for iOS devices.
     You will need to log in to http://appcelerator.com/ios-dev-certs with your Apple Developer
     account, then create, download, and install a certificate.

  !  Unable to find any valid iOS production distribution certificates.
     This will prevent you from packaging apps for distribution.
     You will need to log in to http://appcelerator.com/ios-dist-certs with your Apple Developer
     account, then create, download, and install a certificate.

You should be able to generate an IPA or APP and install it on the simulator manually using XCode, that should allow you bypass the issue altogether.

To create an APP file simply build your project for release and it should be in the build directory. More details here: https://docs.appcelerator.com/platform/latest//#!/guide/Distributing_iOS_apps

To install and run the APP file

xcrun simctl install booted /path/to/Your.app xcrun simctl launch booted com.yourcompany.yourapp

To create the IPA you need to

... ensure the requirements have been satisfied and select the desired SDK version. For ad hoc and in-house distribution, specify the package format as ipa and a path to copy the package to. Click Next.

https://docs.appcelerator.com/platform/latest//#!/guide/Distributing_iOS_apps

To install the IPA

You need to extract the payload and copy it into your simulators folder

I found an .ipa file that I wanted using iTunes and copied it over to my desktop.

After that I changed the extension to .zip and extracted it.

Next I found the Payload folder and moved the application inside to my desktop.

Finally I moved that application to my iPhone simulators applications folder found at:

HD
Applications
Xcode.app (right click - Show Package Contents)
Contents
Developer
Platforms
iPhoneSimulator.platform
SDKs
iPhoneSimulator6.0.sdk
Applications

Hope this helps! (Note: Some apps crash more often than others.)

Details here: https://stackoverflow.com/a/9385507/2680506

Simulator option not available in Run mode · Issue #120 , Just started Atom afresh and couldn't see any iOS simulators. Everything is fine in my system as all simulators were there till y'day and Appc Studio is with Xcode 9.4.1 (https://jira.appcelerator.org/browse/DAEMON-259),  Just reinstalled Appcelerator Studio after a year not using it. Started a brand new project. When I run it I get: [ERROR] Unable to find any Xcode installations that supports iOS Simulator 12.4.

I still wish the original problem was solved (ERROR: Simulator not available) but the answer from DaveS helped me get to where I could load it on the simulator.

After building with appc, the correctly built .app file was in myproject/build/iphone/build/Products/Debug-iphonesimulator then I could just drag and drop that file to the simulator (or probably use the command in Dave's answer but didn't try yet) and the app is properly running on my device.

Related/Current Ticket

Simulator is not available appcelerator studio, You should be able to generate an IPA or APP and install it on the simulator manually using XCode, that should allow you bypass the issue  Try running this command: That should list all the simulators available for iOS 12.4. If there are none, then you obviously need to create some. If there are some, then perhaps Appcelerator is looking in the wrong place.

I believe the issue might be related to the newest XCode update, where the 12.9 2nd Generation ipad was removed as a simulator option. These are the current options with the latest update

[AC-6390] Simulator is not available after app build, Simulator is not available after app build. Log In Eventually deinstalling / reinstalling everything (Appcelerator, Xcode, Titanium CLI, etc). Getting help overview. This guide walkthroughs the setup of Axway Appcelerator Studio (Studio). Although using Studio is not mandatory for mobile application development, which can be done using a text editor and our command-line tools, we believe that it is the most effective way to speed up your development process and increase your productivity when building quality applications using Alloy

Cannot load iOS 12.0 simulator after upgrading , Appcelerator Studio 5.0.0 [ERROR] : Simulator is not available OBJROOT=/​Volumes/BOX/Projects/Titanium/WorkZone/build/iphone/build/  The Visual Studio simulator for UWP apps does not run in an isolated environment on your local machine. Therefore, errors that occur in the simulator, such as a non-recoverable system-wide error, can also affect the entire machine.

You need to manually update ioslib.

I did:

npm install ioslib

and then copied everything on top of the appcelerator sdk's node_modules directory.

iOS 12: Simulator does not boot with Xcode 10, iOS 12: Simulator does not boot with Xcode 10. Log In. Export We are using ioslib 1.7.5 on 7_4_X so this fix should be there. Show. cwilliams  However, if the tiapp.xml file does not contain an SDK version or the app.sdk setting is not set with titanium config, then the application will be built with the SDK select version. If the SDK selected is ever deleted or if you are missing CLI commands, select a new active SDK.

iOS Simulators not showing as run option, When I open AppC Studio I see the option to run on Android Emulators as well as Genymotion and Mobile Web. I do not see the iOS Simulator  This page describes how to use the Appcelerator Studio LiveView tool to preview changes you actively make in your application on a device or simulator. Introduction The Appcelerator Studio LiveView tool displays updates of your application as you actively add, modify or replace the files in the project, such as changing your code in the Editor.

Running Titanium Applications, If not, you need to click the Launch button to start the build process. If you do not see your device or simulator listed in the Target drop-down list, select Refresh  At this moment, the iOS Simulator does not let you to simulate 3D Touch events. So to run and test the sample you will need an iPhone 6S to build to. NOTE: There is a tweak available to simulate the Quick Actions in iOS Simulator.

Are you ready for Xcode 11 and iOS 13 Development?, This allows you to continue to test your apps on iOS 12.x simulators as well or this command, if you are using the open-source Titanium CLI tool: If you do not already have Xcode 11 selected as active, you will need to run 

Comments
  • Weird, I'm encountering the same issue in 8.2.0
  • Eh, I got it to install but it crashes because it was built with the wrong architecture for the simulator.
  • Did you try a .app?
  • Yeah, I just moved that file over to the simulator. I also tried doing so through the terminal. Both installed fine but crashed every time. I don't think I skipped any steps but it's possible. I used the ipa from a coworker and tried that then tried using the zip method to get the .app file.
  • You should try building the app directly, not getting it from the IPA
  • But isn't the newest 11? I'm using 10.0 and it looks like the OP is using 10.2.1
  • Honestly I have no idea about the specifics of Titanium or what you are trying to do. I was just googling around to see how I am suppose to provide screenshots for a simulator no longer provided in Xcode and saw this post. It looked like the error might be caused by the simulator no longer being available. Best of luck.