The current .NET SDK does not support targeting .NET Core 2.2

I am working on asp.net core 2.2.I am using visual studio 2017.When i create the .net core web application, then interface gives an error,that current sdk does not supported targeting .net core 2.2? And when i go to project properties, then there is not targeting framework .net core 2.2 in targeting framework lists?

Install .NET Core 2.2 SDK from here.

Note, as per Kirk's and Marc's comments, you probably need to use v2.2.106.

The Current .Net SDK does not support targeting .Net Core 2.2 , This project cannot get built and there are 4 same errors state "The current .NET SDK does not support targeting .NET Core 2.2. Either target . Have the same problem enabling this does not show up 2.2. Even more:msbuild can't target 2.2 and says .NET SDK does not support targeting Net core 2.2 while i have 2.2.3 installed – Tom Tavernier Apr 5 '19 at 9:03

I found the working solution for this problem here

All credit to Vijay Ramakrishnan

Issue details: 2.1.6xx & 2.2.2xx version of the sdks are only supported on Visual Studio 2019. VS 2017 needs 2.1.5xx & 2.2.1xx versions of the sdk.

How to fix the issue? Install 2.1.5xx version of the SDK if you are targetting a 2.1 app Install 2.2.1xx version of the SDK if you are targetting a 2.2 app.

You can get the install links from here - https://dotnet.microsoft.com/download/dotnet-core/2.2

Hope this helps!

.NET SDK does not support targeting .NET Core 2.2 � Issue #180 , NET Core 2.0 or lower, or use a version of the .NET SDK that supports .NET Core 2.1." I don't see ".net core 2.1" in my target framework. I don'� Error List : The current.NET SDK does not support targeting.NET Core 2.2. Either target.NET Core 2.1 or lower, or use a version of the.NET SDK that supports.NET Core 2.2. Right click the project to open Properties > Application, the content of Target framework is blank and there is no ‘.NET Core 2.2’ option under the dropdown list.

I fixed it by running the following command:

dotnet build 

using command prompt within the project.

The current .NET SDK does not support targeting .NET Core 2.1 , NET SDK does not support targeting . NET Core 2.2. Either you have not installed the latest SDK or your global. json in the project/solution folder is pointing to an older version. Severity Code Description Project File Line Suppression State Error NETSDK1045 The current.NET SDK does not support targeting.NET Core 2.2. Either target.NET Core 2.1 or lower, or use a version of the.NET SDK that supports.NET Core 2.2.

It actually needs "2.2.1nn", where "nn" are any integers. The latest 2.2.1nn at this time is 2.2.109. See: Issue-3124

.NET Core SDK   .NET Core Runtime   Compatible Visual Studio    MSBuild     Notes
2.1.5nn     2.1     2017    15  Installed as part of VS 2017 version 15.9
2.1.6nn     2.1     2019    16  Installed as part of VS 2019
2.2.1nn     2.2     2017    15  Installed manually
2.2.2nn     2.2     2019    16  Installed as part of VS 2019
3.0.1nn     3.0 (Preview)   2019    16  Installed manually

Download .net sdk

How To Target .NET Core 2.2, The Current .NET SDK does not support targeting .NET Core 3.0 NET SDK that supports .NET Core C:\Program Files\dotnet\sdk\2.2.3\sdks\Microsoft.NET. NET Core SDK (2.x) to compile a project that is targeting .NET� the current.net sdk does not support targeting.net core 2.2 Closed - Not a Bug visual studio 2017 version 15.9 windows 10.0 Setup rmathis [MSFT] reported Nov 13, 2018 at 08:40 PM after upgrade to 15.9.0, getting this error when trying to build an existing app that is built on netcore 2.2+ I reinstalled the netcore SDK but didn't fix things.

The Current .NET SDK does not support targeting .NET Core 3.0, The current .NET SDK does not support targeting .NET Core 2.2. Reply � wilna � Avatar. Total Posts: 3; Karma: 15; Joined: 4/5/2020; Location: Namibia. Posted: 4 � The current.NET SDK does not support targeting.NET Core 2.2. Either target.NET Core 1.1 or lower, or use a version of the.NET SDK that supports.NET Core 2.2.

Resolved- The current .NET SDK does not support targeting .NET , Error NETSDK1045 The current .NET SDK does not support targeting .NET Core 2.2. Either target .NET Core 2.1 or lower, or use a version of� The current.NET SDK does not support targeting.NET Core 2.2. Then you currently aren’t running on the latest SDK. Either you have not installed the latest SDK or your global.json in the project/solution folder is pointing to an older version.

Solved: NETSDK1045: The current .NET SDK does not support , The Current .Net SDK does not support targeting .Net Core 2.2 Target .Net Core 2.1 or Lower image.png. I installed dotnet-sdk-2.2.203-win-x64.exe. But I can� Worked for NETSDK1045 The current .NET SDK does not support targeting .NET Core 3.0. when trying out blazor – Vamsi J Mar 24 '19 at 13:47 1 There is no such option in the VS v.16.1 – Eugene Maksimov May 29 '19 at 9:13

Comments
  • So what is you problem? Simply install .net Core 2.2 SDK
  • Have you tried this devblogs.microsoft.com/dotnet/…
  • @vasily.sib i have installed .net ccore 2.2 SDK, but it does not show in project properties targeting framework.
  • If you're using VS2017, make sure you use .NET Core SDK 2.2.106 or lower, as 2.2.202 and higher only work with VS2019 right now.
  • Thanks @KirkLarkin, 2.2.1.06 worked for me.
  • see Kirk's comment about versions, though - you probably want to scroll down a bit to 2.2.106
  • Thanks to all the guys, special thanks to @kirk Larkin ,there was a problem with .net core SDK version, 2.2.1.06 worked successfully.
  • @Ali: Please check this answer if it helped you.