How to install my package in Laravel 5.8? "Your requirements could not be resolved to an installable set of packages."

I entered composer require larabook/gateway but the package was not be installed and I received the following error.

Your requirements could not be resolved to an installable set of packages.

If C:\php\php.ini is your .ini file, then open it

Find this line

;extension=php_fileinfo.dll

and change it to this

extension=php_fileinfo.dll

Installation - Laravel, Packages are the primary way of adding functionality to Laravel. when it is installed, creating a convenient installation experience for your package's users. DB_CONNECTION=mysql DB_HOST=127.0.0.1 DB_PORT=3306 DB_DATABASE=laravel DB_USERNAME=laravel DB_PASSWORD=secret_password. Now you should get into a terminal then go to your directory and use laravel built in artisan to start your application. php artisan serve. This is the end of our step by step guide to install laravel 5.8 on linux

I had this same issue when I was trying to create a Laravel project in PHP 7.4.

From your PHP location, go to php.ini, double click on it and look for extension=php_fileinfo. The latest version of PHP does not come with .dll, so if it is not there don't worry about it. After that, close the notepad, click on save and restart your cmd.

if you are using XAMPP, on the same line that runs Apache on port 80, 443, go to config click on it, navigate to PHP(php.ini) and carry out the same step. Once done, close the notepad file and restart. It should work fine.

Package Development - Laravel, Note: Place Composer's vendor bin directory in $PATH so that Laravel 5.8 installer.exe can be easily located on your local system. The next thing you should do after installing Laravel is set your application key to a random string. If you installed Laravel via Composer or the Laravel installer, this key has already been set for you by the php artisan key:generate command. Typically, this string should be 32 characters long. The key can be set in the .env environment file.

first run

composer update

then removing the semicolon from the line extension=php_fileinfo.dll of php.ini file

and rerun the

composer require larabook/gateway

A Complete Guide to Laravel 5.8 Installation, After a new Laravel install we create a new folder called packages inside the root of our app. We are going to use this packages folder instead� Installing Laravel 5.8 Using the Laravel Installer To install Laravel 5.8, you will first have to download the Laravel installer using Composer via the following command: composer global require

How to create a Laravel Package, here in laravel 5.8 tutorial we will learn how to install laravel with composer with simple if Duration: 8:44 Posted: 28 Feb 2019 #Laravel 5.8 Installation. We have split this installation into 3 parts. Pre-requisites; Installation; after setup # Pre-requesites To use JOSH which is a developer-oriented product, you should have a basic idea of following tools and make sure they are installed in your system.

Laravel 5.8 tutorial #1- Installation and getting start, Laravel is the fastest growing PHP framework right now. With so many built in features and Duration: 5:22 Posted: 21 Feb 2019 I want to install zizaco/entrust package in laravel 5.8, in their github page it was said to include "zizaco/entrust": "5.2.x-dev" in composer.json file and run composer update

Laravel 5.8 Tutorial From Scratch - e01 - Installation, You will need Laravel 5.8+ installed on your machine. In this tutorial, we will learn how to build a Laravel package with Vue.js and Pusher. The� If you want to remove any package from your Laravel Project then you can easily remove the package by following below steps: Step 1: You must know the package name which you want to remove. If you don't know complete package name then you can open your project folder and go to composer.json file and check name in require an array

Comments
  • in php 7.3.5, just uncomment. extension=fileinfo
  • thanks my bro. I did your orders but I got an error :Your requirements could not be resolved to an installable set of packages. Problem 1 - league/flysystem 1.0.51 requires ext-fileinfo * -> the requested PHP extension fileinfo is missing from your system. - league/flysystem 1.0.51 requires ext-fileinfo * -> the requested PHP extension fileinfo is missing from your system. - league/flysystem 1.0.51 requires ext-fileinfo * -> the requested PHP extension fileinfo is missing from your system. - Installation request for league/flysystem (locked at 1.0.51) -> satisfiable by
  • - Installation request for league/flysystem (locked at 1.0.51) -> satisfiable by league/flysystem[1.0.51]. To enable extensions, verify that they are enabled in your .ini files: - C:\xampp\php\php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode. Installation failed, reverting ./composer.json to its original content. please help me thanks
  • and Iuse php7 and laravel 5.8