How can I resolve Apple Mach-O Linker Error from Firebase?

firebase ios sdk
firebase ios sdk open source
github firebase core
firebase performance github
google firebase ios sdk github
firebase ios repo
firebase swift github
github firebase pod

After leaving my app sit for a few months I updated my development system to the latest Xcode and Cocoapods and began to get the Apple Mach-O Linker Error from a number of Firebase pods.

Some notes about what I have tried unsuccessfully:

  • removing derived files directory and restarting
  • removing and reinstalling pods
  • enabling and disabling bitcode
  • ensure 'Find Implicit Dependencies' is selected
  • ensure -ObjC option is included in 'Other Linker Flags'
  • rewriting the app in Swift 4

edit - forgot to mention

  • I always make sure to use xcworkspace to launch

edit - additional stuff attempted

  • after running pod deintegrate and pod install I noticed a message saying that enable bitcode should be inherited by project settings so that pod process could set it, doing this caused enable bitcode to be set to no by the pod install - building still fails the same way regardless of what enable bitcode is set to but this differed from what I understand is supposed to be the default behavior so I thought I should mention it

If I remove references in my code to Firebase the app will build but as soon as I include them the build fails.

The complete error message I am getting is:

Ld /Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/Assembly.app/Assembly normal arm64
    cd /Users/aron/Documents/democracy.guide/Assembly
    export IPHONEOS_DEPLOYMENT_TARGET=11.4
    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch arm64 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.4.sdk -L/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos -L/Users/aron/Documents/democracy.guide/Assembly/Pods/MongoSwiftMobile/vendor/MobileSDKs/iphoneos/lib -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/FirebaseAuth -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/FirebaseCore -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/FirebaseDatabase -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/FirebaseMessaging -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/GTMSessionFetcher -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/GoogleAPIClientForREST -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/GoogleToolboxForMac -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/MongoSwiftMobile -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/Protobuf -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/StitchCore -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/StitchCoreRemoteMongoDBService -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/StitchCoreSDK -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/StitchRemoteMongoDBService -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/leveldb-library -F/Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/nanopb -F/Users/aron/Documents/democracy.guide/Assembly/Pods/FirebaseAnalytics/Frameworks -F/Users/aron/Documents/democracy.guide/Assembly/Pods/FirebaseInstanceID/Frameworks -F/Users/aron/Documents/democracy.guide/Assembly/Pods/FirebaseMLCommon/Frameworks -F/Users/aron/Documents/democracy.guide/Assembly/Pods/FirebaseMLVision/Frameworks -F/Users/aron/Documents/democracy.guide/Assembly/Pods/FirebaseMLVisionBarcodeModel/Frameworks -F/Users/aron/Documents/democracy.guide/Assembly/Pods/GoogleMobileVision/BarcodeDetector/Frameworks -F/Users/aron/Documents/democracy.guide/Assembly/Pods/GoogleMobileVision/Detector/Frameworks -filelist /Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Intermediates.noindex/Assembly.build/Debug-iphoneos/Assembly.build/Objects-normal/arm64/Assembly.LinkFileList -Xlinker -rpath -Xlinker @executable_path/Frameworks -Xlinker -rpath -Xlinker @loader_path/Frameworks -Xlinker -rpath -Xlinker @executable_path/Frameworks -miphoneos-version-min=11.4 -dead_strip -Xlinker -object_path_lto -Xlinker /Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Intermediates.noindex/Assembly.build/Debug-iphoneos/Assembly.build/Objects-normal/arm64/Assembly_lto.o -Xlinker -export_dynamic -Xlinker -no_deduplicate -fobjc-link-runtime -L/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/swift/iphoneos -Xlinker -add_ast_path -Xlinker /Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Intermediates.noindex/Assembly.build/Debug-iphoneos/Assembly.build/Objects-normal/arm64/Assembly.swiftmodule -rpath /Users/aron/Documents/democracy.guide/Assembly/Pods/MongoSwiftMobile/vendor/MobileSDKs/iphoneos/lib -framework Pods_Assembly -Xlinker -dependency_info -Xlinker /Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Intermediates.noindex/Assembly.build/Debug-iphoneos/Assembly.build/Objects-normal/arm64/Assembly_dependency_info.dat -o /Users/aron/Library/Developer/Xcode/DerivedData/Assembly-haegilkknmraivhaftdfctiqowcb/Build/Products/Debug-iphoneos/Assembly.app/Assembly

Undefined symbols for architecture arm64:
  "leveldb::WriteBatch::WriteBatch()", referenced from:
      -[APLevelDBWriteBatch .cxx_construct] in FirebaseDatabase(APLevelDB.o)
  "leveldb::WriteBatch::Clear()", referenced from:
      -[APLevelDBWriteBatch clear] in FirebaseDatabase(APLevelDB.o)
  "leveldb::WriteBatch::Delete(leveldb::Slice const&)", referenced from:
      -[APLevelDBWriteBatch removeKey:] in FirebaseDatabase(APLevelDB.o)
  "leveldb::WriteBatch::Put(leveldb::Slice const&, leveldb::Slice const&)", referenced from:
      -[APLevelDBWriteBatch setData:forKey:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDBWriteBatch setString:forKey:] in FirebaseDatabase(APLevelDB.o)
  "operator delete[](void*)", referenced from:
      leveldb::Status::operator=(leveldb::Status const&) in FirebaseDatabase(APLevelDB.o)
      leveldb::Status::~Status() in FirebaseDatabase(APLevelDB.o)
  "leveldb::Status::CopyState(char const*)", referenced from:
      leveldb::Status::operator=(leveldb::Status const&) in FirebaseDatabase(APLevelDB.o)
  "leveldb::Options::Options()", referenced from:
      +[APLevelDB defaultCreateOptions] in FirebaseDatabase(APLevelDB.o)
  "leveldb::DB::Open(leveldb::Options const&, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, leveldb::DB**)", referenced from:
      -[APLevelDB initWithPath:error:] in FirebaseDatabase(APLevelDB.o)
  "___gxx_personality_v0", referenced from:
      +[APLevelDB levelDBWithPath:error:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB initWithPath:error:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB setData:forKey:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB setString:forKey:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB dataForKey:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB stringForKey:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB removeKey:] in FirebaseDatabase(APLevelDB.o)
      ...
  "leveldb::Status::ToString() const", referenced from:
      -[APLevelDB initWithPath:error:] in FirebaseDatabase(APLevelDB.o)
  "leveldb::WriteBatch::~WriteBatch()", referenced from:
      -[APLevelDBWriteBatch .cxx_destruct] in FirebaseDatabase(APLevelDB.o)
  "_OBJC_CLASS_$_FIRVisionBarcode", referenced from:
      objc-class-ref in CameraViewController.o
  "_OBJC_CLASS_$_FIRVisionBarcodeDetector", referenced from:
      objc-class-ref in CameraViewController.o
  "_utf8_nextCharSafeBody", referenced from:
      _validate_dispatch_data_partial_string in FirebaseDatabase(FSRWebSocket.o)
  "_OBJC_CLASS_$_FIRVisionImageMetadata", referenced from:
      objc-class-ref in CameraViewController.o
  "std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::~basic_string()", referenced from:
      -[APLevelDB initWithPath:error:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB dataForKey:] in FirebaseDatabase(APLevelDB.o)
      -[APLevelDB stringForKey:] in FirebaseDatabase(APLevelDB.o)
  "_OBJC_CLASS_$_FIRInstanceID", referenced from:
      objc-class-ref in AppDelegate.o
      objc-class-ref in FirebaseMessaging(FIRMessaging.o)
  "_OBJC_CLASS_$_FIRVision", referenced from:
      objc-class-ref in CameraViewController.o
  "_OBJC_CLASS_$_FIRVisionImage", referenced from:
      objc-class-ref in CameraViewController.o
  "std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::__init(char const*, unsigned long)", referenced from:
      -[APLevelDB initWithPath:error:] in FirebaseDatabase(APLevelDB.o)
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Firebase support responded to my support request saying Firebase is a self service product and they cannot help me resolve this issue :(

I am specifying pods exactly as Firebase currently specifies in setup instructions my podfile includes:

  • pod 'Firebase/Core'
  • pod 'Firebase/Messaging'
  • pod 'Firebase/Database'
  • pod 'Firebase/Auth'
  • pod 'Firebase/MLVision'
  • pod 'Firebase/MLVisionBarcodeModel'

edit to add podfile.lock content

These should all be the latest versions

PODS:
  - Firebase/Auth (5.4.0):
    - Firebase/CoreOnly
    - FirebaseAuth (= 5.0.2)
  - Firebase/Core (5.4.0):
    - Firebase/CoreOnly
    - FirebaseAnalytics (= 5.0.1)
  - Firebase/CoreOnly (5.4.0):
    - FirebaseCore (= 5.0.5)
  - Firebase/Database (5.4.0):
    - Firebase/CoreOnly
    - FirebaseDatabase (= 5.0.2)
  - Firebase/Messaging (5.4.0):
    - Firebase/CoreOnly
    - FirebaseMessaging (= 3.0.3)
  - Firebase/MLVision (5.4.0):
    - Firebase/CoreOnly
    - FirebaseMLVision (= 0.10.0)
  - Firebase/MLVisionBarcodeModel (5.4.0):
    - Firebase/CoreOnly
    - FirebaseMLVisionBarcodeModel (= 0.10.0)
  - FirebaseAnalytics (5.0.1):
    - FirebaseCore (~> 5.0)
    - FirebaseInstanceID (~> 3.0)
    - "GoogleToolboxForMac/NSData+zlib (~> 2.1)"
    - nanopb (~> 0.3)
  - FirebaseAuth (5.0.2):
    - FirebaseCore (~> 5.0)
    - GTMSessionFetcher/Core (~> 1.1)
  - FirebaseCore (5.0.5):
    - "GoogleToolboxForMac/NSData+zlib (~> 2.1)"
  - FirebaseDatabase (5.0.2):
    - FirebaseCore (~> 5.0)
    - leveldb-library (~> 1.18)
  - FirebaseInstanceID (3.1.1):
    - FirebaseCore (~> 5.0)
  - FirebaseMessaging (3.0.3):
    - FirebaseCore (~> 5.0)
    - FirebaseInstanceID (~> 3.0)
    - GoogleToolboxForMac/Logger (~> 2.1)
    - Protobuf (~> 3.1)
  - FirebaseMLCommon (0.10.0):
    - FirebaseCore (~> 5.0)
  - FirebaseMLVision (0.10.0):
    - FirebaseCore (~> 5.0)
    - FirebaseMLCommon (~> 0.10)
    - GoogleAPIClientForREST/Core (~> 1.3)
    - GoogleAPIClientForREST/Vision (~> 1.3)
    - GoogleMobileVision/Detector (~> 1.3)
  - FirebaseMLVisionBarcodeModel (0.10.0):
    - GoogleMobileVision/BarcodeDetector (~> 1.3)
  - GoogleAPIClientForREST/Core (1.3.4):
    - GTMSessionFetcher (>= 1.1.7)
  - GoogleAPIClientForREST/Vision (1.3.4):
    - GoogleAPIClientForREST/Core
    - GTMSessionFetcher (>= 1.1.7)
  - GoogleMobileVision/BarcodeDetector (1.3.2):
    - GoogleMobileVision/Detector (~> 1.3)
  - GoogleMobileVision/Detector (1.3.2):
    - GoogleToolboxForMac/Logger (~> 2.1)
    - "GoogleToolboxForMac/NSData+zlib (~> 2.1)"
    - GTMSessionFetcher/Core (~> 1.1)
    - Protobuf (~> 3.1)
  - GoogleToolboxForMac/Defines (2.1.4)
  - GoogleToolboxForMac/Logger (2.1.4):
    - GoogleToolboxForMac/Defines (= 2.1.4)
  - "GoogleToolboxForMac/NSData+zlib (2.1.4)":
    - GoogleToolboxForMac/Defines (= 2.1.4)
  - GTMSessionFetcher (1.1.15):
    - GTMSessionFetcher/Full (= 1.1.15)
  - GTMSessionFetcher/Core (1.1.15)
  - GTMSessionFetcher/Full (1.1.15):
    - GTMSessionFetcher/Core (= 1.1.15)
  - leveldb-library (1.20)
  - MongoSwiftMobile (4.0.0)
  - nanopb (0.3.8):
    - nanopb/decode (= 0.3.8)
    - nanopb/encode (= 0.3.8)
  - nanopb/decode (0.3.8)
  - nanopb/encode (0.3.8)
  - Protobuf (3.6.0)
  - StitchCore (4.0.0):
    - StitchCoreSDK (~> 4.0.0)
  - StitchCoreRemoteMongoDBService (4.0.0):
    - StitchCoreSDK (~> 4.0.0)
  - StitchCoreSDK (4.0.0):
    - MongoSwiftMobile (~> 4.0.0)
  - StitchRemoteMongoDBService (4.0.0):
    - StitchCore (~> 4.0.0)
    - StitchCoreRemoteMongoDBService (~> 4.0.0)
  - StitchSDK (4.0.0):
    - StitchSDK/StitchSDK (= 4.0.0)
  - StitchSDK/StitchRemoteMongoDBService (4.0.0):
    - StitchRemoteMongoDBService (~> 4.0.0)
  - StitchSDK/StitchSDK (4.0.0):
    - StitchSDK/StitchRemoteMongoDBService

DEPENDENCIES:
  - Firebase/Auth
  - Firebase/Core
  - Firebase/Database
  - Firebase/Messaging
  - Firebase/MLVision
  - Firebase/MLVisionBarcodeModel
  - StitchSDK (~> 4.0.0)

SPEC REPOS:
  https://github.com/cocoapods/specs.git:
    - Firebase
    - FirebaseAnalytics
    - FirebaseAuth
    - FirebaseCore
    - FirebaseDatabase
    - FirebaseInstanceID
    - FirebaseMessaging
    - FirebaseMLCommon
    - FirebaseMLVision
    - FirebaseMLVisionBarcodeModel
    - GoogleAPIClientForREST
    - GoogleMobileVision
    - GoogleToolboxForMac
    - GTMSessionFetcher
    - leveldb-library
    - MongoSwiftMobile
    - nanopb
    - Protobuf
    - StitchCore
    - StitchCoreRemoteMongoDBService
    - StitchCoreSDK
    - StitchRemoteMongoDBService
    - StitchSDK

SPEC CHECKSUMS:
  Firebase: d66f4f29c23f22d96808d9abc174d81d8eee968f
  FirebaseAnalytics: b3628aea54c50464c32c393fb2ea032566e7ecc2
  FirebaseAuth: 096e457cdd4274412a66c4a35874787e411f5a03
  FirebaseCore: 42b3267233bd21a5abd54117ccc38ca3dd0f8e83
  FirebaseDatabase: 27be5ac5bc75e0b17537b2bbfada8258addcc8cd
  FirebaseInstanceID: f3f0657372592ecdfdfe2cac604a5a75758376a6
  FirebaseMessaging: f43eb0c0e1da096e659de6f713038e74862a62cd
  FirebaseMLCommon: 88ffed2dbb54ecb7dbcf8080a7654b6ea938e15b
  FirebaseMLVision: 144a482992b5b3d60afc17abfeb28a42bf468522
  FirebaseMLVisionBarcodeModel: dfbe6e789d6cedbe77bcf5b8b7eb1f8304e854ff
  GoogleAPIClientForREST: f7951c455df271bc6259b3ddb4073d0026475ccf
  GoogleMobileVision: 6b0a3a2dae1974ec35d80fdeeacc3a03193642e0
  GoogleToolboxForMac: 91c824d21e85b31c2aae9bb011c5027c9b4e738f
  GTMSessionFetcher: 5fa5b80fd20e439ef5f545fb2cb3ca6c6714caa2
  leveldb-library: 08cba283675b7ed2d99629a4bc5fd052cd2bb6a5
  MongoSwiftMobile: 6a2cf9f5e27f9be7fb0eeb3440765ba32d236c2f
  nanopb: 5601e6bca2dbf1ed831b519092ec110f66982ca3
  Protobuf: 0fc0ad8bec688b2a3017a139953e01374fedbd5f
  StitchCore: 55514801894888f2c2daaa12d7176c1d2637722b
  StitchCoreRemoteMongoDBService: 2f76803f5795bfe0008b06197bae494a034f4211
  StitchCoreSDK: 1632259c0f561dd68aeaaf656424834fd931c13c
  StitchRemoteMongoDBService: d1327e8e4fffe7b6c76da2d0117e23e03f365067
  StitchSDK: 35035630829a60935346a79cfbd139cb7d555384

PODFILE CHECKSUM: 8b327f7217b47576ad36564cb4bc3ac36d2684d4

COCOAPODS: 1.5.3

This happens all the time for some reason. I usually just clean the project and rebuild and I don't see it for another few weeks. Not a solution, but it gets you back to coding for the time being.

[RemoteConfig] Apple Mach-O Linker Error (using pods) � Issue , Pod version 6.15.0 - Apple Mach-O Linker Error (10 items) #4685 Xcode version: 11.2.1; Firebase SDK version: 6.15.0; Firebase Component: Firebase/ Analytics; Component This comment was marked as resolved. Ah, whoops :) We don't have plans to distribute dylibs, which is the main driver behind us not supporting Carthage. However, it may be worth while trying to distribute a static framework module through Carthage since we'd be distributing a binary anyway.

After pulling out most of the hair I have left I discovered that another pod I was using did not include bitcode and this was actually what was causing the failure - although it was not mentioned at all in any of the error messages.

Specifically I was using the Stitch SDK from MongoDB Atlas and when they released a new version if did not include bitcode.

I discovered this was the issue by repeatedly toggling enable bitcode, deintegrating pods and clean/builds of the project.

This was only made apparent after changing the enable bitcode flag under Pods build settings instead of under my project settings, then toggling it again from project settings.

To anyone else who encounters this issue I recommend trying to remove any non-Firebase pods as there can be compatibility issues that are not at all apparent from the error messages provided by Xcode.

Pod version 6.15.0, 4 Replies. This was a really finnicky error for me to solve, but eventually I was able to� ld: library not found for -lFirebaseCore clang: error: linker command failed with exit code 1 (use -v to see invocation) 3 Google SignIn SDK is failing by throwing error, A non-recoverable sign in failure occurred -catch error: React Native

This issue is related to the Undefined Behavior Sanitizer. You have to turn it off in the scheme to make a difference?. Find the path Xcode->Edit Scheme->Run-> Diagnostics.If that option is greyed out you can disable manually in XCSCHEME.

Path to open the scheme file appname.xcodeproj/xcshareddata/xcschemes/appname.xcscheme and open the appname.xcscheme in text edit and search with Sanitizer

Set enableUBSanitizer to NO and stopOnEveryUBSanitizerIssue to NO

Apple Mach-O Linker Error, Resolving Apple Mach-O Linker Error in swift and xcode 6.4 beta - ios. My app is a Swift project, and I have imported the modulemap, firebase.h, and� Here, click on the checkbox beside “Pods-YourProjectName” and save your changes. Thereafter, save these settings and make sure that you open the xcworkspace version of your project as opposed to xcode. This is the main reason why you may face the Apple mach-O linker error.

Resolving Apple Mach-O Linker Error in swift and xcode 6.4 beta, Solvedreact native maps Apple Mach-O Linker Error. react-native I tried to launch ios app with google map on simulator and got this error. no such file or react native maps play-services-base Version collision with react-native-firebase. 14. PushPlugin uses Cocoa Pods now, once it is installed you can not run your regular yourProjectName.xcodeproj file you must open a new file that was creating after you installed PushPlugin called yourProjectName.xcworkspace.

[Solved]react native maps Apple Mach-O Linker Error, Xcode Apple Mach-O linker error 1 __frkparticlePluginSDKProcess. I'm working on a game in unity, i'm using EasyAR, Firebase analytics,� In general undefined symbol errors mean you're missing required frameworks, libraries or both. A few that stand out to me: symbols in std:: (like std::__1::basic_string) mean you're missing libc++, so add c++ to your required libraries.

Xcode Apple Mach-O linker error 1 __frkparticlePluginSDKProcess , Hello, I am receiving the following error when trying to build my Firebase project See more: apple mach-o linker error group xcode 9, apple mach-o linker (id)� Select the .m file that is mentioned in the Mach-O error and make sure the ‘Add to Targets’ and ‘Target Membership’ boxes are checked in File Inspector to link the file to your code: Check to make sure the error has been solved. Then, search for other files that are not linked and import. Import .m file instead the .h.

Comments
  • Are you specifying explicit versions for each of the Firebase pods in your Podfile.?If so, are they up-to-date? Also, have Firebase changed the pods they make available for integration in the intervening time?
  • I am specifying pods exactly as Firebase currently specifies in setup instructions my podfile includes: pod 'Firebase/Core' pod 'Firebase/Messaging' pod 'Firebase/Database' pod 'Firebase/Auth' pod 'Firebase/MLVision' pod 'Firebase/MLVisionBarcodeModel'
  • Do the versions showing in your Podfile.lock match the latest released versions?
  • Are you able to build the quickstarts at github.com/firebase/quickstart-ios? If yes, can you see what's different with your workspace? If no, you could share the failing quickstart so someone could help you diagnose.
  • I can try that later but I did make a completely new project and had exactly the same errors.
  • Yeah I have tried that many times unfortunately it has not resolved once.
  • Do you use the xCode workspace instead of the project?
  • You may also try: <Your app> > Edit Scheme > Build the option Find Implicit Dependencies must be checked
  • Yes I have done both of those as mentioned in the initial post.
  • This is a tough one. Do you have your objective-C header file setup correctly? Did you trying doing 1 pod at time? Maybe we can eliminate it to analytics or something.