No matching distribution found for tf-nightly when installing tensorflowjs

install tensorflow
no matching distribution found for tensorflow
conda install tf-nightly
no matching distribution found for tf nightly 2.0 preview >= 2.0 0 dev20190502 from tensorflowjs
uninstall tf-nightly
tf-nightly github
import tf-nightly
tf-nightly for raspberry pi

I am trying to install tensorflowjs on my virtual environment, but am getting the following error:

Could not find a version that satisfies the requirement tf-nightly-2.0-preview>=2.0.0.dev20190304 (from tensorflowjs) (from versions: )
No matching distribution found for tf-nightly-2.0-preview>=2.0.0.dev20190304 (from tensorflowjs)

I have tried upgrading pip and creating the virtual environment with both virtualenv and venv, and installing it with and without the option --no-cache-dir.

To reproduce the error, I do the following:

python3 -m venv .env
source .env/bin/activate
pip install tensorflowjs

This results in the output:

Collecting tensorflowjs
  Downloading https://files.pythonhosted.org/packages/79/29/35e1aa467436ff46b98df65a08c49faaedb3429e1c512d1d90fe308040a0/tensorflowjs-1.0.1-py3-none-any.whl
Collecting tensorflow-hub==0.3.0 (from tensorflowjs)
  Downloading https://files.pythonhosted.org/packages/9e/f0/3a3ced04c8359e562f1b91918d9bde797c8a916fcfeddc8dc5d673d1be20/tensorflow_hub-0.3.0-py2.py3-none-any.whl (73kB)
    100% |████████████████████████████████| 81kB 7.6MB/s 
Collecting numpy==1.15.1 (from tensorflowjs)
  Downloading https://files.pythonhosted.org/packages/d4/fd/6c1c98862f78b1aacd8d81811900ddd5cbe34a6ed168e8f84e4df7cac30f/numpy-1.15.1-cp37-cp37m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (24.5MB)
    100% |████████████████████████████████| 24.5MB 39.6MB/s 
Collecting h5py==2.8.0 (from tensorflowjs)
  Downloading https://files.pythonhosted.org/packages/2a/13/d3fb885ff877578e0fddd8c71e1ed9e22207cec8469c0ef1e483ab5ca0d3/h5py-2.8.0-cp37-cp37m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (6.0MB)
    100% |████████████████████████████████| 6.1MB 42.3MB/s 
Collecting keras==2.2.4 (from tensorflowjs)
  Downloading https://files.pythonhosted.org/packages/5e/10/aa32dad071ce52b5502266b5c659451cfd6ffcbf14e6c8c4f16c0ff5aaab/Keras-2.2.4-py2.py3-none-any.whl (312kB)
    100% |████████████████████████████████| 317kB 44.3MB/s 
Collecting six==1.11.0 (from tensorflowjs)
  Downloading https://files.pythonhosted.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl
Collecting tf-nightly-2.0-preview>=2.0.0.dev20190304 (from tensorflowjs)
  Could not find a version that satisfies the requirement tf-nightly-2.0-preview>=2.0.0.dev20190304 (from tensorflowjs) (from versions: )
No matching distribution found for tf-nightly-2.0-preview>=2.0.0.dev20190304 (from tensorflowjs)

I am using Python 3.7.2, pip 19.0.3, on a macOS 10.13.6.

tf-nightly-2.0-preview releases binaries for MacOS only for Python 2.7 and 3.6.

pip install tf-nightly-2.0-preview No matching distribution found for , pip install tf-nightly-2.0-preview No matching distribution found for python 3.7 # 27470. Closed. cottrell opened this issue on Apr 3, 2019 � 22 comments. Closed� cottrell changed the title pip install tf-nightly-2.0-preview No matching distribution found. pip install tf-nightly-2.0-preview No matching distribution found for python 3.7 Apr 3, 2019 gadagashwini self-assigned this Apr 4, 2019

I ran into the same issue and only had success with python 3.6, give that a try if you can.

tensorflowjs_converter install fails due to tf-nightly-2.0-preview , ERROR: No matching distribution found for tf-nightly-2.0-preview>=2.0.0. dev20190502 (from tensorflowjs). operating system: OSX 10.14.4 caisq changed the title Tensorflow: tensorflowjs_converter: command not found tensorflowjs_converter install fails due to tf-nightly-2.0-preview missing from Python 3.7 May 24, 2019 caisq assigned gunan and unassigned tafsiri May 24, 2019

Always usage of stable version of tf-nightly is recommended, use command

!pip install tf-nightly

pip install tensorflowjs error 1.0.1 � Issue #1371 � tensorflow/tfjs , ERROR: No matching distribution found for tf-nightly-2.0-preview>=2.0.0. dev20190304 I'm able to run pip install tf-nightly without an error. pip install tf-nightly-gpu No matching distribution found for tf-nightly-gpu. av8ramit reopened this Nov 10, 2017. This comment has been minimized.

Fix ERROR No matching distribution found for tensorflow, tensorflowjs) (from versions: ) No matching distribution found for tf-nightly-2.0- preview>=2.0.0.dev20190304 (from tensorflowjs) I have tried upgrading pip and � "No matching distribution found for tensorflow": Pip can't find a TensorFlow package compatible with your system. Installing collected packages: setuptools

pip install tensorflowjs error 1.0.1 - tfjs, Fix ERROR No matching distribution found for tensorflow python pip install tensorflow ERROR Duration: 6:45 Posted: May 5, 2019 Then you can install tensorflowjs using the '--no-deps' flag. E.g., pip install tensorflow==1.11.0rc2 h5py numpy keras pip install --no-deps tensorflowjs This comment has been minimized.

Help me install Tensorflow : tensorflow, (tensorflowjs2) C:\Users\USER>pip install tensorflowjs Collecting tensorflowjs No matching distribution found for tf-nightly-2.0-preview>=2.0.0.dev20190304� and for install the TensorFlow 2 bye pip you can use: pip install tf-nightly-gpu-2.0-preview for GPU and pip install tf-nightly-2.0-preview for CPU. share | improve this answer | follow | edited Jul 12 at 5:06

Comments
  • saved me a lifetime. For those struggling just downgrade to python 3.6