Rails: Could not find concurrent-ruby-1.0.5 in any of the sources (Bundler::GemNotFound)

could not find gem in any of the gem sources listed in your gemfile.
could not find gem in any of the sources
could not find mini_portile2 2.4 0 in any of the sources bundler gemnotfound
bundler gemnotfound could not find tzinfo (1.2 7 in any of the sources)
bundler gemnotfound could not find zeitwerk 2.3 0 in any of the sources
could not find childprocess 1.0 1 in any of the sources
could not find scrypt 3.0 5 in any of the sources
could not find json-2.3.0 in any of the sources

I've Googled this quite a bit, and haven't found anything useful to my situation.

$ docker-compose up abc

produces the following in the logs:

/usr/lib/ruby/vendor_ruby/bundler/spec_set.rb:92:in `block in materialize': Could not find concurrent-ruby-1.0.5 in any of the sources (Bundler::GemNotFound)
   from /usr/lib/ruby/vendor_ruby/bundler/spec_set.rb:85:in `map!'
   from /usr/lib/ruby/vendor_ruby/bundler/spec_set.rb:85:in `materialize'
   from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:132:in `specs'
   from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:177:in `specs_for'
   from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:166:in `requested_specs'
   from /usr/lib/ruby/vendor_ruby/bundler/environment.rb:18:in `requested_specs'
   from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:13:in `setup'
   from /usr/lib/ruby/vendor_ruby/bundler.rb:121:in `setup'
   from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:17:in `<top (required)>'
   from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
   from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'

The relevant bit from my docker-compose.yml file: command: bundle exec rails server

concurrent-ruby is most definitely installed, exactly where it needs to be. I've run bundle install inside Docker so many times, and I've tried adding gem install concurrent-ruby -v 1.0.5 to my docker-compose command, and it installs just fine, and then still complains that it can't find the gem. I tried adding bundle install directly to my docker-compose command, and that fails because of some known issue involving docker-compose and git (I'm using two internal gems). [ EDIT: https://github.com/docker/compose/issues/2856#issuecomment-236625662 ]

Everything worked fine until I upgraded some Ruby gems, but I'm not sure why or how to fix it.

I had an issue similar to this outside of Docker.

I deleted the Gemfile.lock and ran bundle.

Issue went away.

Your mileage may vary.

Could not find concurrent-ruby-1.0.5 in any of the sources (Bundler , bundler :: gemnotfound could not find zeitwerk 2.3 0 in any of the sources could not find gem 'rails 4.2 1.0 in any of the gem sources listed in your gemfile Could not find concurrent-ruby-1.0.5 in any of the sources. Steps to reproduce the problem (from a clean middleman installation) Create a new middleman project with middleman init Run middleman server. Additional information. Ruby version: 2.3.1p112; Middleman version: 4.2.1; OS version: macOS 10.12.3 👍

I had this same error with docker-compose. Apparently, it was installing the gem, after running docker-compose run backend bundle install the Gemfile.lock file was updated correctly. Still, it would continue displaying this error either for this gem or others.

Turns out that in some cases just running bundle install with docker is not enough. As specified in the documentation here: https://docs.docker.com/compose/rails/ sometimes after running bundle install you need to rebuild the images. This fixed my problem:

docker-compose run backend bundle install
docker-compose build

Could not find gem 'SOME GEM' in the gems available on this , Could not find gem ' delayed_job (>= 0)' in any of the gem sources listed in your bundle install Could not find gem 'neo4j-core (~> 2.0.1) ruby' in the gems Could not find gem 'less-rails-bootstrap (= 3.2.0) ruby' in the gems available on this� When bundle, I met errors below, but after I installs manually gem install minitest -v '4.7.5', I can install bundled gems completely. Is this bundler problem? Bundler::GemNotFound: Could not find minitest-4.7.5.gem for installation An e

tl;dr: Set GEM_HOME = BUNDLE_PATH

Since you're using docker, I also assume you are maybe changing the value of BUNDLE_PATH so you can cache the gems? If so, you'll also want to set the GEM_HOME variable to this value.

I can't exactly explain why. My theory is that.. something.. is incorrectly using the value of GEM_HOME when it should be using BUNDLE_PATH, and thus the gems you installed from your rails project's Gemfile are not there.

`Bundler::GemNotFound: Could not find` with ruby 2.1.0 and bundler , Bundler::GemNotFound: Could not find minitest-4.7.5.gem for installation An e oj (2.5.1) pry (0.9.12.4) pry-doc (0.5.0) pry-nav (0.2.3) pry-rails (0.3.2) source "https://rubygems.org" gem "json", '1.8.1' Gemfile.lock <No� Stack Overflow for Teams is a private, secure spot for you and your coworkers to find and share information. Learn more Bundler::GemNotFound: Could not find rake-10.3.2 in any of the sources

Nothing will make it work unless you reinstall the metasploit-framework. I have been facing the issue for 1 week. I have personally tried and its running now.

$ pkg upgrade && pkg install git && pkg install curl && pkg install wget && pkg install nmap && curl -LO raw.githubusercontent.com/Hax4us/Metasploit_termux/master/metasploit.sh && chmod 777 metasploit.sh && ./metasploit.sh

Workflow, Make sure to check the updated Gemfile.lock into version control When you first create a Rails application, it already comes with a Gemfile . Bundler will connect to rubygems.org (and any other sources that you declared), and Installing rake 11.3.0 Using concurrent-ruby 1.0.2 Using i18n 0.7.0 Installing minitest 5.9.1� Could not find gem 'less-rails-bootstrap (= 3.2.0) ruby' in the gems available on this machine. Could not find gem 'ideal-image-slider' in any of the gem sources

How to fix conflict between diferent gem dependencies, Is a good strategy use RVM when you have different projects in different Ruby versions or Rails as well, but I usually only remove the Gemfile.lock and run� Dismiss Join GitHub today. GitHub is home to over 50 million developers working together to host and review code, manage projects, and build software together.

I have a lot of dependency issues in my app, need help., Could not find gem 'sqlite3-ruby (~> 1.3.1)' in any of the gem sources listed in your Gemfile. (Bundler::GemNotFound). I tried editing the Gemfile, deleting the� Join GitHub today. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together.

Migration from 8.15 to 8.16 of source installation blocks in error , sudo -u git -H bundle exec rake --tasks Could not find vmstat-2.3.0 in any of the 1.3.5 Using coffee-script-source 1.10.0 Using thor 0.19.1 Using concurrent-ruby 5.0.1 Using virtus 1.0.5 Using rails-html-sanitizer 1.0.3 Using omniauth-saml 1.7.0 Bundler::GemNotFound: Could not find rake-11.3.0 in any of the sources �