SHA384 is not supported by your openssl extension, could not verify the phar file integrity

composer
install composer
uninstall composer
manually update composer
wget composer
composer installer corrupt
install composer mac
composer command not found windows

I get the error when i run composer self-update on Windows 10 Here is the full error message

     composer self-update
     Updating to version 1.8.4 (stable channel).
     Downloading (100%)


     [RuntimeException]
    SHA384 is not supported by your openssl extension, could not verify the phar file integrity

I am running PHP 7.3.2 What could be the problem?

Remove Your older versions and install the latest version of Composer,

Remove Your older version: sudo rm -f /usr/local/bin/composer

Download the installer: sudo curl -s https://getcomposer.org/installer | php

Move the composer.phar file: sudo mv composer.phar /usr/local/bin/composer

Self-upgrading Composer complains about missing SHA384 in , Downloading (100%) [RuntimeException] SHA384 is not supported by your openssl extension, could not verify the phar file integrity Exception� SHA384 is not supported by your openssl extension, could not verify the phar file intergrity. Please note that it's a VM on ESXi. ISSUE TYPE. Bug Report. OS VERSION ENVIRONMENT CONFIGURATION SUMMARY STEPS TO REPRODUCE EXPECTED RESULTS ACTUAL RESULTS IMPORTANCE

The error means you are using composer of version 1.7.2or below. You have to uninstall composer and then install a composer version 1.7.3 and above.

SHA384 is not supported by your openssl extension � Issue #52 , SHA384 is not supported by your openssl extension #52 is not supported by your openssl extension, could not verify the phar file integrity \n [RuntimeException] SHA384 is not supported by your openssl extension, could not verify the phar file integrity This is a known issue (see Composer Issue 7669) but unfortunately the thread does not offer a clear solution. How I Upgraded Composer

I've just experienced the same issue on my Windows machine. I'd just downloaded and installed Composer from https://getcomposer.org/download/ and when I tried to run php composer-setup.php it failed with "SHA384 is not supported by your openssl extension".

The solution that worked for me was to perform the command line install (documented on the same site).

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('sha384', 'composer-setup.php') === 'c5b9b6d368201a9db6f74e2611495f369991b72d9c8cbd3ffbc63edff210eb73d46ffbfce88669ad33695ef77dc76976') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

Upgrade Composer, Upgrade Composer – SHA384 is not supported by your openssl extension, could not verify the phar file integrity. Last updated on November 1,� SHA384 is not supported by your openssl SHA384 is not supported by your openssl extension, could not verify the phar file integrity ansible all -i

Re-install Composer, Remove Your older versions and install the latest version of Composer,. Remove Your older version: sudo rm -f /usr/local/bin/composer. Download the installer:� SHA384 is not supported by your openssl extension, could not verify the phar file integrity Composer self-update error exception So finally I figured out the issue behind all of this, it is with the current installed version of composer and it needs to be updated to execute composer command. Let’s see how we can do that:

SHA384 is not supported by your openssl extension,, [RuntimeException] SHA384 is not supported by your openssl extension, could not verify the phar file integrity. Checking the OpenSSL MD� SHA384 is not supported by your openssl extension, could not verify the phar file integrity I couldn't find a way to re-install Composer from Composer site . The thread gave me no solutions to update, of course, as gihub projects are not for support requests anyway.

Composerを更新しようとしたら「SHA384 is not supported by your , Ask questionsSHA384 is not supported by your openssl extension, verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;" php proc_open(NUL): failed to open stream: No such file or directory hot 1 file could not be downloaded: failed to open stream: Cannot connect to HTTPS server� Thanks for the report. I'm currently building fresh Virtualbox & Parallels boxes. I don't have my VMware drive and of course I'm out of town. I'll be able to start Hyper-V from here but won't be able to build a new VMware box until I get home Saturday afternoon.

Comments
  • You're using an old version of composer. Try and completely remove it and install the latest version from scratch. Here's a Github issue about this error message.
  • you need to unistall composer <= 1.7.2 and then install a new version of composer >= 1.7.3 to avoid that update error for all future update type installs
  • @MagnusEriksson reinstalling worked
  • Actually it's not even required to remove the old version. Just install new one and move composer.phar