Error when Installing Ethereum: Package 'ethereum' has no installation candidate

I am installing Ethereum on Ubuntu 17.10 following the steps in this article: https://medium.com/@mvmurthy/full-stack-hello-world-voting-ethereum-dapp-tutorial-part-2-30b3d335aa1f

But when executing the following command:

sudo apt-get install ethereum

I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ethereum is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ethereum' has no installation candidate

It seems that there is a compatibility issue with the last stable version of Ethereum and Ubuntu 17.10; and the latest unstable version could be installed with no issues:

sudo apt-get install ethereum-unstable

However, this means that in the next stable version of Ethereum there will be no issues.

How to solve “Package 'ethereum' has no installation candidate” error?, sudo apt-get install ethereum. I get the following error: Reading package lists Done Building dependency tree Reading state information. Installing an unstable version of ethereum package does not seem like a good idea. Considering that package is only about installing a bunch of binaries (geth, swarm and other ethereum tools) into your filesystem.

have you tried common software properties first use this command to install this

(1) sudo apt-get install software-properties-common

and then use ethereum ppa

(2) sudo add-apt-repository -y ppa:ethereum/ethereum

(3) sudo apt-get update

(4) sudo apt-get install ethereum

Error when Installing Ethereum: Package 'ethereum , It seems that there is a compatibility issue with the last stable version of Ethereum and Ubuntu 17.10; and the latest unstable version could be� I am trying to install Ethereum on my system and when I run the following command: sudo apt-get install ethereum I get the following error: Reading package lists Done Building dependency tree Reading state information Done Package ethereum is not available, but is referred to by another package.

Have you added the Ethereum repository? If not, try the following:

sudo apt-get install software-properties-common
sudo add-apt-repository -y ppa:ethereum/ethereum
sudo apt-get update
sudo apt-get install ethereum

Error when Installing Ethereum: Package , Error when Installing Ethereum: Package 'ethereum' has no installation candidate . I am installing Ethereum on Ubuntu 17.10 following the steps in this article:� Hello,I'm new to ethereum,and I want to install the ethereum package for python. When I run pip install ethereum in my shell,I got the following error: `Requirement already satisfied: ethereum in c:\users\wenbo\anaconda3\lib\site-packages\ethereum-2.3.1-py3.6.egg

Installing an unstable version of ethereum package does not seem like a good idea.

Considering that package is only about installing a bunch of binaries (geth, swarm and other ethereum tools) into your filesystem. I would suggest to download the latest stable version directly from ethereum CDN servers or compile them yourself following the instructions described at their official github repo

Error when Installing Ethereum: Package 'ethereum - android, Error when Installing Ethereum: Package 'ethereum' has no installation candidate - ubuntu. Ethereum Stack Exchange is a question and answer site for users of Ethereum, the decentralized application platform and smart contract enabled blockchain. It only takes a minute to sign up. Sign up to join this community

pip install ethereum failed � Issue #880 � ethereum/pyethereum , Hello,I'm new to ethereum,and I want to install the ethereum package for When I run pip install ethereum in my shell,I got the following error:� I was following this youtube video in order to install Ethereum client on Ubuntu 15.10 First I installed Go language environment. Then I have build QT following this wiki After that I tried to do

Ubuntu repository not found � Issue #2356 � ethereum/go-ethereum , Install ethereum by apt-get, using one of these tutorials: I also got the same error of unable to locate package ethereum..Y so?? Ethereum Package for Sublime Text 2/3 Description. Ethereum is a platform for decentralized applications. This package contains syntax highlighting for Ethereum's language Solidity. Installation. Recommended: install via Package Control. Features. Solidity.sublime-syntax: syntax rules for Ethereum Solidity language

Installing Geth, These include installing it via your favorite package manager; downloading a The easiest way to install go-ethereum is to use our Homebrew tap. If you are using macOS and see errors related to macOS header files, install XCode� Installing Ethereum on Ubuntu 12.04. I get the following error: Reading package lists Done Building dependency tree 50% Building dependency tree

Comments
  • try all steps one by one
  • As mentioned in the question: sudo apt-get install ethereum did not work!
  • @MuhammadAltabba If you hadn't added the repository as mentioned above, installing ethereum probably wouldn't work. So it's a valid answer, though badly written.
  • Note that sudo apt install ethereum will not work on newer versions of ubuntu at the time of writing. You can try ethereum-unstable instead.