Error running pod install with swift

error running pod install flutter
install cocoapods
pod install not working
no `podfile' found in the project directory.
gem 'cocoapods' is not installed
cocoapods inhibit_all_warnings
install cocoapods', :deterministic_uuids => false
update cocoapods

I followed the instruction from Cocoapods.

Below is my Podfile:

platform :ios, '8.2'

pod 'SwiftyJSON', '~> 2.1'
pod 'SwiftSpinner', '~> 0.6'
pod 'Alamofire', '~> 1.1'
pod 'SuperRecord', '~> 1.2'
pod 'Toucan

When I did pod install I got the following error:

Pods written in Swift can only be integrated as frameworks; this feature is still in beta. Add use_frameworks! to your Podfile or target to opt into using it.

Updated:

Below is my console log:

$ pod install
Analyzing dependencies
Downloading dependencies
Installing Alamofire (1.1.4)
Installing SuperRecord (1.2)
Installing SwiftSpinner (0.6.0)
Installing SwiftyJSON (2.1.3)
Installing Toucan (0.2.0)
[!] Pods written in Swift can only be integrated as frameworks; this feature is still in beta. Add `use_frameworks!` to your Podfile or target to opt into using it.

Add "use_frameworks!" to your Podfile because:

Because Apple doesn't let you build static libraries that contain Swift. Unlike Objective-C, Apple doesn't ship the Swift standard runtime libraries with iOS. This decouples the language version from the platform version. When you build an app with Swift, you're responsible yourself to ship them. By default, Xcode uses swift-stdlib-tool to handle copying the Swift runtime dylibs, but the tooling falls short when attempting to ship frameworks that use Swift with an app that is Objective-C only. Your app executable and the frameworks you ship will all use the same set of dylibs, which are embedded into the Frameworks subdirectory of the application bundle.

First, that's because you can't link against different versions of the standard libraries. Furthermore it is desirable to embed them only once and not multiple times, because of constraints to memory size and network speed, which are relevant for distribution. You can make CocoaPods integrate to your project via frameworks instead of static libraries by specifying use_frameworks!. If that's not present, you won't be able to integrate dependencies, if you depend on a pod which includes Swift source code.

Reference: http://blog.cocoapods.org/CocoaPods-0.36/

Troubleshooting, The Dependency Manager for iOS & Mac projects. After upgrading from macOS 10.8 to 10.9 the installed CocoaPods gem doesn't work anymore, even after re-installing the gem <I'm getting permission errors while running pod commands. When I did pod install I got the following error: Pods written in Swift can only be integrated as frameworks; this feature is still in beta. Add `use_frameworks!` to your Podfile or target to opt into using it.

Add "use_frameworks!" to your Podfile:

Please see below sample Podfile

target 'MySample' do

  pod 'AFNetworking', '~> 2.5'

  pod 'Net', '~> 0.2' #This is a sample in Swift

  use_frameworks! # <--Use this line
end

Error running pod install � Issue #2651 � CocoaPods/CocoaPods , Run pod install on a new empty project. What did you Steps followed: I'm getting the error on my main project, but to make su Podfile. source 'https:// github.com/CocoaPods/Specs.git' platform :ios, '6.0' pod 'Appirater'� go to pod file of your project and adding pod which you want to install. added in pod file : pod 'AFNetworking', '~> 3.0. Command : Pod install. Close project of Xcode. open your Project from terminals. Command : open PodDemos.xcworkspace

as it written in Podfile it says uncomment use_frameworks! is your are using Swift so all you have to do uncomment this line and all works just fine

# Uncomment this line to define a global platform for your project
# platform :ios, '8.0'
# Uncomment this line if you're using Swift
use_frameworks! 

target 'YourProjectName' do
  pod 'SwiftyJSON', '~> 2.1'
  pod 'SwiftSpinner', '~> 0.6'
  pod 'Alamofire', '~> 1.1'
  pod 'SuperRecord', '~> 1.2'
  pod 'Toucan'
  # all other pods goes here 
end

target 'YourProjectName' do

end

target 'YourProjectName' do

end

CocoaPods error when running app on iOS emulator � Issue #19338 , Logs. Launching lib/main.dart on iPhone X in debug mode Running pod install.. . 1.7s CocoaPods' output:� Do pod try DropDown in your console and run the project to try a demo. To install CocoaPods, run sudo gem install cocoapods in your console. Installation 📱 DropDown supports Swift 5.0 since version 2.3.13. DropDown supports Swift 4.2 since version 2.3.4. If you need Swift 4.0, use version 2.3.2: Manually: use tag 2.3.2; CocoaPods: pod

I my case i used to upgrade cocoapods by command sudo gem install cocoapods and my issue got resolved. I used objective - c as well as swift libraries in my project.

How to fix Flutter stuck at “running pod install…” when running on , Here is the quick solution if you are stuck at “running pod install…” when running ios simulator on Flutter. How does this error happen? This happened when I copy � This running pod works great. No connectivity issues so far after 3 runs. Very accurate after calibrating. Usually off by about .05 miles at the end of run, but I’ve yet to see a run pod do any better. And the price is fantastic! Zwift needs to make it a lot more clear that you need to calibrate it first, and how.

the solution is very simple. You only have to add these lines to your pod file:

target 'PassDTAFirebase' do

  inherit! :complete

    # Here your pods

  use_frameworks! 

end

Fixing iOS compile issues in Flutter - Code More, error: The sandbox is not in sync with the Podfile.lock. Run 'pod install' or update your CocoaPods installation. So this time I tried pod install� CocoaPods Error-The platform of the target `Pods`(OS X 10.6) is not compatible with (1) The solution is to just specify a platform version in the Podfile platform :osx, '10.7'

pod-install, But now you can simply instruct users to run npx pod-install . This package will If not then it'll quit with a helpful error message. Ensure CocoaPods If not then it 'll try again in an ios/ directory (if one exists). Run pod install. target 'MyApp' do pod 'SwiftyOnboard', '~> 1.3' end Then run a pod install inside your terminal, or from CocoaPods.app. Alternatively to give it a test run, run the command:

CocoaPods Tutorial for Swift: Getting Started, Use this CocoaPods Tutorial for Swift to learn how to install and manage your progress by opening IceCreamShop.xcodeproj, then building and running. This can cause CocoaPods to become confused and throw errors. pod try Available since v0.29.0. pod try NAME|URL. Downloads the Pod with the given NAME (or Git URL), install its dependencies if needed and opens its demo project.If a Git URL is provided the head of the repo is used.

Error running pod install with swift, pod install I got the following error: Pods written in Swift can only be integrated as frameworks; this feature is still in beta. Add use_frameworks! to your Podfile� Dismiss Join GitHub today. GitHub is home to over 50 million developers working together to host and review code, manage projects, and build software together.

Comments
  • @DharmeshKheni all of the libs listed above are all in Swift.
  • What is the pod version you are using, use "pod --version" to get it. Make sure you update Cocoapods installation to latest version using "sudo gem install cococapods".
  • Some of Pods are not working well with "use_frameworks!". So can you please guide how to deal with both pods together?
  • The comment flag in Ruby is "#" instead of "//".