Android Lint error: Class requires API level 3, current is min is 1

call requires api level 8 current min is 1
the application's minsdkversion is newer than the device api level
android manifest minimum sdk version
android api level
best api level for android
manifest min api
use sdk
android sdk uses

When running my Android app I often get a list of errors, wich says

Class requires API level 3 (current min is 1): android.hardware.SensorEventListener

I've searched for the correct answer to this, like Android tools > Clear Link Markers, but this doesn't solve the problem. Every once in a while the list of errors keeps coming back. Is it something in my project settings or are my methods deprecated? I've installed the latest SDK for Android 4.4.

In your manifest file set the sdk like this based on your requirement..

 <uses-sdk
    android:maxSdkVersion="17"
    android:minSdkVersion="8" />

I don't Understand Call or Class Requires API Level 3, Call requires API level 3 (current min is 1) You need to set min SDK version in AndroidManifest like <uses-sdk android:targetSdkVersion="18" The error messages you're getting ("requires API level 11") mean that the  I don't have this problem. minSdk = 15, gradle-retrolambda 3.6.0, Android Studio 2.3.3 Solution is waiting release of Android Studio 3.0, there are build-in support of Java 8 features in it This comment has been minimized.

Restart and invalidate cache if this error just started up for no apparent reason

lint/libs/lint_checks/tests/src/com/android/tools/lint/checks , "src/foo/bar/ApiCallTest.java:27: Error: Call requires API level 3 (current min is 1): android.widget. Earlier than Android 5.0 (API level 21) See the respective Behavior Changes page for each of the following releases to ensure your that your app has accounted for changes introduced in these releases: Android 5.0 (API level 21). Android 4.4 (API level 19). Android 4.1.x (API level 16). Continue by following the instructions in the next section.

Change your application minsdk from Preference>Android>select the api level Android1.6

platform/sdk, package com.android.tools.lint.checks; "ApiCallTest.java:27: Error: Call requires API level 3 (current min is 1):  Android SDK Tools 24.3.4 or higher is required. Android 5.1 (API level 22) For details about the platform changes, see the Lollipop overview and Android 5.1 API changes. Revision 1 (March 2015) Initial release for Android 5.1 (API level 22). For more information, see the Android 5.1 API Overview. Dependencies:

Android Lint cree erróneamente que la versión mínima de SDK es 1, AsyncTask#<init> Call requires API level 3 (current min is 1): Android.view. " Borrar marcadores de pelusa" en la Respuesta aceptada eliminó el error temporalmente, pero seguía volviendo cada vez  The application will then be installable on platforms such as Android 1.5 (API Level 3) and Android 1.6 (API Level 4), but not on the Android 1.1 (API Level 2) and Android 1.0 platforms (API Level 1). For more information about how to specify an application's API Level requirements, see the <uses-sdk> section of the manifest file documentation.

lint failed · Issue #802 · react-native-community/react-native , Task :react-native-webview:lint FAILED Ran lint on variant release: 11 The first 3 errors (out of 4) were: Error: Call requires API level 21 (current min is 16): android.webkit. this need to set the min sdk version to 21 No one assigned.

Call requires API level 14 (current min is 10):, Call requires API level 14 (current min is 10): - android. It is actually a warning from Lint, rather than an error. though that this will raise the "bar" for running the app from Android 2.3.3 to Android 4.0.

Comments
  • The documentation recommends excluding the maxSdkVersion unless you have a really good reason. "There is no need to set the attribute as means of blocking deployment of your application onto new versions of the Android platform as they are released. By design, new versions of the platform are fully backward-compatible"