Issue with rails s (with sass apparently)

sass-rails
sassc-rails
cannot load such file -- sass
sassc gem

I tried to run rails s but sudently I'm getting an error message:

/home/leiver/.rbenv/versions/2.4.5/lib/ruby/gems/2.4.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:32:in `require': cannot load such file -- sass (LoadError)
        from /home/leiver/.rbenv/versions/2.4.5/lib/ruby/gems/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `block in require'
        from /home/leiver/.rbenv/versions/2.4.5/lib/ruby/gems/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:253:in `load_dependency'
        from 
.....

I know that there's something about sass about how it's going to disapear or something and I don't know if it's linked

Thanks if you can help :)

EDIT

here's my full Gemfile:

source 'https://rubygems.org'
ruby '2.4.5'

gem 'bootsnap', require: false
gem 'jbuilder', '~> 2.0'
gem 'pg', '~> 0.21'
gem 'puma'
gem 'rails', '5.2.1'
gem 'redis'

gem 'autoprefixer-rails'
gem 'bootstrap-sass', '~> 3.3'
gem 'font-awesome-sass', '~> 5.0.9'
gem 'sassc-rails'
gem 'simple_form'
gem 'uglifier'
gem 'webpacker'
gem 'devise'
gem 'money-rails'
gem "pundit"

group :development do
  gem 'web-console', '>= 3.3.0'
end

group :development, :test do
  gem 'pry-byebug'
  gem 'pry-rails'
  gem 'listen', '~> 3.0.5'
  gem 'spring'
  gem 'spring-watcher-listen', '~> 2.0.0'
  gem 'dotenv-rails'
end

Have tried bundle or bundle install before running the rails s. Still not working try to replace that gem with thisgem 'sassc' and bundle or just do gem install sassc

sass/sassc-rails, c:0065 p:---- s:0385 e:000384 CFUNC :compile_data_context c:0064 I had the same issue upgrading to sass-rails 6.0.0 and finally I fixed it using sprockets 4. ruby 2.6.5; rails Apparently my comment above is incomplete. Ruby on Rails stylesheet engine for Sass. Contribute to rails/sass-rails development by creating an account on GitHub.

Ok so I couldn't resolve the problem, so I deleted my local directory and re-cloned it from GitHub. I don't know if it's good practice but it resolved the problem for me, so if anyone else is having this issue and don't find a proper solution, try doing that.

Problems when other gems depend on sass-rails · Issue #6 · sass , I forked ActiveAdmin and replaced the dependencies on sass-rails with sassc and it works perfectly now. Obviously that's not the best way to go  Or alternatively, to specify that sass-rails load a gem version of sass lower than 3.2 to prevent this issue (sass-rails 3.2.6 currently only specifies needing sass versions higher than sass 3.1.0, appearing to allow sass-rails to include sass versions above 3.2.0 that breaks if upgrading to rails 3.2.x,).

The problem may be exists in gems. The problem founded by OP (and described in his answer) appears in the application files. However same problem problem may be caused in gems. The same problem in gems with same reason has identical solution.

In details. The problem during installation or some else may corrupt some gem so it is visible as installed but actually has missed or corrupted files. Check before that hard drive has enough free space.

So solution is fully reinstall bundle gems:

bundle install --force

The Facts on File Dictionary of American Regionalisms, South Carolina to mean a straight rail fence. galluses; gallowses Suspenders. I would call it Gardenia, from our worthy friend Dr. Alexander Garden of S. Carolina. sass Garden vegetables; sass, apparently a variation of sauce, was first  When using sassc / sassc-rails, my Gemfile.lock does not include sass and I do rake assets:precompile I get LoadError: cannot load such file -- sass. LoadError: cannot load such file -- sass sprock

If You Can't Be Better Than an N-Word, Then Who Can You Be Better , The Perpetuation of White Supremacy in Apartheid America Thomas Sass. combating pain. Apparently, Mr. Limbaugh has problems with his back, among other ailments, He is addicted to a drug, a drug that our rulers, for whatever reason(s) have doing the exact same or similar things as those against whom they rail. However, if an app depends on both sass-rails and sassc-rails, problems can occur. sass/sassc-rails#6 So, removing the sass-rails as an explicit dependency from browse-everything will allow dependent apps to choose sass-rails or sassc-rails themselves, switching on their own timeline, without the browse-everything dependency interfering. This change is unlikely to pose any backwards compatibility problems, as dependent apps should have sass-rails in their Gemfile already, as it is generated

The American Encyclopaedic Dictionary: A Thoroughly Accurate, , Stener, s. Bwilding: & * 1. A device at the meeting rails of sashes, to pre: vent a sash from 16'51 ; lime, 6'20; potash, 6'82; magnesia, 193; water, 17-0=99.96. såss, s. 23). , Apparently it occurs in a specific sense for the devil only in the later  Rails needs a plan a plan to deal with this before the ruby version becomes unmaintained. If a first-class Sass implementation for the ruby and rails community is desired, hopefully a maintainer can be found. Otherwise, one of the other Sass implementations can be used (most likely through node/npm). This was referenced on May 15, 2018

The New American Encyclopedic Dictionary: An Exhaustive Dictionary , A device at the meeting rails of sashes, to prevent a sash from bein #: Usually a sort of 16:51; lime, 6:20; potash, 6.82; magnesia, 1'93; water, 17-0=99.96. såss, s. Apparently it occurs in a specific sense for the devil only in the later sacred  What’s this? Free 30 Day Trial . Teams. Q&A for Work. Stack Overflow for Teams is a private, secure spot for you and your coworkers to find and share information.

Comments
  • Do you have any sass gem in your gemfile?
  • In my Gemfile I have gem 'sassc-rails', I tried to run gem instal sass but it still won't appear in my Gemfile
  • You might try deleting your bootsnap cache in tmp/cache/bootsnap-compile-cache & posting your full Gemfile in the question.
  • I tried bundle, also gem install sassc , the gem is successfully installed but I keep getting the same error message
  • The --force option has apparently been deprecated and renamed --redownload. Still worked for me, but thought I should point out in case someone comes across this in the future when it's actually gone.