Dependecies for CardView and RecyclerView in SDK version 28

androidx recyclerview dependency
dependencies for recyclerview and cardview in android
androidx dependencies
android recyclerview versions
com android support appcompat-v7:29
material cardview dependency
recyclerview cardview
fragment dependency

I am trying to add CardView and RecyclerView dependencies in my Android Studio Project for SDK version 28. Upon building the project, I get the message, "Gradle Project Sync Failed. Basic Functionality will not work properly".

build.gradle(Module:app) file:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 28
    defaultConfig {
        applicationId "com.kavyabarnadhyahazarika.quarterallotmentiocl"
        minSdkVersion 16
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
       }
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}
buildToolsVersion '28.0.0'
          }

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    androidTestImplementation('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    implementation 'com.android.support:appcompat-v7:28.0.0-alpha3'
    implementation 'com.android.support:cardview-v7:28.0.0'
    implementation 'com.android.support:recyclerview-v7:28.0.0'
    implementation 'com.mcxiaoke.volley:library:1.0.19'
    testImplementation 'junit:junit:4.12'
}

Error Messages: Failed to resolve: com.android.support:cardview-v7:28.0.0 Failed to resolve: com.android.support:recyclerview-v7:28.0.0

I have tried both build and clean project.

Also if these dependencies are not supported on SDK version 28, how do I resolve the issue?

There is no 28.0.0 final release as of yet - just like your appcompat-v7 dependency, cardview-v7 and recyclerview-v7 should have a version of 28.0.0-alpha3:

implementation 'com.android.support:appcompat-v7:28.0.0-alpha3'
implementation 'com.android.support:cardview-v7:28.0.0-alpha3'
implementation 'com.android.support:recyclerview-v7:28.0.0-alpha3'

Support Library Packages, androidx.recommendation · androidx.recyclerview · androidx.remotecallback · androidx.room · androidx. API Reference: Latest Update, Current Stable Release, Next Release Candidate, Beta Release, Alpha Release To add a dependency on CardView, you must add the Google Maven repository to your project. Timeline for Dependecies for CardView and RecyclerView in SDK version 28 Current License: CC BY-SA 4.0. 4 events when toggle format

This works for me.

// RecyclerView
implementation 'com.android.support:recyclerview-v7:+'

// CardView
implementation 'com.android.support:cardview-v7:+'

Cardview, Library Dependencies. Note: With the release of Android 9.0 (API level 28) there is a new version of the support library called For example the RecyclerView class provides an user interface widget for displaying and  Cannot resolve RecyclerView and CardView Gradle dependencies Dependecies for CardView and RecyclerView in SDK version 28. 1. problem with gradle dependencies

Here's a working solution.

replace the following dependencies

implementation 'com.android.support:cardview-v7:28.0.0-alpha3'
implementation 'com.android.support:recyclerview-v7:28.0.0-alpha3'

or

implementation 'com.android.support:cardview-v7:28.0.0'
implementation 'com.android.support:recyclerview-v7:28.0.0'

with the below implementations

implementation 'androidx.cardview:cardview:1.0.0'
implementation 'androidx.recyclerview:recyclerview:1.0.0'

I hope it helps.

Support Library, Dépendances pour CardView et RecyclerView dans la version 28 du SDK buildToolsVersion '28.0.0' } dependencies { implementation fileTree(include: ['*.​jar']  Declaring dependencies. To add a dependency on CardView, you must add the Google Maven repository to your project. Read Google's Maven repository for more information. Add the dependencies for the artifacts you need in the build.gradle file for your app or module: dependencies { implementation "androidx.cardview:cardview:1.0.0" }

Dépendances pour CardView et RecyclerView dans la version 28 , implementation 'com.android.support:cardview-v7:27.0.2' implementation and RecyclerView dependencies in my Android Studio Project for SDK version 28. The Gradle build script dependency identifier for this library is as follows: com.android.support:palette-v7:28.0.0 v7 recyclerview library. The recyclerview library adds the RecyclerView class. This class provides support for the RecyclerView widget, a view for efficiently displaying large data sets by providing a limited window of data items.

Android Studio SDK 27.1.0 CardView Render Issue, Learn to integrate RecyclerView and CardView in layout ( user interface ), first by adding their Duration: 4:40 Posted: May 29, 2018 Trying to use the new RecyclerView from the support library. I downloaded the 20 update for the support library using the SDK manager. I've added the jar file to the libs folder - and added to build

#3.2 Android Integrate RecyclerView and CardView Dependency in , I am working on Android Studio SDK version 28 and when I did gradle sync I got implementation 'com.android.support:recyclerview-v7:28.1.0' implementation implementation 'com.android.support:cardview-v7:28.0.0' implementation  Add the dependencies for the artifacts you need in the build.gradle file for your app or module: dependencies { implementation "androidx.recyclerview:recyclerview:1.1.0" // For control over item selection of both touch and mouse driven selection implementation "androidx.recyclerview:recyclerview-selection:1.1.0-rc01" }

Comments
  • Did you mean to paste in some additional error message?
  • Failed to resolve: com.android.support.cardview-v7:28.0.0-alpha3: Also, Project Build Failed.
  • You have a period instead of a semi-colon. com.android.support:cardview-v7:28.0.0-alpha3
  • Thanks, that resolved the issue. But, now getting a new one: AAPT2 error: check logs for details.
  • If your dependency question is solved, you should mark this question as solved, search to see if anyone has already asked a question about your new issue, and then ask a new question with your full reproduction steps and error message if you cannot find an answer.