parse_vt_settings /dev/tty0 (permission denied)

cannot open virtual console 2 (permission denied)
xf86openconsole: switching vt failed
xinit keeptty
startx single application
startx without window manager
manjaro startx
xinit resolution
reload xinitrc

I am trying to run xinit chromium-browser some_settings address:port in /home/pi/.bashrc file.

What it does in first version of "Jessie PIXEL" is open chromium browser on start up after console auto-login and opens the page address:port.

In new version of Jessie PIXEL I get the following error:

[ 513.403] X.Org X Server 1.18.4 Release Date: 2016-07-19< [ 513.403] X Protocol Version 11, Revision 0 [ 513.403] Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian [ 513.403] Current Operating System: Linux raspberrypi 4.4.38-v7+ !!938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l [ 513.403] Kernel command line: 8250.nr_uarts=1 dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2709.boardrev=0x2a02082 bcm2709.serial=0xff00$ [ 513.403] Build Date: 11 November 2016 11:59:59AM [ 513.403] xorg-server 2:1.18.4-2+rpi1 (https://www.debian.org/support) [ 513.403] Current version of pixman: 0.33.3 [ 513.403] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. [ 513.403] Markers: (--) probed, () from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 513.403] (==) Log file: "/home/pi/.local/share/xorg/Xorg.0.log", Time: Fri Dec 23 09:46:08 2016 [ 513.404] (==) Using system config directory "/usr/share/X11/xorg.conf.d" [ 513.404] (==) No Layout section. Using the first Screen section. [ 513.404] (==) No screen section available. Using defaults. [ 513.405] () |-->Screen "Default Screen Section" (0) [ 513.405] () | |-->Monitor "" [ 513.405] (==) No device specified for screen "Default Screen Section". Using the first device section listed. [ 513.405] () | |-->Device "Allwinner A10/A13 FBDEV" [ 513.405] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. [ 513.405] (==) Automatically adding devices [ 513.405] (==) Automatically enabling devices [ 513.405] (==) Automatically adding GPU devices [ 513.405] (==) Max clients allowed: 256, resource mask: 0x1fffff [ 513.405] (WW) The directory "/usr/share/fonts/X11/misc" does not exist. [ 513.405] Entry deleted from font path. [ 513.405] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist. [ 513.405] Entry deleted from font path. [ 513.405] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist. [ 513.405] Entry deleted from font path. [ 513.405] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist. [ 513.405] Entry deleted from font path. [ 513.405] (==) FontPath set to: /usr/share/fonts/X11/100dpi/:unscaled, /usr/share/fonts/X11/Type1, /usr/share/fonts/X11/100dpi, built-ins [ 513.405] (==) ModulePath set to "/usr/lib/xorg/modules" [ 513.405] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices. [ 513.406] (II) Loader magic: 0x54d5cf20 [ 513.406] (II) Module ABI versions: [ 513.406] X.Org ANSI C Emulation: 0.4 [ 513.406] X.Org Video Driver: 20.0 [ 513.406] X.Org XInput driver : 22.1 [ 513.406] X.Org Server Extension : 9.0 [ 513.411] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c2 [ 513.411] (II) no primary bus or device found [ 513.411] (II) LoadModule: "glx" [ 513.412] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so [ 513.416] (II) Module glx: vendor="X.Org Foundation" [ 513.416] compiled for 1.18.4, module version = 1.0.0 [ 513.416] ABI class: X.Org Server Extension, version 9.0 [ 513.416] (==) AIGLX enabled [ 513.416] (II) LoadModule: "fbturbo" [ 513.416] (II) Loading /usr/lib/xorg/modules/drivers/fbturbo_drv.so [ 513.417] (II) Module fbturbo: vendor="X.Org Foundation" [ 513.417] compiled for 1.18.4, module version = 0.5.1 [ 513.417] Module class: X.Org Video Driver [ 513.417] ABI class: X.Org Video Driver, version 20.0 [ 513.417] (II) FBTURBO: driver for framebuffer: fbturbo [ 513.417] (EE) Fatal server error: [ 513.417] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) [ 513.417] (EE) [ 513.417] (EE) Please consult the The X.Org Foundation support at http://wiki.x.org for help. [ 513.417] (EE) Please also check the log file at "/home/pi/.local/share/xorg/Xorg.0.log" for additional information. [ 513.417] (EE) [ 513.418] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor [ 513.418] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor [ 513.419] (EE) Server terminated with error (1). Closing log file.

Does anybody know where lies the problem?

PS If You see '*' in the log it was '**' but that is bold text Also there is '!!' in log that was '#' but thats bold


I encountered the same issue. How I solve this was:

  1. create new user named teacher
  2. grant all groups that pi has
  3. cp the /etc/suders.d/010_pi-nopasswd and rename the inner username to teacher
  4. startx and it works.

Be careful: don't run startx in byobu, some bugs.

Cannot open /dev/tty0 (Permission denied), log: `[ 14950.248] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)` Hmmm, why oh why? I had rdp working on Linux Mint 18  [ 13149.834] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) and to make matters worse: $ ps aux | grep xrdp root 13384 0.0 0.0 42472 504 ?


In particular, you want to add your user to the tty group to resolve this specific issue.

gpasswd -a pi tty

where pi is your user.

startx as user pi (permission denied), config directory "/usr/share/X11/xorg.conf.d" (EE) Fatal server error: (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) (EE)  Posted: Wed Oct 19, 2016 7:25 am Post subject: [SOLVED] parse_vt_settings cannot open /dev/tty0 permission Hi all penguines, I cannot launch up any instance of /usr/bin/X from non-root account.


I found a solution:

I don't use .bashrc anymore and I fully moved to rc.local.

sudo node /home/pi/server/server.js &

xinit /usr/bin/chromium-browser --no-sandbox --window-size=1920,1080 --noerrdialogs --start-fullscreen --start-maximized --disable-notifications --disable-infobars --kiosk --incognito http://localhost:3000 -- -nocursor &

exit 0

What this does is runs node.js server on port 3000 and runs chromium on localhost:3000 with no mouse cursor and fully sized chromium browser in something like 15-20 sec time.

Now working on showing it without going blank. Still no success, HELP!

EDIT: If chromium appears with borders use this:

xinit /usr/bin/chromium-browser --no-sandbox --window-position=0,0 --window-size=1920,1080 --noerrdialogs --disable-notifications --disable-infobars --kiosk --incognito http://localhost:3000 -- -nocursor &

View topic, [ 56778.801] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) [ 56778.804] (EE) [ 56778.806] (EE) Please consult the The  Problem with xRDP on Ubuntu 18.04 (parse_vt_settings) Fatal server error: [687588.331] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) [687588


#856351, Debian Bug report logs - #856351 parse_vt_settings: Cannot open /dev/tty0 (​Permission denied). version graph. Package: xinit; Maintainer for  Fatal server error: [ 30.475] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied) I followed the instruction from this post Issues with xRDP and Ubuntu 18.04.2 – How to fix it to solve the issue, i.e. install the missing depenency packages. Following is a summary: remove xrdp than re-install.


Bug#856351: parse_vt_settings: Cannot open /dev/tty0 (Permission , Bug#856351: parse_vt_settings: Cannot open /dev/tty0 (Permission denied). Showing 1-2 of 2 messages. Bug#856351: parse_vt_settings:  I am trying to run xinit chromium-browser some_settings address:port in /home/pi/.bashrc file.. What it does in first version of "Jessie PIXEL" is open chromium browser on start up after console auto-login and opens the page address:port.


[SOLVED] startx: xf86OpenConsole: Cannot open /dev/tty0 / Newbie , xf86OpenConsole: Cannot open /dev/tty0 (Permission denied). I've been into the Archlinux IRC channel, and I've been suggested to chmod  (EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory) However, I can stat and ls the file from the non-root user and the permission on it are 755 arch-linux x11 xorg x-server