Xcode 10 seems to break com.apple.commcenter.coretelephony.xpc

I have upgraded to Xcode 10 on High Sierra and now the Rewarded Ad example project from AdMob complains that com.apple.commcenter.coretelephony.xpc is not working correctly.

Is there a new entitlement that I have to enable? I am searching for hours without any clue.

UPDATE: This only happens from the simulator. On the device it works fine. They must have added a new restriction.

2018-09-22 10:59:39.730813+0100 RewardedVideoExample[1449:26168] libMobileGestalt MobileGestalt.c:890: MGIsDeviceOneOfType is not supported on this platform.
2018-09-22 10:59:40.031746+0100 RewardedVideoExample[1449:26281] Failed to create remote object proxy: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.031865+0100 RewardedVideoExample[1449:26261] Failed to ping server after delegate was set
2018-09-22 10:59:40.031938+0100 RewardedVideoExample[1449:26262] Failed to create synchronous remote object proxy: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.032054+0100 RewardedVideoExample[1449:26262] [NetworkInfo] Descriptors query returned error: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.032353+0100 RewardedVideoExample[1449:26262] Failed to create synchronous remote object proxy: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.032451+0100 RewardedVideoExample[1449:26262] [NetworkInfo] Descriptors query returned error: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.035631+0100 RewardedVideoExample[1449:26262] Failed to create synchronous remote object proxy: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.035714+0100 RewardedVideoExample[1449:26262] [NetworkInfo] Descriptors query returned error: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated.}
2018-09-22 10:59:40.259658+0100 RewardedVideoExample[1449:26314] WF: === Starting WebFilter logging for process RewardedVideoExample
2018-09-22 10:59:40.259805+0100 RewardedVideoExample[1449:26314] WF: _userSettingsForUser : (null)
2018-09-22 10:59:40.259876+0100 RewardedVideoExample[1449:26314] WF: _WebFilterIsActive returning: NO
2018-09-22 10:59:41.020170+0100 RewardedVideoExample[1449:26282] <Google> Cannot find an ad network adapter with the name(s): com.google.DummyAdapter. Remember to link all required ad network adapters and SDKs, and set -ObjC in the 'Other Linker Flags' setting of your build target.
Reward based video ad failed to load: No ad returned from any ad server.
2018-09-22 11:00:09.288227+0100 RewardedVideoExample[1449:26168] [MC] System group container for systemgroup.com.apple.configurationprofiles path is /Users/houmie/Library/Developer/CoreSimulator/Devices/3FF81C00-0DA2-4F98-8964-A84F14FB14A6/data/Containers/Shared/SystemGroup/systemgroup.com.apple.configurationprofiles
2018-09-22 11:00:09.289859+0100 RewardedVideoExample[1449:26168] [MC] Reading from private effective user settings.

Running this in Terminal made it go away:

xcrun simctl spawn booted log config --mode "level:off"  --subsystem com.apple.CoreTelephony

Swift. The connection to service named com.apple.commcenter , [REQUIRED] Step 2: Describe your environment Xcode version: 10 /xcode-10-​seems-to-break-com-apple-commcenter-coretelephony-xpc. I have upgraded to Xcode 11.1 on Mojave and now the Rewarded Ad example project from FacebookSDK complains that com.apple.commcenter.coretelephony.xpc is not working correctly.

I found a workaround restarting the simulator.

The connection to service named com.apple.commcenter , I'm using AWSMobileClient for Cognito signIn seems to work properly but when trying i'm using Xcode 10.1 and AWSMobileClient 2.9.1 /52455652/xcode-10​-seems-to-break-com-apple-commcenter-coretelephony-xpc. Xcode 10 seems to break com.apple.commcenter.coretelephony.xpc Xcode 10-iOS 12 Simulator location simulation fails on City Bicycle Ride/City Run/Freeway Drive Missing Provisioning Profile:Apps must contain a provisioning profile in a file named embedded.mobileprovision

Well it's working on both the simulator and device in Xcode 10.2.

  1. Add CoreTelephony.framework (Optional)

  2. Executing the following command in Terminal:

    xcrun simctl spawn booted log config --mode "level:off" --subsystem 
    com.apple.CoreTelephony
    
  3. From the Xcode menu open: Product > Scheme > Edit Scheme

    On your Environment Variables set OS_ACTIVITY_MODE = disable

  4. Restart simulator

Xcode 10 breaks com.apple.commcenter.coretelephony.xpc, to Xcode 10 and now the rewarded Ad example from AdMob doesn't run anymore. It seems com.apple.commcenter.coretelephony.xpc is. xcrun unable to find simctl. Ask Question In Xcode, open the Xcode menu Xcode 10 seems to break com.apple.commcenter.coretelephony.xpc. 2.

For those who are experiencing this issue in real devices, linking CoreTelephony.framework to the project fixes the problem.

It does not fix it for the simulator, though.

App freezes due to CoreTelephony.xpc |Apple Developer Forums, The app is freeze during this warning, which appear at least 20 times in just one second. If so, please do that and then, when you get stuck, break into the frame #0: 0x0000000108b6ba66 libsystem_kernel.dylib`kevent_id + 10 named com.apple.commcenter.coretelephony.xpc was invalidated. The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated #1965 Closed pabloroca opened this issue Oct 17, 2018 · 13 comments

The connection to service named com.apple.commcenter , run app on simulator with 'iPhone X' from xcode, in debug area, show xcode-10​-seems-to-break-com-apple-commcenter-coretelephony-xpc. The connection to service named com.apple.commcenter.coretelephony.xpc was invalidated. #1251 omaraksim opened this issue Feb 27, 2019 · 5 comments Assignees

iOS 12 freezes application - swift4 - Python, Hello everyone I have a very strange issue with iOS 12, my application is a simple works normally until iOS 11.4.1, now when I upgraded XCode 10 with iOS 12, showAlertGlobally(alert) } break case 1: let storyboard = UIStoryboard(​name: to service named com.apple.commcenter.coretelephony.xpc was invalidated. UserInfo ={NSDebugDescription = The connection to service named com. apple. commcenter. coretelephony. xpc was invalidated.} 2018-09-22 10: 59: 40.031865 + 0100 RewardedVideoExample [1449: 26261] Failed to ping server after delegate was set 2018-09-22 10: 59: 40.031938 + 0100 RewardedVideoExample [1449: 26262] Failed to create synchronous

run app on simulator with 'iPhone X' from xcode, in debug area, show this error info. to service named com.apple.commcenter.coretelephony.xpc was invalidated. node/v10.15.0/bin/yarn npm: 6.5.0 - ~/.node/v10.15.0/bin/npm Watchman: violation: Calling synchronous methods on native modules is not supported in 

Comments
  • I got the same problem with AWS Cognito, did you solve the problem?
  • I had to update OS to Mojawe for it to go away.
  • Oh ok, in my case I realized that this error was happening only with the simulator but not with a real device. EDIT: I just saw your edit about the simulator thing
  • Yes, it's annoying as you have to use your device for testing and can't use the simulator anymore.
  • Did my answer fix your problem?
  • It simply sets a config for the simulator to have no ("off") logging for the subsystem com.apple.CoreTelephony. It's much better than rejecting all OS messages as some of them (I think auto layout warnings also belongs to it) are really useful
  • @ChikabuZ did you install the command line utilities? If not, let me know if it helped. If you already did, let me know as well.
  • @DepartamentoB I installed "Command Line Tools for Xcode" but I receive the same error.
  • This is like spraying febreeze on a piss stain. It's still there. Just smell nicer.
  • Can't believe this is still an issue on Xcode 11+. How Apple devs don't get annoyed with this themselves enough to fix it is beyond me.
  • for me OS_ACTIVITY_MODE = disable worked. Xcode 10.3, Mojave
  • Good way to try.
  • No it does not work, it does not show debug messages. So layout errors does not appear, either. so sad.