This project uses version 5.5.12 of RxJs, which is not supported by Angular v6

how to check rxjs version
rxjs-compat
rxjs versions
cannot find module 'rxjs
uninstall rxjs
npm install rxjs subscription
rxjs/add/operator/map npm
node rxjs

I was trying to run a downloaded project but it was giving me this error

Your global Angular CLI version is greater than your local version. The local Angular CLI version is used.

So I updated cli to latest version.But now I am getting this error.

This project uses version 5.5.12 of RxJs, which is not supported by Angular v6.

How can I update a specific dependency (in this case rxjs) to latest version?

Try running

npm i rxjs@6 --save

It can work !!

Want to upgrade project from Angular v5 to Angular v6, Make sure NodeJS version is 8.9+ if not update it. RxJS v6 has major changes from v5, v6 brings backwards change hence first make your code compatible to latest RxJS version. Update NodeJS version to 8.9+ (this is required by angular cli 6 version) if npm version is < 5 then use npm cache clean 0 This project uses version 5.5.12 of RxJs, which is not supported by Angular v6 Feb 16 '19 0 Router Navigate does not call ngOnInit when same page Nov 28 '19 0 Select > Upload FTP Solution for Eclipse Mar 21 '13

Try running following commands

npm i <module name>@<version>(optional) --save

example: -S is the alias of --save

npm i rxjs@latest -S

yarn add <module name>@<version>(optional)

Or

yarn update <module name>@<version>(optional)
yarn update

ng update --all

This way you can update all or individual modules.

Error running update command when migrating to v6 · Issue #10363 , Hi Guys, You will face this error if you use angular 6. This project uses version 5.5​.12 of RxJs, which is not supported by Angular v6. This project uses version ${rxjsVersion} of RxJs, which is not supported by Angular v6. This project uses version ${rxjsVersion} of RxJs, which is not supported by Angular v6 +. The official RxJs version that is supported is 5.6.0-forward-compat.0 and greater. Please visit the link below to find instructions on how to update RxJs.

Go to package.json, change the below line:

"rxjs": "^5.5.12"

to:

"rxjs": "6.3.3"

Perform npm update, then ng serve. This should work.

ng update @angular/core fails · Issue #10621 · angular/angular-cli , So I updated cli to latest version.But now I am getting this error. This project uses version 5.5.12 of RxJs, which is not supported by Angular v6. How can I update  This should probably be renamed to 'Compatibility with Angular 6 / RxJs v6' and handle all Angular 6 issues at the same time as RxJs6 ones. For example Angular 6 now supports singleton services where you don't need to 'provide' them in app.module and specify providedIn: 'root' parameter to @Injectable instead.

Version 6 of Angular Now Available, Versions Angular CLI: 6.0.0-rc.4 Node: 8.9.4 OS: darwin x64 Angular: 6.0.0-rc.5 ^_^ ng serve This project uses a temporary compatibility version of RxJs Please run the following command to install a compatible version of The first problem ( Schematic input does not validate ) is reported as #10312  RxJS Reactive Extensions Library for JavaScript. This website requires JavaScript.

Package, Versions Angular CLI: 6.0.0 Node: 8.9.1 OS: win32 x64 Angular: RxJS peer dependency is failing with Angular 6 | Make it compatible with Angular 6 #37 I couldn't use ng update @angular/core to upgrade to 6.0.2 (because of package: https://github.com/angulartics/angulartics2/releases/tag/v6.0.0. With the use of rxjs@6 and rxjs-compat@6 , the waring disapeared. The angular slick grid works fine on Angular 6. So, I have both rxjs v6 and rxjs-compat (for compatibility with angular 5) installed. When all libraries (that I am using) finished migrating to Angular 6 , I 'll then drop the compatibility layer defined by rxjs-compat.

rxjs, ng update will not replace your package manager, but uses npm or yarn under CLI v6 now has support for workspaces containing multiple projects, such as multiple RxJS v6 brings with it several major changes, along with a backwards​  This project uses version ${rxjsVersion} of RxJs, which is not supported by Angular v6. The official RxJs version that is supported is 5.6.0-forward-compat.0 and greater. @@ -111,7 +107,7 @@ export class Version {

Comments
  • try to npm update in your project diretory
  • Already did that but it doesn't work.
  • update.angular.io