Rails - Gem Error while installing pg (1.1.3), and Bundler cannot continue

error installing pg: error: failed to build gem native extension.
n error occurred while installing pg 1.0 0 and bundler cannot continue
gem install pg-0.21 0
can't find the 'libpq-fe.h header
gem install pg 1.1 4 source https rubygems org succeeds before bundling
gem install pg failed mac
pg gem
fatal error: libpq-fe h no such file or directory

I am still fairly new to Rails. I am trying to push to Heroku and I am getting errors

The first error is when I run a Bundle Install I get this error message

"An error occurred while installing pg (1.1.3), and Bundler cannot continue. Make sure that gem install pg -v '1.1.3' succeeds before bundling."

I have tried to run this command gem install pg -v '1.1.3'

But it fails and gives me this error message

"ERROR: Error installing pg: ERROR: Failed to build gem native extension."

Does anyone have a solution to this?


try instaling with pg-config like this: gem install pg -v 1.1.3 -- --with-pg-config=/usr/pgsql-9.X/bin/pg_config.

In pg-config path mention the posgtres version installed in you're system.

Error message: Make sure that `gem install pg -v '0.18.1'` succeeds , When i want to start the rails server, i get this error message: An error occurred while installing pg (0.18.1), and Bundler cannot continue. Make sure that "gem  Steps to install postgresql . Install PostgreSQL and its libraries. sudo apt-get install postgresql postgresql-contrib libpq-dev After the installation create a user for postgresql


I had the exact same problem, and solved it by running sudo apt install postgresql-contrib libpq-dev. Then bundle worked just fine.

Ubuntu: Fix "An error occurred while installing pg", An error occurred while installing pg (0.17.1), and Bundler cannot continue. Make sure that gem install pg -v '0.17.1' succeeds before bundling. Learn to structure large Ruby on Rails codebases with the tools you already know and love. Answered here: Can't install pg gem on Windows There is no Windows native version of latest release of pg (0.10.0) released yesterday, but if you install 0.9.0 it should install binaries without issues.


if you're using OSX, you could try running

brew install postgresql

and then installing the gem

Bundler fails to install pg gem which can be successfully installed , What you're trying to accomplish: Successfully run bundler:install from prior to Rails 4.1 gem 'activesupport-json_encoder' # Error handling gem, An error occurred while installing pg (0.18.4), and Bundler cannot continue. Housekeeping Notes: - specified rails < 5 because it's true - hacked on a PG 4.2.x workaround rails/rails#31673 winfred added a commit to aha-app/acts_as_list that referenced this issue Aug 6, 2018


Problem building pg gem, Gem::Ext::BuildError: ERROR: Failed to build gem native extension. current occurred while installing pg (1.1.4), and Bundler cannot continue. As the last lines of the output suggest I tried to do a "gem install pg" (did it with version 0.14, 0.17 and 0.17.1 all with the same results…


Solving issues “Could not find gem 'pg (~> 0.18)' when creating , After a long time not touching around or even just looking what's new in Rails, An error occurred while installing pg (0.21.0), and Bundler cannot continue. When bundle, I met errors below, but after I installs manually gem install minitest -v '4.7.5', I can install bundled gems completely. Is this bundler problem? Bundler::GemNotFound: Could not find minitest-4.7.5.gem for installation An e


"gem install pg" not working, I suspect it is the same problem since my server is running Ubuntu 12.04 x64. ERROR: Error installing pg: ERROR: Failed to build gem native extension. On Ubuntu $ sudo apt-get install postgresql-client libpq5 libpq-dev $ sudo By continuing to browse our website, you agree to our use of cookies. Dismiss Join GitHub today. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together.