anaconda/lib/libcurl.so.4 no version information available when i compile opencv at ubuntu14

When I compiled opencv on Ubuntu, I met this problem "/usr/bin/cmake: /usr/home/anaconda/lib/libcurl.so.4: no version information available (required by cmake)".

I don't know the reason, I have found libcurl.so.4 at /usr/home/anaconda/lib/, is it because I have other version of libcurl.so.4? or I should reinstall the anaconda?


You could conda remove curl and compile against the system curl.

cmake, You could conda remove curl and compile against the system curl. I ran into the problem while trying to use git push Below are some information I get. Please let me know if I can provide more information. $ git push origin master ssh: /home/user/anaconda3/lib/


How about add "su" before the command?

libcurl.so.4 no version information available, The issue turned out to be I had 2 installs of curl on the system. An apt-get install curl and a curl build from source. I ended up removing the curl built from source  Other wrappers are available. The library itself is platform-independent and often used for real-time image processing and computer vision. Version Note. Ubuntu's latest incarnation, Utopic Unicorn, comes with a new version of libav, and opencv sources will fail to build with this new library version.


Removing conda curl didn't help me. I had to upgrade cmake and curl:

conda upgrade curl
conda upgrade cmake

Error message: gtm: /usr/lib/libcurl.so.4: no version information , chenbotao828 opened this issue on Oct 4, 2017 · 7 comments. Open gtm: /usr/​lib/libcurl.so.4: no version information available (required by gtm) diff --git a/​script/build-libgit2-static.sh b/script/build-libgit2-static.sh index 5723721..83fdbc7​  I cannot compile OpenCV with python2 support, even though a small test CMakeLists.txt can detect the installed python interpreter and libraries. System information (version) OpenCV => 3 from git; Operating System / Platform => SUSE Linux Enterprise Server 11 SP4; Compiler => gcc 4.9.3; Detailed description


error: /usr/local/lib/libcurl.so.4: no version information available , wanggw@liutl:~/work/openpose/build$ make -jnproc [100%] Built target error: /​usr/local/lib/libcurl.so.4: no version information available #507. Closed /home/​liutl/anaconda/pkgs/curl-7.38.0-0/lib/libcurl.so.4.3.0 System information (version) OpenCV => 4.0.0-rc; Operating System / Platform => Linux GT72S 4.15.0-32-generic #35~16.04.1-Ubuntu SMP Fri Aug 10 21:54:34 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux; Compiler => $ g++ -v Using built-in specs.


Highest Voted 'anaconda' Questions, How do I install Anaconda on Ubuntu 14.04 from the command line? I've installed opencv for Anaconda with this command: conda install opencv And when I run no version information available (required by /usr/local/lib/libcurl.so.​4). When trying to compile pycaffe on Ubuntu 16.04, with Anaconda 3.6 installed I get  up vote 1 down vote favorite I am currently trying to build OpenCV 3 on Ubuntu. If I just run CMake with the default settings, everything works fine (configure + generate) and the


compiling opencv with anaconda - python, over again /usr/bin/cmake: /home/waspinator/anaconda2/lib/libssl.so.1.0.0: no version information available (required by /usr/lib/x86_64-linux-gnu/libcurl.so.4)  A safe option instead of messing up the system libraries is to download (or build) libz.so.1.2.9 and place it in the directory of your executable (or wherever) and export LD_LIBRARY_PATH to that directory