Distributed 1.21.8 requires msgpack, which is not installed

pip install msgpack
no matching distribution found for msgpack
could not install packages due to an environmenterror: (winerror 5) access is denied
msgpack-python
cannot uninstall 'wrapt'
conda install msgpack-numpy
permissionerror(13, 'access is denied')

I'm having a problem trying to install plotly. I proceeded to upgrade anaconda using the command line on Debian 9 and I received the error message "distributed 1.21.0 requires msgpack, which is not installed".

Then I tried a conda install mspack, then a pip install --upgade plotly, and I get "distributed 1.22.0 requires msgpack, which is not installed". This 1.22.0 error message is what kicked off my whole upgrading process of many packages. Does this break plotly? Don't know, haven't tried but judging from msgpack website https://msgpack.org/, it is probable to cause errors. We'll see, I guess. Not sure what else to do.

pip install msgpack does not fix the problem

I face same issue while installing dask Later I resolved it using either of these two methods.

First Method: Run this command

conda install -c anaconda msgpack-python

Second Method: Run this command

pip install msgpack

distributed 1.21.8 requires msgpack, which is not installed. · Issue , I keep getting this error trying to simply install tf. Why is none of this simple??? Python Module Not Found, Yet Installed and in Search Path Hot Network Questions How could pirates reasonably transport dinosaurs in captivity, some of them enormous, across oceans?

For Windows users who have stumbled upon this thread:

Run Anaconda Prompt as Administrator and enter the following:

pip install msgpack

Msgpack reports not being installed, despite being installed · Issue , messages on the screen. one says requirement met and the other says "​distributed 1.21.8 requires msgpack, which is not installed. mrocklin changed the title Msgpack reports not being installed Msgpack reports not being installed, despite being so Jul 2, 2018 mrocklin changed the title Msgpack reports not being installed, despite being so Msgpack reports not being installed, despite being installed Jul 2, 2018

To answer your multiple questions

  1. "distributed 1.21.8 requires msgpack" This error has nothing to do with plotly installation. Its due to the way anaconda is installed

  2. The error will not affect installation/upgrades of any of the packages.

  3. "pip install msgpack does not fix the problem" .It will not fix until you try to install msgpack with user admin(Windows) / root(linux) right. I got this fixed on my Windows 10 & Lubuntu 16 with above mentioned solution

distributed 1.21.8 requires msgpack, which is not installed. / jeepxie , I face same issue while installing dask Later I resolved it using either of these two methods. First Method: Run this command conda install -c  Also it seems like distributed needs to switch to using msgpack rather than msgpack-python at one point, but that's not really the core issue. I quickly looked at this one and it seems like you get a different dask-mpi script whether you are installing 1.21.6 from the binary wheel or from the source .tar.gz.

I installed the TextBlob package for text classification. Right after that I tried to open Jupyter Notebook and got this error message : AttributeError: type object 'IOLoop' has no attribute 'initialized' I was searching for a solution to above problem and stumbled upon a solution regarding uninstalling tornado and downgrading it to tornado 4.5.3 . I did that and it did not solve the problem. Then I realized this warning distributed 1.22.0 requires msgpack, which is not installed. After installing msgpack the problem is solved.

[Solved] Distributed 1.21.8 requires msgpack, which is not installed., Then I tried a conda install mspack , then a pip install --upgade plotly , and I get "​distributed 1.22.0 requires msgpack, which is not installed". This  conda install msgpack # or pip install msgpack # or conda install -c conda-forge msgpack The right choice sort of depends on what you're doing. Using the -c flag with conda gives you access to non-core repositories - these carry fewer guarantees about working together, but gives you access to many more versions of the package, usually.

If you are trying to installing msgpack in your work/office machine where PIP install have proxy issues. you can try below method.

Download msgpack using below link : https://pypi.org/project/msgpack-python/#files Extract the .tar.gz file Navigate till setup.py file in command prompt Execute python setup.py install command to install

Distributed 1.21.8 requires msgpack, which is not installed, Distributed 1.21.8 requires msgpack, which is not installed. likeanswer 2019-04-​24. I'm having a problem trying to install plotly. I proceeded to upgrade  I tried to install msgpack-python==0.4.8 and just msgpack, but it doesn't solve the problem. Borg works fine locally, but remotely it gives the errors just like in the first message of this thread. This comment has been minimized.

Distributed 1.21.8 requires msgpack, which is not installed-python , Not sure whta this means? "distributed 1.21.8 requires msgpack, which is not installed. " What should I do with this when I've tried to do a "!pip  msgpack-numpy will try to use the binary (fast) extension in msgpack by default. If msgpack was not compiled with Cython (or if the MSGPACK_PUREPYTHON variable is set), it will fall back to using the slower pure Python msgpack implementation.

Distributed 1.21.8 requires msgpack, which is not installed,

distributed 1.21.8 requires msgpack, which is not installed.,

Comments
  • Please keep in mind that pip wont work in anaconda. stackoverflow.com/questions/45917541/…