why doesn't task wrapper function work

There are many good suggestions to how to fix gradle versions, but some of them are outdated or I just couldn't find the paths that were suggested. one solution did work for me is project>project structure>project>gradle version.

Here I can change it to the supported version, and successfully builds the project.

A small error in the the javascript code, so a change is made to it. Ionic build android, now something wrong occurrs here. Minimum supprted Gradle version is 2.14.1. Current version is 2.13..

But in the project/platforms/android/build.gradle

task wrapper(type: Wrapper){ gradleVersion = '2.14.1' }

and from this link, it suggests that this is the way set your gradle wrapper.

So I am expecting in project/platforms/android/gradle/wrapper/gradle-wrapper.properties to have distributionUrl=http\://services.gradle.org/distributions/gradle-2.14.1-all.zip, instead this is what it has distributionUrl=http\://services.gradle.org/distributions/gradle-2.13-all.zip.

Can't make direct change to this file project/platforms/android/gradle/wrapper/gradle-wrapper.properties, because after each build it will revert back to gradle-2.13-all.zip.

What is going on here? can't find anything that explain why it keeps on changing the distributionUrl=http\://services.gradle.org/distributions/gradle-2.13-all.zip. Would anyone be kindly explain this please? Maybe something very stupid that I have missed. Thank you.

Links that I have looked at

"Gradle Version 2.10 is required." Error

How to update gradle in android studio

ionic build android error when download gradle

gradle code

apply plugin: 'com.android.application'

buildscript {
    repositories {
        mavenCentral()
        jcenter()
    }

    // Switch the Android Gradle plugin version requirement depending on the
    // installed version of Gradle. This dependency is documented at
    // http://tools.android.com/tech-docs/new-build-system/version-compatibility
    // and https://issues.apache.org/jira/browse/CB-8143
    dependencies {
        classpath 'com.android.tools.build:gradle:2.2.1'
    }
}

// Allow plugins to declare Maven dependencies via build-extras.gradle.
allprojects {
    repositories {
        mavenCentral();
        jcenter();
    }
}

task wrapper(type: Wrapper) {
    gradleVersion = '2.14.1'
}

// Configuration properties. Set these via environment variables, build-extras.gradle, or gradle.properties.
// Refer to: http://www.gradle.org/docs/current/userguide/tutorial_this_and_that.html
ext {
    apply from: 'CordovaLib/cordova.gradle'
    // The value for android.compileSdkVersion.
    if (!project.hasProperty('cdvCompileSdkVersion')) {
        cdvCompileSdkVersion = null;
    }
    // The value for android.buildToolsVersion.
    if (!project.hasProperty('cdvBuildToolsVersion')) {
        cdvBuildToolsVersion = null;
    }
    // Sets the versionCode to the given value.
    if (!project.hasProperty('cdvVersionCode')) {
        cdvVersionCode = null
    }
    // Sets the minSdkVersion to the given value.
    if (!project.hasProperty('cdvMinSdkVersion')) {
        cdvMinSdkVersion = null
    }
    // Whether to build architecture-specific APKs.
    if (!project.hasProperty('cdvBuildMultipleApks')) {
        cdvBuildMultipleApks = null
    }
    // .properties files to use for release signing.
    if (!project.hasProperty('cdvReleaseSigningPropertiesFile')) {
        cdvReleaseSigningPropertiesFile = null
    }
    // .properties files to use for debug signing.
    if (!project.hasProperty('cdvDebugSigningPropertiesFile')) {
        cdvDebugSigningPropertiesFile = null
    }
    // Set by build.js script.
    if (!project.hasProperty('cdvBuildArch')) {
        cdvBuildArch = null
    }

    // Plugin gradle extensions can append to this to have code run at the end.
    cdvPluginPostBuildExtras = []
}

// PLUGIN GRADLE EXTENSIONS START
apply from: "cordova-plugin-badge/simplelogin777664-badge.gradle"
// PLUGIN GRADLE EXTENSIONS END

def hasBuildExtras = file('build-extras.gradle').exists()
if (hasBuildExtras) {
    apply from: 'build-extras.gradle'
}

// Set property defaults after extension .gradle files.
if (ext.cdvCompileSdkVersion == null) {
    ext.cdvCompileSdkVersion = privateHelpers.getProjectTarget()
}
if (ext.cdvBuildToolsVersion == null) {
    ext.cdvBuildToolsVersion = privateHelpers.findLatestInstalledBuildTools()
}
if (ext.cdvDebugSigningPropertiesFile == null && file('debug-signing.properties').exists()) {
    ext.cdvDebugSigningPropertiesFile = 'debug-signing.properties'
}
if (ext.cdvReleaseSigningPropertiesFile == null && file('release-signing.properties').exists()) {
    ext.cdvReleaseSigningPropertiesFile = 'release-signing.properties'
}

// Cast to appropriate types.
ext.cdvBuildMultipleApks = cdvBuildMultipleApks == null ? false : cdvBuildMultipleApks.toBoolean();
ext.cdvMinSdkVersion = cdvMinSdkVersion == null ? null : Integer.parseInt('' + cdvMinSdkVersion)
ext.cdvVersionCode = cdvVersionCode == null ? null : Integer.parseInt('' + cdvVersionCode)

def computeBuildTargetName(debugBuild) {
    def ret = 'assemble'
    if (cdvBuildMultipleApks && cdvBuildArch) {
        def arch = cdvBuildArch == 'arm' ? 'armv7' : cdvBuildArch
        ret += '' + arch.toUpperCase().charAt(0) + arch.substring(1);
    }
    return ret + (debugBuild ? 'Debug' : 'Release')
}

// Make cdvBuild a task that depends on the debug/arch-sepecific task.
task cdvBuildDebug
cdvBuildDebug.dependsOn {
    return computeBuildTargetName(true)
}

task cdvBuildRelease
cdvBuildRelease.dependsOn {
    return computeBuildTargetName(false)
}

task cdvPrintProps << {
    println('cdvCompileSdkVersion=' + cdvCompileSdkVersion)
    println('cdvBuildToolsVersion=' + cdvBuildToolsVersion)
    println('cdvVersionCode=' + cdvVersionCode)
    println('cdvMinSdkVersion=' + cdvMinSdkVersion)
    println('cdvBuildMultipleApks=' + cdvBuildMultipleApks)
    println('cdvReleaseSigningPropertiesFile=' + cdvReleaseSigningPropertiesFile)
    println('cdvDebugSigningPropertiesFile=' + cdvDebugSigningPropertiesFile)
    println('cdvBuildArch=' + cdvBuildArch)
    println('computedVersionCode=' + android.defaultConfig.versionCode)
    android.productFlavors.each { flavor ->
        println('computed' + flavor.name.capitalize() + 'VersionCode=' + flavor.versionCode)
    }
}

android {
  sourceSets {
    main {
      manifest.srcFile 'AndroidManifest.xml'
      java.srcDirs = ['src']
      resources.srcDirs = ['src']
      aidl.srcDirs = ['src']
      renderscript.srcDirs = ['src']
      res.srcDirs = ['res']
      assets.srcDirs = ['assets']
      jniLibs.srcDirs = ['libs']
    }
  }
  defaultConfig {
    if (cdvMinSdkVersion != null) {
      minSdkVersion cdvMinSdkVersion
    }
    minSdkVersion 16
    targetSdkVersion 23
  }
  lintOptions {
    abortOnError false;
  }
  compileSdkVersion 23
  buildToolsVersion '21.1.2'
  if (Boolean.valueOf(cdvBuildMultipleApks)) {
    productFlavors {
      armv7 {
        versionCode defaultConfig.versionCode * 10 + 2
        ndk {
          abiFilters "armeabi-v7a", ""
        }
      }
      x86 {
        versionCode defaultConfig.versionCode * 10 + 4
        ndk {
          abiFilters "x86", ""
        }
      }
      all {
        ndk {
          abiFilters "all", ""
        }
      }
    }
  }
  /*

  ELSE NOTHING! DON'T MESS WITH THE VERSION CODE IF YOU DON'T HAVE TO!

  else if (!cdvVersionCode) {
    def minSdkVersion = cdvMinSdkVersion ?: privateHelpers.extractIntFromManifest("minSdkVersion")
    // Vary versionCode by the two most common API levels:
    // 14 is ICS, which is the lowest API level for many apps.
    // 20 is Lollipop, which is the lowest API level for the updatable system webview.
    if (minSdkVersion >= 20) {
      defaultConfig.versionCode += 9
    } else if (minSdkVersion >= 14) {
      defaultConfig.versionCode += 8
    }
  }
  */
  compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_7
    targetCompatibility JavaVersion.VERSION_1_7
  }
  if (cdvReleaseSigningPropertiesFile) {
    signingConfigs {
      release {
        // These must be set or Gradle will complain (even if they are overridden).
        keyAlias = ""
        keyPassword = "__unset"
        // And these must be set to non-empty in order to have the signing step added to the task graph.
        storeFile = null
        storePassword = "__unset"
      }
    }
    buildTypes {
      release {
        signingConfig signingConfigs.release
      }
    }
    addSigningProps(cdvReleaseSigningPropertiesFile, signingConfigs.release)
  }
  if (cdvDebugSigningPropertiesFile) {
    addSigningProps(cdvDebugSigningPropertiesFile, signingConfigs.debug)
  }
  productFlavors {
  }
}

dependencies {
  compile fileTree(include: '*.jar', dir: 'libs')
  // SUB-PROJECT DEPENDENCIES START
    debugCompile project(path: "CordovaLib", configuration: "debug")
    releaseCompile project(path: "CordovaLib", configuration: "release")
    compile "com.android.support:support-v4:+"
    // SUB-PROJECT DEPENDENCIES END
}

def promptForReleaseKeyPassword() {
    if (!cdvReleaseSigningPropertiesFile) {
        return;
    }
    if ('__unset'.equals(android.signingConfigs.release.storePassword)) {
        android.signingConfigs.release.storePassword = privateHelpers.promptForPassword('Enter key store password: ')
    }
    if ('__unset'.equals(android.signingConfigs.release.keyPassword)) {
        android.signingConfigs.release.keyPassword = privateHelpers.promptForPassword('Enter key password: ');
    }
}

gradle.taskGraph.whenReady { taskGraph ->
    taskGraph.getAllTasks().each() { task ->
        if (task.name == 'validateReleaseSigning') {
            promptForReleaseKeyPassword()
        }
    }
}

def addSigningProps(propsFilePath, signingConfig) {
    def propsFile = file(propsFilePath)
    def props = new Properties()
    propsFile.withReader { reader ->
        props.load(reader)
    }

    def storeFile = new File(props.get('key.store') ?: privateHelpers.ensureValueExists(propsFilePath, props, 'storeFile'))
    if (!storeFile.isAbsolute()) {
        storeFile = RelativePath.parse(true, storeFile.toString()).getFile(propsFile.getParentFile())
    }
    if (!storeFile.exists()) {
        throw new FileNotFoundException('Keystore file does not exist: ' + storeFile.getAbsolutePath())
    }
    signingConfig.keyAlias = props.get('key.alias') ?: privateHelpers.ensureValueExists(propsFilePath, props, 'keyAlias')
    signingConfig.keyPassword = props.get('keyPassword', props.get('key.alias.password', signingConfig.keyPassword))
    signingConfig.storeFile = storeFile
    signingConfig.storePassword = props.get('storePassword', props.get('key.store.password', signingConfig.storePassword))
    def storeType = props.get('storeType', props.get('key.store.type', ''))
    if (!storeType) {
        def filename = storeFile.getName().toLowerCase();
        if (filename.endsWith('.p12') || filename.endsWith('.pfx')) {
            storeType = 'pkcs12'
        } else {
            storeType = signingConfig.storeType // "jks"
        }
    }
    signingConfig.storeType = storeType
}

for (def func : cdvPluginPostBuildExtras) {
    func()
}

// This can be defined within build-extras.gradle as:
//     ext.postBuildExtras = { ... code here ... }
if (hasProperty('postBuildExtras')) {
    postBuildExtras()
}

Update

'gradlew wrapper throws error, because certain wrapper doesn't exist under maven and the sub build.gradle uses it to download 2.14.1.prom and 2.14.1.jar. This link will explain it.

Found problem

The problem why it keeps on changing back to 2.13-all.zip is because of this line, var distributionUrl = process.env['CORDOVA_ANDROID_GRADLE_DISTRIBUTION_URL'] || 'http\\://services.gradle.org/distributions/gradle-2.13-all.zip'; in the [project name]/platforms/android/cordova/lib/builders/GradleBuilder.js instead of ~/android/lib/GradleBuilder.js. (Line 164)

Why Trump doesn't want to wear a mask - CNN, It's no surprise that President Donald Trump says he won't follow CDC recommendations to wear a mask to stop the spread of coronavirus,  To find out why, Menachery has been giving mice at his Texas lab SARS — which is a very close cousin to the new coronavirus. Baby mice at his lab have shaken off the infection, while the older

The problem why it keeps on changing back to 2.13-all.zip is because of this line, var distributionUrl = process.env['CORDOVA_ANDROID_GRADLE_DISTRIBUTION_URL'] || 'http\\://services.gradle.org/distributions/gradle-2.13-all.zip'; in the [project name]/platforms/android/cordova/lib/builders/GradleBuilder.js instead of ~/android/lib/GradleBuilder.js. (Line 164)

Why Johnny Doesn't Flap: NT is OK!: Morton, Clay, Morton, Gail , Why Johnny Doesn't Flap: NT is OK! [Morton, Clay, Morton, Gail, Merry, Alex] on Amazon.com. *FREE* shipping on qualifying offers. Why Johnny Doesn't Flap:  If you were to say Alicia Keys doesn’t wear makeup and just relies on her really great skincare routine, you’d be right.And if you were to argue that she actually does wear makeup, and you've

if you are using Eclipse, just change the version (example gradleVersion = '4.8') and run the 'wrapper' task under 'build-setup' (Gradle Tasks View) and console output would be

Working Directory: C:\aa\gradle-jar
Gradle User Home: C:\Users\aa\.gradle
Gradle Distribution: Gradle wrapper from target build
Gradle Version: 4.8
Java Home: C:\Program Files\Java\jdk1.8.0_91

Biden Fumbles Interview: Why Doesn't Trump Act Like A President , Biden Fumbles Interview: Why Doesn't Trump Act Like A President? "That's A Stupid Way To Say It, Sorry". More Videos. Next Up. Biden At  Read Why Doesn’t God Heal Every Sickness, Disease, and Illness? by Chris Russell on BibleStudyTools.com Christian Blogs.

A president should want all Americans to vote. Why doesn't Trump , Why doesn't Trump? A precinct deputy in St. Petersburg, Fla., wears gloves to assist voters dropping off ballots during Florida's primary election  Cats may purr while they demonstrate aggression — you may have seen your cat purr even as his tail puffs up to about three times its normal size. Cats also purr when they are sick, injured or scared. It’s been suggested that the purr has healing powers, and there may well be some truth to that. Not Every Cat Purrs. So why doesn’t your cat

Jason Fried: Why work doesn't happen at work, Jason Fried has a radical theory of working: that the office isn't a good place to do it. He calls out the two main offenders (call them the M&Ms) and offers three  Here's Why Donald Trump Doesn't Want Anyone To Know His Grades Or SAT Scores Christopher Rim Senior Contributor Opinions expressed by Forbes Contributors are their own.

Why Doesn't My Child Want To Go Outside?, Why Doesn't My Child Want To Go Outside? It's important we all stay home during the UK lockdown, but some parents are finding their children  Why doesn’t the U.S. use the metric system? Phil Lewis/shutterstock As of today, the entire world has adopted the metric system, with the exception of the United States, Myanmar, and Liberia

Comments
  • Doesn't affect anything, but note that you can just do this terser syntax: wrapper { gradleVersion = '2.14.1' }
  • Thanks @weston, but somehow it still gives me the same error
  • Yeah, I did say "Doesn't affect anything" It wasn't meant to be a fix, just a tip.
  • You don't have any wrapper tasks defined in the subprojects build.gradle files do you?
  • two build.gradle files, but only one has wrapper task and it is the one I mentioned above.
  • Hi @kiskae, just want to be sure if I understand your suggestions correctly. I used command prompt, in the project/platforms/android/ and used this commands. I have Gradle 2.13 as a return if i used gradlew --version and failed with minimum version error if used gradlew. I can't use the ./ in the command prompt.
  • Why can't you use ./gradlew? What happens if you do?
  • sorry, it doesn't work. this is the message i get if I try to use it '.' is not recognised as an internal or external command, operable program or batch file.
  • odd, what operating system is this on? and what terminal? . is pretty standard for current directory
  • One thing you could try is to upgrade with gradlew wrapper and then making the gradle-wrapper.properties file read only. Then see if some part of your toolchain complains