Failed to resolve: com.google.firebase:firebase-core:11.2.0

I'm getting multiple "Failed to Resolve" issues when syncing my project. They are all firebase and play-services related. I made sure they are all the same (11.2.0). I've also checked and the latest version for both is 11.2.0. Also, all the other answers to similar questions involve updating Google play services and repository in the SDK Manager but mine is already up to date.

Any idea why I can't sync my project?

EDIT - Current working solution

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'
        classpath 'com.google.gms:google-services:3.0.0'
        classpath 'com.google.firebase:firebase-plugins:1.0.4'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
        maven { url "https://maven.google.com" } 
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Add maven { url "https://maven.google.com" } to your root level build.gradle file

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

Failed to resolve com.google.firebase: firebase-core 10.0.1, android - Failed to resolve: com.google.firebase:firebase-core:11.2.0. Failed to resolve Duration: 2:29 Posted: Feb 5, 2018 I'm getting multiple "Failed to Resolve" issues when syncing my project. They are all firebase and play-services related. I made sure they are all the same (11.2.0). I've also checked and the latest version for both is 11.2.0.


Play services and Firebase dependencies are now available via maven.google.com with the release of version 11.2.0 of Google Play services and Firebase.

You can find the Google Play Services official doc here and the firebase doc here..

allprojects {
    repositories {
        jcenter()
        maven { url 'https://maven.google.com' }
    }
}

If you are using the android gradle plugin 3.x you can also use:

allprojects {
    repositories {
        jcenter()
        google()
    }
}

Failed to resolve: com.google.firebase:firebase-core:11.2.0 , Failed to resolve: com.google.firebase:firebase-core:11.2.0. I'm getting multiple "​Failed to Resolve" issues when syncing my project. They are all firebase and  Questions: I’m getting multiple “Failed to Resolve” issues when syncing my project. They are all firebase and play-services related. I made sure they are all the same (11.2.0). I’ve also checked and the latest version for both is 11.2.0. Also, all the other answers to similar questions involve updating Google play services and


I just fixed same error by adding firebase-core dependency.

implementation 'com.google.firebase:firebase-core:16.0.1'

Firebase Android Release Notes, Add maven { url "https://maven.google.com" } to your root level build.gradle file allprojects { repositories { jcenter() maven { url  Failed to resolve: com.google.firebase:firebase-core:11.2.0 (6 answers) Closed 2 years ago . I know that this question has been asked a lot, but the answer is always to go to your SDK Manager and make sure that Google Play Services and Google Repository are installed/updated.


Failed to resolve: com.google.firebase:firebase-core:11.2.0, After updating to the semantinc versioning the OneSignal Gradle plugin fails. jkasten2 changed the title he library com.google.firebase:firebase-iid is being I also created an issue on this repo to automatically resolve a dependency mismatch like this in the future. Update firebase-core and firebase-messaging #3060. This feature is not available right now. Please try again later.


The best Method to fix this problem is not using the manual method of linking firebase to your app.

I have tried adding latest firebase repo by referring to this Link .

It showed error " failed to resolve the dependencies firebase 11.2.0"

FireBase recommends adding firebase to your app with the help of FireBase Assistant for Android Studio Version 2.2 and Higher. Manually adding the latest library to build-gradle(module) result in an error as above.

Firebase assistant added lower versions 10.0.1 automatically to dependencies on the module gradle-build which is compatible and could be resolved.

Using Firebase assistant is so easy and 2 step process. For reference, You can use the "Use the Firebase Assistant" section on the same link mentioned above.

It Really worked Out with my Android Studio 2.3.3. And also make sure Your Google Repository is up to date

com.google.gms:google-services Compatibility Issue, I'm setting up the firebase project exactly following the instructions. I keep getting the above error on syncing with gradle. Updating gradle  In addition to downloading the latest "Google Play Services" as suggested by John Oreilly above I also had to update my 'Google Repository' to get it to work.. In Android Studio go to "Tools -> Android -> SDK manager".


Failed to resolve: com.google.firebase:firebase-core:16.0.0 · Issue , Firebase Authentication, Firebase Crashlytics, Firebase Crashlytics NDK, Cloud Failure to find any licenses when a library project is present (GitHub Issue #​119) method overloading when POM file cannot be resolved (GitHub Issue #​120) When you upgrade your app's Play services dependencies to 11.2.0 or later,  I’m getting multiple “Failed to Resolve” issues when syncing my project. They are all firebase and play-services related. I made sure they are all the same (11.2.0). I’ve also checked and the latest version for both is 11.2.0. Also, all the other answers to similar questions involve updating Google play services and repository in the […]


Release Notes | Google APIs for Android, Failed to resolve: com.google.firebase:firebase-core:11.2.0. Question. I'm getting multiple "Failed to Resolve" issues when syncing my project. They are all  Error:(29, 13) Failed to resolve: com.google.firebase:firebase-core:11.8.0 Let us know it wroks or not Please share if you have any other way. HappyFirebase Please subcribe us to watch


Failed to resolve: com.google.firebase:firebase-core:11.2.0, FCM: Gradle failed to resolve firebase-core library. I'm using For example, instead of compile 'com.google.android.gms:play-services:11.2.0' Do compile  Dismiss Join GitHub today. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together.