ERROR: libmp3lame >= 3.98.3 not found

libmp3lame ffmpeg
opus not found using pkg-config
error: libx264 not found
update ffmpeg
install libmp3lame

I am installing ffmpeg utility, but I am facing libmp3lame >= 3.98.3 not found not found error. I am able to find lame-3.99.5-1.el6.rf.x86_64.rpm and lame-libs-3.98.4-1.el6.nux.x86_64.rpm but installing these are not solving the problem. I am not able to find libmp3lame rpm to install.

Can anyone help me here?

[root@sdp-dev-03:/opt/ffmpeg] # ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --extra-libs=-ldl --enable-version3 --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvpx --enable-libfaac --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libvo-aacenc --enable-libxvid --disable-ffplay --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter --enable-pthreads

ERROR: libmp3lame >= 3.98.3 not found

If you think configure made a mistake, make sure you are using the latest version from Git. If the latest version fails, report the problem to the ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net. Include the log file "config.log" produced by configure as this will help solve the problem.


What worked for me was building lame from source. Download lame from here: https://sourceforge.net/projects/lame/files/lame/3.99/, then extract and install:

tar -zxvf lame-3.99.5.tar.gz 
cd lame-3.99.5
./configure
make
sudo make install

Check to see where libmp3lame.a is:

locate libmp3lame.a

Its probably in /usr/local/lib.

Now when you go to configure ffmpeg, try adding that path to the end of your ./configure string. For me it made the difference. e.g.:

--extra-ldflags=-L/usr/local/lib

[FFmpeg-user] configure error, I am working through the dependencies, but having a problem with libmp3lame. > > This is my configure command: > ./configure --extra-cflags=-I/  Cannot register libmp3lame.dll Recommended Solution to Fix Dll Error To fix errors related with .DLL file you need to download libmp3lame.dll and copy it to the installation folder of the application or game, or copy it into the Windows system folder and it should fix the error.


For configure troubleshooting see the ffbuild/config.log in the ffmpeg source directory.

In my case it had missing references to libmath functions, even if -lm was set in host_extralibs.

For a quick-fix add -lm to the configure script:

enabled libmp3lame        && require "libmp3lame >= 3.98.3" lame/lame.h lame_set_VBR_quality -lmp3lame -lm

How to install libmp3lame for ffmpeg, I would want to convert all possible audio files to mp3. I get the error 'codec not found'. here's what i typed: /var/www/i/uploads$ sudo /  libmp3lame.dll file is a critical component for the software to work properly and without any dll error messages. You may receive an error message like the ones below that indicates the file is not found, damaged, or the wrong version. This application failed to start because libmp3lame.dll was not found.


I just experienced this problem. I had lame v3.99.5 installed, but ffmpeg configure was giving ERROR: libmp3lame >= 3.98.3 not found.

In addition to --extra-ldflags, I had to specify --extra-cflags. So, the configure line was:

./configure [...] --enable-libmp3lame [...] --extra-ldflags=-L/usr/local/lib --extra-cflags=-I/usr/local/include

how to solve the ERROR: libmp3lame >= 3.98.3 not found , ERROR: libmp3lame >= 3.98.3 not found i have tried adding a line in ld.so.conf with a line /usr/local/lib and i checked in that directory if the file. Sometimes libmp3lame.dll error can happen because of malware on your computer. The malicious software can intentionally corrupt DLL files in order to substitute them with its own malicious files. Therefore, your number one priority should be to scan your computer for malware and eliminate it as soon as possible.


In my case the solution for ffmpeg/3.1.3 (based on https://github.com/Homebrew/legacy-homebrew/issues/44489) was to add:

--host-ldflags=-L/usr/local/lib

to the configure string.

ERROR: libmp3lame >= 3.98.3 not found « How to , and other stuff , Linux — admin @ 10:29 am. Well if you have this error when you try to install ffmpeg then you must download lame from sourceforge. ERROR: libmp3lame >= 3. 98. 3 not found i have tried adding a line in ld.so.conf with a line /usr/local/lib and i checked in that directory if the file libmp3lame is present and its there but why is it i get the ERROR: libmp3lame >= 3.98.3 not found any work around for this guys? thanks in advance


this is my way:

install X11,and goto ffmpeg path,and code this in the Terminal:

    pkg-config usr/local/lib
    pkg-config usr/lib
    pkg-config usr/X11/lib

then code ./configure xxxx.

[SOLVED] Error with libmp3lame and winff, Hi, I used sbopkg to install FFMPEG + WINFF + LAME I want convert file.opus to file.mp3, but winff report me: unknown encoder LIBMP3LAME. ERROR: libmp3lame >= 3.98.3 not found. If you think configure made a mistake, make sure you are using the latest version from Git. If the latest version fails, report the problem to the ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net. Include the log file "config.log" produced by configure as this will help solve the problem.


How to add libmp3lame of ffmpeg in ExoPlayer? · Issue #3117 , to add "libmp3lame" of FFMpeg in ExoPlayer . But it's happened that "ERROR: libmp3lame >= 3.98.3 not found" I already add mp3lame-dev . On Sat, Oct 28, 2017, at 10:31 AM, Reindl Harald wrote: > i guess this only affects the current snapshot since releases which > nobody should use - yes, sarcasm - have no problems I believe the git master branch is currently experiencing a cleanup and merge cycle that has been postponed for some time.


ERROR: libmp3lame >= 3.98.3 not found · Issue #32 · Kagami , I am getting the following error. After searching through existing issues, I've tried the following to build: git clone git submodule init && git  gypified libmp3lame C library. Contribute to gypified/libmp3lame development by creating an account on GitHub.


libmp3lame error, libmp3lame error. Post by thelostpenguin98 » Sun Jul 16, 2017 6:12 am. Hi! So I'​ve just installed Mixxx and I also got the libmp3lame thingy and I did everything  The path to libmp3lame.dylib must be readable and executable for Mixxx's actual user. Alternate methods Here are some other ways our users have found to broadcast their mix sessions, useful for Mixxx versions 1.8.x and earlier, or if you're having problems with the above.