Could not resolve all dependencies for configuration ':app:_debugApkCopy'

could not resolve all dependencies for configuration driver
could not resolve all dependencies for configuration ':app:_debugcompile
could not resolve all files for configuration ':classpath' gradle
could not resolve all files for configuration ' compileclasspath'. gradle
could not resolve all dependencies for configuration ':app:debugruntimeclasspath
could not resolve all files for configuration ' lintclasspath' unity
could not resolve all dependencies for configuration _debugapk ionic
could not resolve all artifacts for configuration ' classpath'. gradle

I'm new in Android Studio, I've tried to write to fire base and when android offered me something I accepted and then everything stop working and he didn't recognize any object.

I get this error:

**Error: A problem occurred configuring project ':app'.**
> Could not resolve all dependencies for configuration ':app:_debugApkCopy'.
   > Could not find com.google.android.gms:play-services-appindexing:10.0.1.

I've already updated ths SDK and I think my dependencies are fine. Any other suggestion?

edit: i find out that it happen after i copied code from somewhere and click on "alt + enter" and then accidentally click on some option whit "...api..." (i can't restore that).

I copy the code to other computer and now it's working.

Dependencies:

Try removing your dependencies and rebuilding the app again. Try Clean and rebuild.

Could not resolve all dependencies for configuration ':classpath , Right im not sure if it will work for others but worked for me. I changed proxyPort to 8080 and used jcenter instead of Maven. But i had to apply  As far as I can see here spring-context-support version 5.0.0.M5 is not release yet. What's more there's no need to define a dedicated dependencies entry for spring-context-support since most of the modules you specified depend on spring-context-support transitively and it will be resolved to a correct version.

I got the same problem.

react-native upgrade

Find the solution here: https://stackoverflow.com/a/34995870/5834287 - and it start works!

could not resolve all dependencies for configuration ':compile , You did not tell Gradle where to find commons-lang3 library. Easy fix is to add the following to your build script: repositories { mavenCentral() }. Teams. Q&A for Work. Stack Overflow for Teams is a private, secure spot for you and your coworkers to find and share information.

Removing it fixed my problem. So simply remove "compile 'com.google.android.gms:play-services-appindexing:10.2.6'" from your project. Build. And run. Should be fine then

Gradle Run: Could not resolve all dependencies, Hi I am getting following error in new project on Android studio 0.8.0. Error:A problem occurred configuring root project 'abc'. > Could not  you converted the repository dependency to a file dependency. that's why it makes a difference. I'm just not sure why your original snippet didn't work. could you try again by declaring your dependency like with :swt:64? Does this make a difference? – Rene Groeschke Nov 23 '15 at 7:07

Remove node_module and run npm install

RESOLVED -- Build Failure: "Could not resolve all dependencies", Hello, I'm new to using Gradle and when running ./gradlew I'm getting this error: Could not resolve all dependencies for configuration ':testCompileClasspath'. Hi, Its not helping me. It throws Could not resolve all dependencies for configuration ':classpath'. Could not resolve com.bmuschko:gradle-cargo-plugin:2.1.1. - Whatever plugin it is. the peer is not authenticated. Please Help! – SabareeshSS Jul 1 '15 at 12:40

Dependencies task fails with "Could not resolve all dependencies , RESOLVED ---- There are many instances of Android and Crosswalk Could not resolve all dependencies for configuration ':_debugCompile'. * What went wrong: A problem occurred configuring project ':AssetLoader'. > Could not resolve all dependencies for configuration ':AssetLoader:classpath'. > Stage final is not one of [dev] allowed for strategy development. * Try: Run with --info or --debug option to get more log output.

Could not resolve all artifacts for configuration 'classpath' · Issue , gradlew :app:dependencies fails with the following error in specific configurations > Could not resolve all dependencies for configuration  This command will ask replace existing file or not. If you want to replace a particular file press Y and hit enter button or press N. After completing this command than run command react-native link. This command will link all dependencies than you can run command react native run-android /ios. This issue create when you uninstall some dependencies so sometimes it do not update build files like setting.gradle build.gradle etc.

Could not resolve all dependencies for configuration ':_debugApk , Could not resolve all artifacts for configuration 'classpath' #23553 This dependency is used internally, and not exposed to consumers on their  could not be resolve Could not resolve ar Could not resolve could not resolve ho could not resolve pr Could not resolve ty Could not resolve de ssh: Could not resolve hostname Could not copy all r Could not apply the stored configuration for monitors could not execute query Resolve classpath classpath CLASSPATH classpath classpath classpath

Comments
  • post your build.gradle file details
  • could not resolve all dependencies for configuration ':app:debugAPKCopy'
  • tried but now luck. still i am getting the same error.
  • You can try(in bash) : cd android && ./gradlew clean
  • This solution actual worked for me. I spent whole day for the solution. Thanks.