cannot find module "firebase-functions"

cannot find module '@angular
error cannot find module discord
uncaught error: cannot find module
cannot find module .'' - ionic
cannot find module '@angular 8
cannot find module 'react
cannot find module ts
cannot find module 'dotenv

I imported and downloaded: firebase-functions and firebase-admin using npm i <package> but it give me a lint error like: cannot find module "firebase-functions". I also restarted vscode, but problem persists..


Could it be problem with webpack or tsconfig?

Some important packages in package.json:

{
    "dependencies": {
    "@angular/animations": "^5.2.3",
    "@angular/cdk": "^5.1.1",
    "@angular/common": "^5.2.2",
    "@angular/compiler": "^5.2.2",
    "@angular/core": "^5.2.2",
    "@angular/forms": "^5.2.2",
    "@angular/http": "^5.2.2",
    "@angular/material": "^5.0.2",
    "@angular/material-moment-adapter": "^5.2.3",
    "@angular/platform-browser": "^5.2.2",
    "@angular/platform-browser-dynamic": "^5.2.2",
    "@angular/platform-server": "^5.2.3",
    "@angular/router": "~5.2.2",
    "core-js": "^2.5.3",
    "express": "^4.16.2",
    "firebase": "^4.9.1",
    "firebase-admin": "~5.8.1",
    "firebase-functions": "^0.8.1",
    "zone.js": "0.8.18"
  },
  "private": true,
  "devDependencies": {
    "@angular/cli": "^1.6.7",
    "@angular/compiler-cli": "^5.2.2",
    "@angular/language-service": "^4.2.4",
    "@types/jasmine": "~2.5.53",
    "@types/jasminewd2": "~2.0.2",
    "@types/node": "~6.0.60",
    "angular-universal-express-firebase": "0.0.4",
    "babel-preset-es2015": "^6.24.1",
    "codelyzer": "~3.1.1",
    "jasmine-core": "~2.6.2",
    "jasmine-spec-reporter": "~4.1.0",
    "karma": "~1.7.0",
    "karma-chrome-launcher": "~2.1.1",
    "karma-cli": "~1.0.1",
    "karma-coverage-istanbul-reporter": "^1.2.1",
    "karma-jasmine": "~1.1.0",
    "karma-jasmine-html-reporter": "^0.2.2",
    "npm-run-all": "^4.1.2",
    "protractor": "~5.1.2",
    "ts-loader": "^3.4.0",
    "ts-node": "~3.2.0",
    "tslint": "~5.3.2",
    "typescript": "^2.4.2",
    "webpack": "^3.8.1",
    "webpack-node-externals": "^1.6.0"
  }

}

You can try the following commands:

firebase use --add
firebase init functions

To get your project. Sometimes, its a permission problem. What you can try is creating a new account on your computer and doing the same commands, that almost always works.

Uncaught Error: Cannot find module "." · Issue #4921 · webpack , What is the current behavior? Below exception: polyfills.js:1 Error: Cannot find module "." at webpackMissingModule (eval at 148 (http://localhost:  In my case it is “ /usr/local/bin/npm ” and now note down the path. Navigate to the /usr/local with the help of finder/ explorer. You will find the folder called “lib” and within that “lib” folder you will be able to see node_modules folder, which is your global level module folder.

I handled this problem with these steps. I don't really know whether exact solution is delete and initialize firebase functions again. Also I thought that problem is not specific only firebase-functions or firebase-admin. It can be missing node_modules packages.

  1. delete node_modules in functions
  2. firebase init functions. Update tsconfig and package.json and install dependencies.
  3. restart vscode

Error: Cannot find module 'open' when running server · Issue #5 , scripts/web-server.sh module.js:340 throw err; ^ Error: Cannot find module 'open' at Function.Module._resolveFilename (module.js:338:15) at Function.Module. Error: Cannot find module 'C:\Users\Me\my_app.js'. then you are most likely trying to run the wrong file. It is possible you are missing a dependency that is needed from npm install, but if it says it cannot find the main file you are trying to run, then you are trying to run a file that does not exist.

npm install firebase-functions
npm install firebase-admin

How to solve "Error: Cannot find module '*.js'" with Node.js , Introduction. If you are trying to run your Node.js application and you get something like this: Error: Cannot find module 'C:\Users\Me\my_app.js'. This has nothing to do with not being able to find a module. this just means the angular cli module will be updated for any version 1.6.x – SanSolo Dec 20 '18 at 11:18 add a comment | 3

Error: Cannot find module [Solved] - Glitch Help, It's installed in the package.json but keeps throwing the error. Using this: https://​www.npmjs.com/package/aq3d module.js:491 throw err; ^ Error: Cannot find  The way how compiler resolves modules is controlled by moduleResolution option that can be either node or classic (more details and differences can be found here). If this setting is omitted the compiler treats this setting to be node if module is commonjs and classic - otherwise.

Cannot find Module *name*.js, Like if I type “~help” in discord, it says in the error long cannot find “help.js” even though it's there in the directory. Error: Cannot find module 'help.js'. Here is the  Find-Module returns the newest version of a module if no parameters are used that limit the version. To get a repository's list of a module's versions, use the parameter AllVersions. If the MinimumVersion parameter is specified, Find-Module returns the module's version that is equal to or greater than the minimum.

Error: Cannot Find Module, I can run the app from the command line without any issues. When I start the script from Max I get "Error: Cannot Find Module." I've run "script npm  In the above scenario, you go into the package.json file and change the value alongside ‘version’ to 1.0.0. However, there are a few potential causes of this problem, so if that doesn’t fix it then provide your project name and we can take a look for you.

Comments
  • Just one thought: what happens if you install the latest version of firebase-functions (which was subject to a major update in the last weeks, with release of V1.0)
  • While this code may answer the question, providing additional context regarding how and/or why it solves the problem would improve the answer's long-term value.