An error occurred while installing json (1.8.1), and Bundler cannot continue - Rails

an error occurred while installing json (2.2.0), and bundler cannot continue.
error installing json: error: failed to build gem native extension.
an error occurred while installing json (2.3.0), and bundler cannot continue.
could not find json-1.8 1 in any of the sources
an error occurred while installing sparsam 0.2 7 and bundler cannot continue
bundle install error json 1.8 3
failed to find gems/json 1.7 7
gem install json 1.8 3

An error occurred while installing json (1.8.1), and Bundler cannot continue. Make sure that gem install json -v '1.8.1' succeeds before bundling. xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

make failed, exit code 1

I know this has already been posted but i have tried bundle update, bundle install and putting the gem file in my gem file and bundle install but nothing works from the other answers.

ideas?

Running "bundle update" worked for me.

Error installing bundle (on json-1.8.1) · Issue #4462 · rubygems , 5 An error occurred while installing json (1.8.1), and Bundler cannot continue. Make sure that `gem install json -v '1.8.1'` succeeds before  I tried to run the bundle install command and I got the following errors. After reading some stackoverflow posts, I also ran bundle update. I am still getting the issue of json ~ 1.8.6 gem (I gues

You can try bundle update && bundle install. More on this here.

An error occurred while installing json (1.8.6), and Bundler cannot , 6), and Bundler cannot continue. Make sure that `gem install json -v '1.8.6'` succeeds before bundling #6178. I didn't say it would work. It will show you more verbose (and different) errors. Include the output of running the command on SSH here if you still want help. – max pleaner May 12 '16 at 2:36

A safer approach can be: bundle update json bundle install

What to Do When Bundle Install Fails with JSON 1.8.1, I cannot express my abject frustration at times with the Ruby ecosystem in general and What to Do When Bundle Install Fails with JSON 1.8.1 [​generator.o] Error 1 make failed, exit code 2 Gem files will remain installed in Posted In: #ruby #rails #json #gem #bundle #things_that_make_me_postal  Você recebeu essa mensagem porquê está inscrito no Google Groups "rails-br". Para enviar uma mensagem para o grupo, mande um email para rail@googlegroups.com Para se descadastrar, mande um e-mail para

Run the following in terminal:

xcode-select --install

Source

Getting following error An error occurred while installing json (1.8.1 , 1), and Bundler cannot continue. I am trying to create a new rails app test. But I am getting following error while running bundle install. An error  What to Do When Bundle Install Fails with JSON 1.8.1 Oct 11, 2016 I cannot express my abject frustration at times with the Ruby ecosystem in general and bundler in particular.

Remove your old Gemfile.lock file and run bundle again. A newer version of json should be installed.

error occurred while installing json (1.8.2) and bundler cannot , error occurred while installing json (1.8.2) and bundler cannot continue. Hello, i have a problem when i generate the rails app. I use the sane  💥The two solutions above are dangerous. Running bundle update will update all of your dependencies which may solve the problem but cause a host of other ones.. A safer solution would be to run bundle update json which in my case still crashed on kgio.

ruby - Can't install json 1.8.1, An error occurred while installing json (1.8.1), and Bundler cannot continue. April 14, 2017 How to Fix “Not able to install gem json -v '1.8.1'”. An error occurred while installing json (1.8.2), and Bundler cannot continue.Make sure tha

Error installing json 1.8.3 with ruby 2.4, An error occurred while installing json (1.8.6), and Bundler cannot continue · Rails · Sadaf_N September 21, 2018, 3:25pm #1. When i run 'bundle install  When bundle, I met errors below, but after I installs manually gem install minitest -v '4.7.5', I can install bundled gems completely. Is this bundler problem?

Unable to install Github-Pages with gem? 7 · Can't install Rails on Ubuntu 16.04 · 13 · Error: Failed to build gem native extension when trying to  ruby on rails - Can't access RubyGems - possibly due to SSL? ruby on rails - How to resolve bundle install rake error and An error occurred while install

Comments
  • This answer was already posted at least once. How is your solution any different? What makes it "safer"?